Results 1 to 6 of 6

Thread: Zimbra upgrade to network version, lost all email

  1. #1
    Join Date
    Mar 2010
    Posts
    4
    Rep Power
    5

    Default Zimbra upgrade to network version, lost all email

    Hi guys,

    wondering if you can offer some advice.

    We have upgraded our zimbra system from the open source version to the purchased Professional Network edition.

    The upgrade all went successfully other than during installation it complained about not being able to find the ZCSLicense.xml file, carried on with the installation, then installed the key through the admin console afterwards. All seemed to work successfully.

    Now the problem. After upgrade we have noticed that even though user mailboxes exist, all the old emails have disappeared. New emails are coming in fine, but user mailboxes that used to have hundreds of megs are now down to just a few megs from new incoming emails.

    We have tried to re-index mailboxes, but to no avail.

    Any advice appreciated.

    Thanks.

  2. #2
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    That sounds worrying. Check the size of the /opt/zimbra/store folder to see if it's as big as you'd expect, if its not then the mail is gone.

    If the size looks right, then you should be able to recover everything, I'd suggest contacting support and having them help, just incase anything I suggest makes it worse! My first feeling though would be to stop the services and run "/opt/zimbra/libexec/zmfixperms --extended" to see if that helps.

  3. #3
    Join Date
    Mar 2010
    Posts
    4
    Rep Power
    5

    Default

    Hiya Thanks for response.

    Yes checked under /opt/zimbra/store ran through terminal and folder for "0" and "incoming" went into "0" and lots of folders underneath, took folder "30" as a test and did an ls, full of .msg files so all files are there.

    I'm obviously not certain but it does sound like it's lost its symbiotic links with sql and has re-created new IDs for each user.

    We have contacted support and hoping to hear back from them soon, there was just that hope it was something really simple... no such luck it seems

    Stopping services was the first thing I did as soon as I realised, didn't want to confuse things by having new messages associated with a wrong ID.

    Might try the permission fix though.

    Thanks.

  4. #4
    Join Date
    Mar 2010
    Posts
    4
    Rep Power
    5

    Default

    Update:

    Ran zmfixperms as su and took about a minute to run.

    Ran "zmcontrol start" and checked the admin console for user quotas, still nothing unfortunately.

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Sounds to me like something when wrong with the upgrade; or there was a issue with the MySQL database and the integrity check fixed it and hence new emails are being recorded.

  6. #6
    Join Date
    Mar 2010
    Posts
    4
    Rep Power
    5

    Default

    I apologise in advance for this long post. This is more me kind of cataloguing exactly what we've tried and how it's going.


    Now understanding that under /opt/zimbra/store we have the folder "0" where messages are being stored. Under this folder we have lots more numbered folders. These numbered folders are representative of each users group_ID within SQL.

    Source:
    Zimbra Server - Zimbra :: Wiki
    Message Store

    The Zimbra Message Store is where all email messages reside, including the message body and any file attachments. Messages are stored in MIME format.

    The Message Store is located on each Zimbra server under
    /opt/zimbra/store. Each mailbox has a dedicated directory named after its internal Zimbra mailbox ID.
    I have managed to find out a users group_ID by following the below, found on the zimbra forums.

    http://www.zimbra.com/forums/adminis...tml#post163360
    Hi,

    I found the /opt/zimbra/bin/zmlmtpinject command.
    I discovered for this user that the mboxgroup is 10.

    My procedure to find mboxgroup.

    1) Get the user ID of the account in question.
    su - zimbra
    zmprov ga @domain.com zimbraId

    1) Login to mysql on the zimbra host
    mysql

    2) Change to zimbra database
    use zimbra;

    3) Find the group ID for the account
    select group_id from mailbox where account_id="";

    How do I use zmlmtpinject command?

    Best regards,
    Bibo
    After I had found a users Group_ID i went into their folder store, located the newest email via incremental numbering and opened using gedit to verify the email.
    This was the correct users folder.

    Afterwards I used mysql to search the directories as follows:

    Log on as su
    type su zimbra
    type mysql
    This will connect you with mysql, then continue as follows within sql

    SHOW databases;

    use mboxgroup"usergroupid"

    SHOW tables;

    SELECT * FROM mail_item;
    This came up with only 27 rows, showing that the sql had only catalogued the new emails and folders.

    I was then called by a technical advisor and he mentioned this wiki directory.

    Network Edition Moving from Open Source to Network Edition ZCS - Zimbra :: Wiki

    Which apparently tells you that you need to export data before running the upgrade. Which we had not done as had been led to believe that you just run the ./install.sh from the Network edition installer, which then gives you the option to upgrade.

    Right now it seems that we are going to have to look into restoring the data.

    Only problem is that after talking with tech support zimbra had an issue with no longer recognising the mysql command as a zimbra user. This has led us to a whole mess, and we are currently at the stage where we have uninstalled the network edition, re-installed the open source edition, copied back the contents of /opt/zimbra/ from a backup of the open source version, running /opt/zimbra/libexec/zmfixperms -extended and then zmcontrol start.

    We have managed to get back our old sql database with mboxes, which can locate 607 rows for the same user that previously only had 27.
    We cannot now access webadmin or webmail from the server, nor can we seem to get access to the server using telnet on port 143 (imap) or 110 (pop3) from any workstation.

    I'm now kind of stuck.

Similar Threads

  1. Replies: 8
    Last Post: 01-20-2009, 01:06 PM
  2. [SOLVED] parts_decode_ext error
    By jsabater in forum Administrators
    Replies: 7
    Last Post: 10-13-2008, 08:24 AM
  3. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  4. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  5. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 07:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •