Results 1 to 5 of 5

Thread: Can't send messages through Web Interface

Hybrid View

  1. #1
    Join Date
    Jul 2006
    Posts
    12
    Rep Power
    9

    Default Can't send messages through Web Interface

    I just recently upgraded from 3.1 to 3.2. I'm trying to send a message through the web interface but I keep getting a little pop-up window with a bunch of Java debug messages:


    msg - system failure: IOException
    com.zimbra.cs.service.ServiceException: system failure: IOException
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:174)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:279)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:119)
    at com.zimbra.cs.operation.SendMsgOperation.callback( SendMsgOperation.java:73)
    at com.zimbra.cs.operation.Operation.schedule(Operati on.java:190)
    at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg. java:109)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:261)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:162)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:159)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
    at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:541)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:667)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.io.IOException: Unable to rename /opt/zimbra/store/incoming/1154558765387-47.msg to /opt/zimbra/store/0/2/msg/4/18240-35500.msg
    at com.zimbra.cs.store.FileBlobStore.renameTo(FileBlo bStore.java:228)
    at com.zimbra.cs.mailbox.Mailbox.addMessageInternal(M ailbox.java:3121)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:2938)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:2910)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:183)
    ... 26 more

    code - service.FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Receiver




    any ideas?

    Thanks

  2. #2
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default quick questions

    Does the folder /opt/zimbra/store/0/2/msg/4/ exist? Is the disk full?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Jul 2006
    Posts
    12
    Rep Power
    9

    Default

    Yes that directory is there and no the disk is not full

  4. #4
    Join Date
    Jul 2006
    Posts
    12
    Rep Power
    9

    Default

    should the files under there be owned by root or zimbra?

  5. #5
    Join Date
    Jul 2006
    Posts
    12
    Rep Power
    9

    Default

    OK...its fixed!! Thanks to a step from wannabetenor from a previous post I did, I ran /opt/zimbra/libexec/zmfixperms and that seemed to have done the job.

    Thanks for all your help!

Similar Threads

  1. Error with sending email from web interface
    By Max Ma in forum Administrators
    Replies: 3
    Last Post: 07-26-2007, 11:44 PM
  2. Web interface rejecting e-mail
    By zachkarpinski in forum Installation
    Replies: 2
    Last Post: 06-20-2007, 11:49 AM
  3. Spam assassain not traiing properly!
    By Mike T in forum Administrators
    Replies: 1
    Last Post: 10-09-2006, 02:34 PM
  4. Comments and wishes for web interface
    By PNE in forum Administrators
    Replies: 2
    Last Post: 04-12-2006, 09:48 AM
  5. Outgoing mail and web interface
    By gazevedo in forum Installation
    Replies: 2
    Last Post: 10-26-2005, 12:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •