Results 1 to 3 of 3

Thread: [SOLVED] 5.0.23 upgrade hangs

  1. #1
    Join Date
    Apr 2007
    Rep Power

    Unhappy [SOLVED] 5.0.23 upgrade hangs

    I am upgrading a NE 5.0.15 release to 5.0.23. Everything was going fine until it reached "Upgrading Document templates...". That was 31 minutes ago and I'm starting to doubt it will come back.

    The system seems mostly idle and the last few lines in the zmsetup.log say:

    Thu Apr 8 22:19:36 2010 checking isEnabled zimbra-store
    Thu Apr 8 22:19:36 2010 zimbra-store is enabled
    Thu Apr 8 22:19:36 2010 Upgrading Document templates...
    Thu Apr 8 22:19:36 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov ut -h /opt/zimbra/wiki/Template

    Any suggestions? I'm thinking of killing the zmprov command so the install can move on but I'm worried there's a bigger issue here.

    BTW, we have few if any "Document" users on this system.

  2. #2
    Join Date
    Apr 2007
    Rep Power

    Default Killed it after 1 hour and 13 minutes

    As feared, there is a bigger issue here. I can access fine using IMAP but the web UI is not responding! I can't get to the admin UI either...

    Generated a stack trace of the zmprov java client by using kill -SIGQUIT pid:

    Full thread dump Java HotSpot(TM) 64-Bit Server VM (1.5.0_20-b02 mixed mode):
    "Low Memory Detector" daemon prio=1 tid=0x0000000050ab2fb0 nid=0x3352 runnable [0x0000000000000000..0x0000000000000000]
    "CompilerThread1" daemon prio=1 tid=0x0000000050ab1410 nid=0x3351 waiting on condition [0x0000000000000000..0x000000004191c4f0]
    "CompilerThread0" daemon prio=1 tid=0x0000000050aafef0 nid=0x3350 waiting on condition [0x0000000000000000..0x000000004181b520]
    "AdapterThread" daemon prio=1 tid=0x0000000050aae820 nid=0x334f waiting on condition [0x0000000000000000..0x0000000000000000]
    "Signal Dispatcher" daemon prio=1 tid=0x0000000050aad590 nid=0x334e runnable [0x0000000000000000..0x0000000000000000]
    "Finalizer" daemon prio=1 tid=0x0000000050a9a100 nid=0x334d in Object.wait() [0x0000000041f16000..0x0000000041f16e10]
    	at java.lang.Object.wait(Native Method)
    	- waiting on <0x00002b4d9cdf4b40> (a java.lang.ref.ReferenceQueue$Lock)
    	at java.lang.ref.ReferenceQueue.remove(
    	- locked <0x00002b4d9cdf4b40> (a java.lang.ref.ReferenceQueue$Lock)
    	at java.lang.ref.ReferenceQueue.remove(
    	at java.lang.ref.Finalizer$
    "Reference Handler" daemon prio=1 tid=0x0000000050a99920 nid=0x334c in Object.wait() [0x0000000041e15000..0x0000000041e15a90]
    	at java.lang.Object.wait(Native Method)
    	- waiting on <0x00002b4d9cc83ea8> (a java.lang.ref.Reference$Lock)
    	at java.lang.Object.wait(
    	at java.lang.ref.Reference$
    	- locked <0x00002b4d9cc83ea8> (a java.lang.ref.Reference$Lock)
    "main" prio=1 tid=0x00000000509fad20 nid=0x331c runnable [0x00007fffa0ddf000..0x00007fffa0de0270]
    	at Method)
    	- locked <0x00002b4da7b6f4f8> (a java.lang.Object)
    	- locked <0x00002b4da7b6f4a0> (a java.lang.Object)
    	- locked <0x00002b4da7b73be0> (a
    	- locked <0x00002b4da7b88f98> (a
    	at org.apache.commons.httpclient.methods.StringRequestEntity.writeRequest(
    	at org.apache.commons.httpclient.methods.EntityEnclosingMethod.writeRequestBody(
    	at org.apache.commons.httpclient.HttpMethodBase.writeRequest(
    	at org.apache.commons.httpclient.HttpMethodBase.execute(
    	at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(
    	at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(
    	at org.apache.commons.httpclient.HttpClient.executeMethod(
    	at com.zimbra.common.soap.SoapHttpTransport.invoke(
    	at com.zimbra.common.soap.SoapHttpTransport.invoke(
    	at com.zimbra.common.soap.SoapTransport.invoke(
    	at com.zimbra.common.soap.SoapTransport.invoke(
    	at com.zimbra.cs.account.soap.SoapProvisioning.invoke(
    	- locked <0x00002b4d9cd0d918> (a com.zimbra.cs.account.soap.SoapProvisioning)
    	at com.zimbra.cs.account.soap.SoapProvisioning.soapAdminAuthenticate(
    	at com.zimbra.cs.account.soap.SoapProvisioning.soapZimbraAdminAuthenticate(
    	at com.zimbra.cs.account.ProvUtil.initProvisioning(
    	at com.zimbra.cs.account.ProvUtil.main(
    "VM Thread" prio=1 tid=0x0000000050a95490 nid=0x334b runnable 
    "GC task thread#0 (ParallelGC)" prio=1 tid=0x0000000050a187c0 nid=0x3349 runnable 
    "GC task thread#1 (ParallelGC)" prio=1 tid=0x0000000050a19640 nid=0x334a runnable 
    "VM Periodic Task Thread" prio=1 tid=0x0000000050a0f720 nid=0x3353 waiting on condition
    After killing the zmprov process, the install completed except for an "Upgrading Document templates...failed." message.

  3. #3
    Join Date
    Apr 2007
    Rep Power

    Lightbulb Found problem with certificates

    Seeing errors in /var/log/zimbra.log

    Apr  9 00:39:47 zimbra-svc slapd[12072]: conn=280 op=0 STARTTLS
    Apr  9 00:39:47 zimbra-svc slapd[12072]: conn=280 op=0 RESULT oid= err=0 text=
    Apr  9 00:39:47 zimbra-svc slapd[12072]: conn=280 fd=19 closed (TLS negotiation failure)
    /opt/zimbra/bin/zmcertmgr deploycrt self
    and restarting seems to have fixed the problem. Ran
    zmprov ut -h /opt/zimbra/wiki/Template
    manually to complete missing install step.

Similar Threads

  1. [SOLVED] Upgrade to 6.0.4 hangs: Starting mysql...
    By faizel in forum Administrators
    Replies: 4
    Last Post: 07-31-2010, 02:08 PM
  2. Zimbra Admin console hangs after 6.0.5 upgrade
    By lindsey in forum Administrators
    Replies: 5
    Last Post: 03-17-2010, 07:41 PM
  3. Upgrade hangs @ starting mysql
    By billzeta in forum Installation
    Replies: 10
    Last Post: 05-27-2008, 11:31 AM
  4. Upgrade 4.5.3 -> 4.5.6 failed: ldap hangs
    By sm3.142 in forum Installation
    Replies: 2
    Last Post: 07-05-2007, 02:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts