Results 1 to 3 of 3

Thread: [SOLVED] Zimbra 6.0.5 and NFS

  1. #1
    Join Date
    Apr 2010
    Posts
    6
    Rep Power
    5

    Default [SOLVED] Zimbra 6.0.5 and NFS

    after attempting 3 installs of ZCS (one of the network trial, and twice with the open source), I'm pretty sure I've got all the install wrinkles ironed out. Notably Ubuntu 8.04 LTS Server (Hardy Heron) Install Guide - Zimbra :: Wiki and
    http://www.zimbra.com/forums/install...-04-users.html


    I suspect, after reading the zimbra.log files, and googling for the key words, that these two bugs might be related to my problem:
    Bug 33221 – Need clarity on supporting nfs mounted zimbra directories - report error/msg if nfs mount is present
    Bug 15217 – disk space check does not account for multiple mounts on /opt/zimbra

    I have /opt mounted on an NFS share on my NAS server. Since Zimbra is running in a VM on a host optimized for VMs (and not disk storage, nor backup) can anyone please confirm or deny that the current version(*) of ZCS DOES NOT WORK WITH /opt mounted on an NFS export/share?

    And if it does work, can someone please inform me of the best way to get help understanding the various errors in zimbra.log?

    Thanks in advance!
    d.
    (*)zcs-6.0.5_GA_2213.UBUNTU8_64.20100203012906.tgz

    PS
    here's the reason I suspect NFS from the logs:
    Apr 14 13:27:54 zimhost zimbramon[5311]: 5311:info: Availble disk space on /opt/zimbra is below threshold of 100. Mbytes available.
    The zimbra user can operate on /opt/zimbra, and there is lots of space. Here's the real situation:
    Code:
    zimbra@zimhost:~$ df -B M 
    Filesystem                      1M-blocks Used   Available Use% Mounted on
    /dev/mapper/zimbra--host-root    19188M   1261M   16960M   7%   /
    varrun                             503M      1M     503M   1%   /var/run
    varlock                            503M      0M     503M   0%   /var/lock
    udev                               503M      1M     503M   1%   /dev
    devshm                             503M      0M     503M   0%   /dev/shm
    192.168.254.1:/data/zimbra-test 203187M   6931M  186016M   4%   /opt
    /dev/sda1                          236M     45M     179M  20%   /boot
    The ownership of directories and files within /opt/zimbra is a mix of root and zimbra. This is 'as-installed'.

  2. #2
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    Hi Derek,

    Welcome to the forums!

    There are a number of posts in these forums regarding NFS mounts, and while some have gotten them to work just fine, the general consensus is that NFS mounts should not be used for /opt/zimbra. There is some Zimbra documentation (I believe in the wiki) which also speaks to this and gives reasons why NFS can be problematic.

    We have clients running (non-Zimbra) LAMP stacks with very intensive MySQL usage, where all the MySQL bits are on NFS shares and they work just fine.

    We tried NFS a few years ago with Zimbra and did not have success, so we abandoned it and stick to block-level storage only.

    Hope that helps,
    Mark

  3. #3
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Posts
    291
    Rep Power
    10

    Default

    Yeah it was made pretty clear to us in the Zimbra Advanced Training course, that NFS for /opt/zimbra was a bad idea. You may be able to use NFS for HSM volumes, and you can use NFS for /opt/zimbra/backup. This was said by a few guys pretty high up in Zimbra support, and I can see why from a technical level that is the case. There are just too many bits that require normal filesystem support.
    Have you considered iSCSI? Don't know if your NAS supports it, but more and more are these days.
    http://www.solutionsfirst.com.au/hosting/zimbra/
    Australia's premier Zimbra Hosting Partner
    Resellers wanted!

Similar Threads

  1. Slow Sending Messages with Zimbra?
    By Diranged in forum Administrators
    Replies: 5
    Last Post: 08-22-2010, 01:51 AM
  2. backup space issue after migration to 6.0.2
    By maumar in forum Administrators
    Replies: 1
    Last Post: 01-06-2010, 11:46 PM
  3. Replies: 0
    Last Post: 06-12-2009, 12:19 PM
  4. Zimbra Collaboration Suite rPath Appliance and NFS
    By clincoln in forum Administrators
    Replies: 2
    Last Post: 06-26-2007, 05:43 AM
  5. Zimbra Cluster + NFS
    By KenVM in forum Installation
    Replies: 4
    Last Post: 06-12-2007, 08:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •