Results 1 to 3 of 3

Thread: [SOLVED] have zimbra web access listen on port 444 but create normal https download l

  1. #1
    Join Date
    Nov 2009
    Posts
    3
    Rep Power
    6

    Smile [SOLVED] have zimbra web access listen on port 444 but create normal https download l

    hi!

    my setup is as follows:
    zimbra web access listens on port 444. as frontend i have apache, listening on port 443 in ssl mode, mod proxy forwards the requests to zimbra.

    the problem with this is, that download links (such as in the briefcase) are generated as
    "https://ssl.domain.com:444/home/user@domain.com/Briefcase/some.file?disp=a"

    since many companies only allow outbound http and and https traffic, to acces downloads i always need to remove the port from the URL to be able to access files:
    "https://ssl.domain.com/home/user@domain.com/Briefcase/some.file?disp=a"

    is it possible to instruct zimbra to generate links without port number or with a different port number than the one it listens on?


    thank you very much for any ideas!

  2. #2
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    You could try messing with the settings zimbraPublicServiceHostname, zimbraPublicServiceProtocol, and zimbraPublicServicePort. These can be changed at a global or domain level. It might affect more than the briefcase, i.e. public calendar shares but maybe you want that too.

  3. #3
    Join Date
    Nov 2009
    Posts
    3
    Rep Power
    6

    Smile

    Quote Originally Posted by bdial View Post
    You could try messing with the settings zimbraPublicServiceHostname, zimbraPublicServiceProtocol, and zimbraPublicServicePort. These can be changed at a global or domain level. It might affect more than the briefcase, i.e. public calendar shares but maybe you want that too.
    thanks a lot, this worked perfectly! for future readers of this thread i would like to add, that setting only the zimbraPublicServicePort parameter had no effect, only when i set all of them i got the expected result.

    thank you very much again!

Similar Threads

  1. Fresh Zimbra installation does not work
    By Datax in forum Installation
    Replies: 4
    Last Post: 08-18-2008, 02:18 PM
  2. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 09:21 AM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •