Results 1 to 3 of 3

Thread: [SOLVED] Zimbra upgrade V5->V6, centos 5.4 final problems

  1. #1
    Join Date
    Apr 2010
    Rep Power

    Default [SOLVED] Zimbra upgrade V5->V6, centos 5.4 final problems

    I've tried to upgrade zimbra vrom V5 to V6 with this package:
    First I've updated centos from 5.0 to the actual 5.4. : yum install all went fine zibmra continued working.
    then I've installed zimbra: ./ --platform-override
    Now I've get errors:
    1. Tue Apr 20 21:14:34 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov -m -l -- mcf zimbraReverseProxyMailEnabled TRUE
    Exception in thread "Thread-2" java.lang.OutOfMemoryError: Java heap space
    at 58)

    2: Tue Apr 20 21:35:22 2010 Running /opt/zimbra/bin/zmprov -m -l gas mailbox
    Tue Apr 20 21:35:27 2010 Checking for default IM conference room...
    Tue Apr 20 21:35:27 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov -m -l -- gxc
    Exception in thread "main" java.lang.NullPointerException
    at com.zimbra.cs.account.ProvUtil.dumpXMPPComponent(P
    at com.zimbra.cs.account.ProvUtil.doGetXMPPComponent(
    3. Tue Apr 20 21:53:36 2010 Removing com_zimbra_search
    Tue Apr 20 21:53:36 2010 *** Running as zimbra user: /opt/zimbra/bin/zmzimletctl undeploy com_zimbra_search
    [] INFO: I/O exception ( caught when processing request: Connection refused
    [] INFO: Retrying request
    com.zimbra.common.zclient.ZClientException: invoke Connection refused, server: localhost
    at com.zimbra.common.zclient.ZClientException.IO_ERRO R(
    at com.zimbra.cs.account.soap.SoapProvisioning.invoke (
    at com.zimbra.cs.account.soap.SoapProvisioning.soapAd minAuthenticate(
    at com.zimbra.cs.zimlet.ZimletUtil$ZimletSoapUtil.ini tZimletSoapUtil(
    at com.zimbra.cs.zimlet.ZimletUtil$ZimletSoapUtil.(
    at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUti
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.ja va:1888)
    Caused by: Connection refused
    4. Starting imapproxy...Failed.
    Starting nginx...2010/04/20 21:51:21 [emerg] 7770#0: SSL_CTX_use_certificate_chain_file("/opt/zimbra/conf/nginx.crt") failed (SSL: error:02001002:system library:fopen:No such file or directory error:20074002:BIO routines:FILE_CTRL:system lib error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:sys)

    Any help is very appreciated. If you need the full zmsetup log file please send me a email to
    Thank you

  2. #2
    Join Date
    Nov 2006
    Rep Power


    Welcome to the forums

    Exception in thread "Thread-2" java.lang.OutOfMemoryError: Java heap space
    How much memory does your Zimbra server have ?

  3. #3
    Join Date
    Apr 2010
    Rep Power

    Default Mailbox memory amount (mailboxd_java_heap_memory_percent)

    Thanks for the welcome
    Do you refer to the config value:
    mailboxd_java_heap_memory_percent = 30
    So, I suppose this is not enough (the machine has 1024MB)
    So I will increase this value to 50
    Solved the Problem:
    1. more memory
    2. had to generate the certificates manually
    Last edited by wbk; 04-23-2010 at 02:36 PM.

Similar Threads

  1. [SOLVED] Postfix unavailable - queue down
    By pmona in forum Administrators
    Replies: 20
    Last Post: 01-21-2010, 10:03 PM
  2. Replies: 1
    Last Post: 04-02-2009, 11:43 AM
  3. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  4. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts