Results 1 to 3 of 3

Thread: [SOLVED] Still working on broken logger.

  1. #1
    Join Date
    Mar 2006
    Posts
    300
    Rep Power
    9

    Default [SOLVED] Still working on broken logger.

    This is 6.0.6 on SLES10.

    The strange thing is if I run
    zmlogswatchctl start
    zmstatctl start

    then run

    zmcontrol status

    everything shows as running.

    If I go into admin console and access server stats I get:

    Message: system failure: Unable to read logger stats Error code: service.FAILURE Method: GetLoggerStatsRequest Details:soap:Receiver

    Also all server status in Admin console shows red X.
    There is nothing in the logs, zmlogswatch.out is empty.
    I see PID files for logswatch and swatch.

    Zmswatch.out has a blurb in it that it is running.

    Inside startup.log I see:
    no connection to syslog available
    -unix dgram connect: Connection refused at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 44

    Any help appreciated.

    ******I am unsure, but it appears that the logger stats may be ending up in /var/log/messages and /var/log/localmessages.*****
    Sure looks like stats data in there.

    ***Tally of results from 5.0.9 to 6.0.6 upgrade
    1) Logger borked.
    2) Clam/Amavisd rejects all mail.

    Presently I have Logger, Antivirus and Antispam services disabled.
    Fortunately I have an AV/Antispam solution in front of my Zimbra server anyway.

    I am considering rerunning install.sh and see if it can patch up what is wrong.
    Last edited by tgx; 04-23-2010 at 03:26 PM.

  2. #2
    Join Date
    Mar 2006
    Posts
    300
    Rep Power
    9

    Default

    Quote Originally Posted by vavai View Post
    Hi Tgx,

    Did you solve your problem ? I'm facing same problem, zcs 6.0.6 on SLES 10 32 bit. Actually, zcs 6.0.6 working successfully on SLES 11 64 bit.
    No. It is still broken. Mine is also 32bit.
    I have disabled the logger. In the past I've had to run without
    it until some miracle update fixes it. Is your AS/AV working?
    Mine is blocking all emails so it is also disabled. Fortunately
    for that issue I have another solution in front of the Zimbra
    server so not really an issue.

  3. #3
    Join Date
    Mar 2006
    Posts
    300
    Rep Power
    9

    Default

    Follow this thread to fix the logger issue:

    http://www.zimbra.com/forums/install...9-6-0-6-a.html

Similar Threads

  1. [SOLVED] Another logger not working thread
    By TheCowStir in forum Administrators
    Replies: 6
    Last Post: 03-05-2010, 08:23 AM
  2. Logger not working
    By fsoares in forum Administrators
    Replies: 1
    Last Post: 12-10-2009, 10:37 AM
  3. Replies: 3
    Last Post: 11-10-2009, 11:47 AM
  4. Ubuntu VServer logger not working
    By cshepherd in forum Installation
    Replies: 12
    Last Post: 11-14-2006, 03:33 AM
  5. Logger not working in 4.0 RC1
    By jdell in forum Administrators
    Replies: 11
    Last Post: 08-24-2006, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •