Results 1 to 3 of 3

Thread: [SOLVED] Correct procedure for restore, help!

  1. #1
    Join Date
    Mar 2010
    Rep Power

    Unhappy [SOLVED] Correct procedure for restore, help!

    I'm using the this script for backing up (the simple Simple Shell Script Method)

    Open Source Edition Backup Procedure - Zimbra :: Wiki

    I wanted to test a restore, so I setup a a new Linux server and installed the same version of ZCS: Release 6.0.6_GA_2324.UBUNTU8 UBUNTU8 FOSS edition.
    Identical installation on the new server, the only different things were the server IP address and maybe password for the admin user. No problem during the installation.
    The new installation works correctly.
    Then, for the restore:
    I stopped ZCS, and followed these steps (mail.backup.tgz is my backup):

    mv /opt/zimbra /opt/zimbra-old
    mkdir /opt/zimbra
    tar zxvf /var/tmp/mail.backup.tgz -C /opt/zimbra
    chown -R zimbra:zimbra /opt/zimbra

    This the result, after rebboting the server:

    antispam Stopped
    zmmtaconfigctl is not running
    zmamavisdctl is not running
    antivirus Stopped
    zmmtaconfigctl is not running
    zmamavisdctl is not running
    zmclamdctl is not running
    ldap Stopped
    logger Stopped
    zmlogswatchctl is not running
    mailbox Stopped
    zmmtaconfigctl is not running.
    mysql.server is not running.
    zmmailboxdctl is not running.
    mta Stopped
    zmmtaconfigctl is not running
    postfix is not running
    zmsaslauthdctl is not running
    snmp Stopped
    zmswatch is not running.
    stats Stopped

    What could have gone wrong?

    This procedure has worked for me several times, the only difference this time was that I used a differente IP address and maybe a different admin password. Could this be the problem or my backup was bad?
    Of course things always work in a test environment, then stop to work in a production environment ...
    Simone from italy

  2. #2
    Join Date
    Nov 2006
    Rep Power


    Perhaps you could check for some error messages in your logfiles ? Also ensure that none of the ports Zimbra requires are already in use. Shutdown Zimbra and the start again and once up check /var/log/zimbra.log and /opt/zimbra/log/mailbox.log to see what it is doing.

  3. #3
    Join Date
    Mar 2010
    Rep Power


    Thanks for replying. Maybe there was something wrong with the backup. I
    added the following line to the backup script (it is commented on the script by Daniel W. Martin)

    ps auxww | awk '{print $1" "$2}' | grep zimbra | kill -9 `awk '{print $2}'`

    Now it the restore seems to be ok.
    Maybe processes were not completely killed...I don't know. Thanks

Similar Threads

  1. Replies: 12
    Last Post: 11-04-2009, 11:29 PM
  2. Correct outlook config
    By carnold in forum Administrators
    Replies: 2
    Last Post: 10-07-2009, 03:40 AM
  3. Correct server shutdown technique
    By nufan in forum Installation
    Replies: 1
    Last Post: 04-29-2009, 11:25 AM
  4. Correct way to move domains?
    By lisap in forum Administrators
    Replies: 11
    Last Post: 02-24-2008, 10:33 PM
  5. Correct Installation procedure?
    By ikmsupport in forum Installation
    Replies: 3
    Last Post: 10-15-2006, 08:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts