Results 1 to 3 of 3

Thread: perl not recognized

  1. #1
    Join Date
    May 2010
    Rep Power

    Post perl not recognized

    I am attempting to install zimbra onto Ubuntu Hardy 8.04 x64 bit edition using this tarball:

    However when I run the install script I get this error:

    Press Return to continue
    Checking for prerequisites...
         FOUND: NPTL
         FOUND: sudo-1.6.9p10-1ubuntu3.7
         FOUND: libidn11-1.1-1
         FOUND: libpcre3-7.4-1ubuntu2.1
         FOUND: libgmp3c2-2:4.2.2+dfsg-1ubuntu2
         FOUND: libexpat1-2.0.1-0ubuntu1.1
         FOUND: libstdc++6-4.2.4-1ubuntu4
         MISSING: libstdc++5
         MISSING: libltdl3
         FOUND: libperl5.8-5.8.8-12ubuntu0.4
    Checking for suggested prerequisites...
         perl-5.8.8 does not appear to be installed.
    ./install is reporting that perl-5.8.8 is not installed, when it in fact is...

    root@cloud5:/home/bluethundr# perl -v
    This is perl, v5.8.8 built for x86_64-linux-gnu-thread-multi
    Copyright 1987-2006, Larry Wall
    Perl may be copied only under the terms of either the Artistic License or the
    GNU General Public License, which may be found in the Perl 5 source kit.
    Complete documentation for Perl, including FAQ lists, should be found on
    this system using "man perl" or "perldoc perl".  If you have access to the
    Internet, point your browser at, the Perl Home Page.

    How can I get around this error? Thanks!
    Last edited by bluethundr_; 05-14-2010 at 11:41 AM.

  2. #2
    Join Date
    Nov 2006
    Rep Power


    Have you tried looking at the install script to see what it is looking for ? Why are you trying to install version 5; is this a new installation ?

  3. #3
    Join Date
    May 2010
    Rep Power

    Default libperl-dev

    Quote Originally Posted by knudfl View Post
    Quite simple : Perl is not installed.

    You only have a small part of it. ( I guess.)

    sudo apt-get install libperl-dev
    ... will probably do.
    This was the answer.. from LinuxQ...

Similar Threads

  1. Perl 5.10 Support
    By andu in forum Migration
    Replies: 0
    Last Post: 06-03-2009, 12:29 AM
  2. Installing on CentOS
    By jfha73 in forum Installation
    Replies: 8
    Last Post: 09-27-2008, 09:48 AM
  3. ubuntu perl problem
    By mahmoud in forum Installation
    Replies: 1
    Last Post: 06-10-2008, 10:54 AM
  4. Replies: 2
    Last Post: 08-12-2007, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts