Results 1 to 8 of 8

Thread: [SOLVED] a little bump in the zimbra road

  1. #1
    Join Date
    May 2010
    Posts
    15
    Rep Power
    5

    Post [SOLVED] a little bump in the zimbra road

    I am trying to setup an MTA server in a zimbra cluster. I have set the postfix and amavis users passwords but in the install screen they are listed as "Not Verified".


    How do I get past this point?

    Code:
       2) zimbra-mta:                              Enabled                       
            +MTA Auth host:                        cloud5.example.com         
            +Enable Spamassassin:                  yes                           
            +Enable Clam AV:                       yes                           
            +Notification address for AV alerts:   admin@cloud5.example.com   
    ******* +Bind password for postfix ldap user:  Not Verified                  
    ******* +Bind password for amavis ldap user:   Not Verified
    Last edited by bluethundr_; 05-21-2010 at 04:47 AM.

  2. #2
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    you should be able to get these from the localconfig on your ldap server

    Code:
    zmlocalconfig -s | grep ldap_postfix_password
    zmlocalconfig -s | grep ldap_amavis_password

  3. #3
    Join Date
    May 2010
    Posts
    15
    Rep Power
    5

    Exclamation another small bump in the road

    ah! thanks for hipping me to zmlocalconfig!

    I was able to set the ldap_postfix_password and ldap_amavis_password respectively.

    however I ran into a new wrinkle. Turns out I have to set the overall ldap password as well and that just ain't happening.

    Code:
    zimbra@cloud3:~$ zmlocalconfig -e zimbra_ldap_password=myPass
    Error: can not edit key zimbra_ldap_password

    May I have a hint as to how to proceed?

  4. #4
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    you can edit the file manually /opt/zimbra/conf/localconfig.xml to modify that entry

  5. #5
    Join Date
    May 2010
    Posts
    15
    Rep Power
    5

    Exclamation still on the bump

    hmm.. ok I was able to set the password in the specified file on the ldap server (cloud3)

    Code:
    zmlocalconfig -s | zimbra_ldap_password
    
    zimbra_ldap_password = myPass
    And over on cloud4 (my mailbox host) I am still stuck on verifying the ldap password

    Code:
    Common configuration
    
       1) Hostname:                                example.com                
       2) Ldap master host:                        cloud3.example.com         
       3) Ldap port:                               389                           
    ** 4) Ldap Admin password:                     Not Verified                  
       5) LDAP Base DN:                            cn=zimbra                     
       6) Secure interprocess communications:      yes                           
       7) TimeZone:                                America/New_York
    I even went so far as to add each server in the local DNS zone files of each machine and no dice...

  6. #6
    Join Date
    May 2010
    Posts
    15
    Rep Power
    5

    Post ldap telnet test

    This is getting weirder and weirder. I have verified that LDAP is reachable on the LDAP host by telnetting to it from the mailbox host:

    Code:
    root@cloud4:~# telnet cloud3.example.com 389
    Trying 123.45.67.67...
    Connected to cloud3.example.com.
    Escape character is '^]'.
    And I have further verified the fact that ldap is running on the ldap host with with command.

    Code:
    zimbra@cloud3:~$ ps -ef | grep zimbra | grep slapd
    zimbra    2973     1  0 May20 ?        00:00:11 /opt/zimbra/openldap/sbin/slapd -l LOCAL0 -4 -u zimbra -h ldap://cloud3.example.com:389 ldapi:/// -F /opt/zimbra/data/ldap/config
    zimbra   27784 12789  0 07:40 pts/0    00:00:00 grep slapd
    Yet this condition persists and it's driving me nuts!!!

    Code:
    1) Common Configuration:                                                  
            +Hostname:                             example.com                
            +Ldap master host:                     cloud3.example.com         
            +Ldap port:                            389                           
    ******* +Ldap Admin password:                  Not Verified                  
            +LDAP Base DN:                         cn=zimbra                     
            +Secure interprocess communications:   yes                           
            +TimeZone:                             America/New_York
    Last edited by bluethundr_; 05-21-2010 at 06:11 AM.

  7. #7
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    when you set it in the file, you're not setting the actual password you're setting the password zimbra will use to bind to the ldap server with. the actual password is encrypted and stored within the ldap database.

    the password in the localconfig.xml on the ldap server should be whats in the database, but if it isn't you can always go about resetting it

    first on hte ldap server do

    Code:
    zmldappasswd yournewpassword
    then update teh zimbra_ldap_password in the localconfig.xml of every server in your multiserver install iwth hte new password, it may require restarting the services as well.

  8. #8
    Join Date
    May 2010
    Posts
    15
    Rep Power
    5

    Lightbulb eureeka!

    dude.. you're brilliant... it's working (finally).. and thank you!

    tim

Similar Threads

  1. Zimbra spam system
    By rajahd in forum Administrators
    Replies: 9
    Last Post: 04-16-2008, 07:25 PM
  2. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •