Results 1 to 3 of 3

Thread: DNS lookup does not check /etc/hosts

  1. #1
    Join Date
    Jun 2010
    Posts
    1
    Rep Power
    5

    Default DNS lookup does not check /etc/hosts

    My zimbra server sits in a DMZ with a non-public IP. Ports are forwarded
    to the server from a virtual IP address on the firewall. There are DNS/MX
    records for public virtual IP address but there is no DNS
    record for the non-public DMZ IP address but it is listed in /etc/hosts.

    Mail sent to the server is bounced back to the sender with the
    error "Host or domain name not found. Name service error ..."
    trying to lookup the local mail host name.

    Any solution to this short of running bind on the zimbra server
    just so that the local host name will resolve ??

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by sjadams View Post
    My zimbra server sits in a DMZ with a non-public IP. Ports are forwarded
    to the server from a virtual IP address on the firewall. There are DNS/MX
    records for public virtual IP address but there is no DNS
    record for the non-public DMZ IP address but it is listed in /etc/hosts.

    Mail sent to the server is bounced back to the sender with the
    error "Host or domain name not found. Name service error ..."
    trying to lookup the local mail host name.

    Any solution to this short of running bind on the zimbra server
    just so that the local host name will resolve ??
    Postfix requires that you have an A & MX record for the server, it will deliver it's mail after doing a DNS lookup.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    Have you tried a split dns setup using bind? There's lots about that in the forums...

Similar Threads

  1. [SOLVED] DNS Lookup
    By openx in forum Installation
    Replies: 3
    Last Post: 05-07-2009, 06:16 AM
  2. [SOLVED] Amavisd-Postfix RCPT TO Takes a long time
    By samuraii in forum Administrators
    Replies: 8
    Last Post: 02-11-2009, 03:34 PM
  3. Check your DNS - Word to the Wise
    By dwmtractor in forum Administrators
    Replies: 5
    Last Post: 08-14-2008, 04:38 PM
  4. :( DNS Lookup issues
    By jhgutierrezg in forum Administrators
    Replies: 3
    Last Post: 05-30-2007, 09:00 AM
  5. Quick DNS check
    By phoenix in forum Administrators
    Replies: 0
    Last Post: 04-25-2006, 09:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •