Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: zimbra_url - balloon but no preview

  1. #1
    Join Date
    Aug 2006
    Location
    Somerset, UK
    Posts
    22
    Rep Power
    9

    Default zimbra_url - balloon but no preview

    OS = FC4
    ZCS = 3.1.4_GA_518
    RAM = 1Gb physical / 2Gb swap

    I have two installs of ZCS, one on my server (above) and the other is the FC4 vmware instance downloaded from yourselves. I have also upgraded the vmware instance with the latest beta ZCS4.-RC1 for FC4.

    My problem is that the zimlet url is not working in both instances of ZCS. The URL's are highlited correctly and the popup ballon does show - but I never see any previews.

    The live server is running over https(port 10443) and the vmware is default http. I know the preview is supposed to only show http url's which I why I tested the vmware version running on http.

    My browser is the Firefox 1.5.0.2.

    Any suggestions as to how to debug this, out of interest the jscipt debugger in firefox does not show any error.

    Below is the output of zmzimletctl on my live server:

    [zimbra@gw ~]$ zmzimletctl listZimlets
    Installed Zimlet files on this host:
    com_zimbra_amzn
    com_zimbra_phone
    com_zimbra_tracking
    com_zimbra_url
    com_zimbra_wikipedia
    com_zimbra_xslt
    com_zimbra_ymaps
    Installed Zimlets in LDAP:
    com_zimbra_amzn
    com_zimbra_phone
    com_zimbra_tracking
    com_zimbra_url
    com_zimbra_wikipedia
    com_zimbra_xslt
    com_zimbra_ymaps
    Available Zimlets in COS:
    default:
    com_zimbra_amzn
    com_zimbra_phone
    com_zimbra_tracking
    com_zimbra_url
    com_zimbra_wikipedia
    com_zimbra_xslt
    com_zimbra_ymaps


    Thanks,
    David.

  2. #2
    Join Date
    Aug 2006
    Location
    Somerset, UK
    Posts
    22
    Rep Power
    9

    Default

    I just tried to see the zimlet in Firefox 1.5.0.5 running on XP Pro and still the same issue, balloon but no preview,

    Thanks.
    David

  3. #3
    Join Date
    Aug 2006
    Posts
    3
    Rep Power
    9

    Default Re: zimlet URL issue

    I'm having the same problem with my new install too.

    Phil

  4. #4
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default This may be an Alexa issue...

    Alexa provides webpage thumbnails, and this may be an issue with their service. We'll take a look.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Join Date
    Mar 2006
    Posts
    14
    Rep Power
    9

    Default Same issue.

    New install...same issue. Any fix yet?

  6. #6
    Join Date
    Sep 2005
    Posts
    55
    Rep Power
    10

    Default

    It looks like Alexa thumbnails has become a fee-based Amazon web service:

    http://www.amazon.com/gp/browse.html?node=236156011

    The URL that our code uses to fetch the thumbnails (from pthumbnails.alexa.com) is no longer valid, so you get a connection error and a blank canvas.

    I'm not sure what our plans are with regard to the Amazon service. Nothing in the short term, I imagine. The best thing to do for now is to disable the URL zimlet.

    -Conrad
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Doesn't disabling that zimlet also disable the one-click launch of the link? Usefule for getting to the forums posts.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    This sucks. Introduce a service, let people start to use it and then turn it off and tell everyone they need to pay to get it back. Like Amazon dont make enough money already.

    I didnt need another reason to stay away from Amazon (paying extra for next day delivery and having the goods arrive 5 weeks later was more than enough for that, but that's another story). This just makes them look cheap in my eyes.

    So, suggestions.

    1. Contact google, they do everything else, I wonder if they want a piece of the website thumbnailing market?

    2. Do it locally. When a zimbra user hovers a link, the zimbra server checks itself to see if it knows the domain, shows the picture if it's seen it before and gets the image if it hasnt. It could be reactive rather than proactive, as most of the links people get tend to be from the same place anyway, after a few weeks it would have most previews it would need. Image size is small so overhead and diskspace could be quite minimal.

    Any others?

  9. #9
    Join Date
    Oct 2005
    Location
    Belgium
    Posts
    68
    Rep Power
    10

    Default

    2. Do it locally. When a zimbra user hovers a link, the zimbra server checks itself to see if it knows the domain, shows the picture if it's seen it before and gets the image if it hasnt. It could be reactive rather than proactive, as most of the links people get tend to be from the same place anyway, after a few weeks it would have most previews it would need. Image size is small so overhead and diskspace could be quite minimal.
    I wouldn't do that, if a user then receives a spam message with a coded URL that spammers can track, then they would know if the email address realy exists.
    The user doesn't have to click then on the link but just hover the link could be painful, and de spammer know.

  10. #10
    Join Date
    Jul 2006
    Location
    Australia, ACT
    Posts
    197
    Rep Power
    9

    Default Disappointed

    Quote Originally Posted by cdamon
    It looks like Alexa thumbnails has become a fee-based Amazon web service:

    http://www.amazon.com/gp/browse.html?node=236156011

    The URL that our code uses to fetch the thumbnails (from pthumbnails.alexa.com) is no longer valid, so you get a connection error and a blank canvas.

    I'm not sure what our plans are with regard to the Amazon service. Nothing in the short term, I imagine. The best thing to do for now is to disable the URL zimlet.

    -Conrad
    This is very disappointing guys. Why not simply include this functionality as part of the Zimbra server?

Similar Threads

  1. Double click on email with preview pane visible
    By kristian.penno in forum Users
    Replies: 3
    Last Post: 06-19-2007, 09:33 PM
  2. Zimbra ALE and a new preview demo
    By KevinH in forum Announcements
    Replies: 18
    Last Post: 06-20-2006, 05:31 PM
  3. Preview pane question?
    By pshelton in forum Users
    Replies: 3
    Last Post: 06-10-2006, 05:45 PM
  4. Email not showing, Preview pane on the loose
    By Kafka in forum Administrators
    Replies: 14
    Last Post: 02-22-2006, 03:31 PM
  5. Replies: 1
    Last Post: 02-07-2006, 07:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •