Results 1 to 2 of 2

Thread: [SOLVED] Unable to add Domains to System

  1. #1
    Join Date
    Sep 2008
    Posts
    9
    Rep Power
    7

    Default [SOLVED] Unable to add Domains to System

    I recently discovered that I am unable to add any additional domains to either of the two zimbra servers I administer. I have attempted to do so both via Admin UI and via CLI. The errors are essentially the same either way.

    Server error encountered Message: system failure: unable to get globalgrant Error code: service.FAILURE Method: CreateDomainRequest Details:soap:Receiver

    I was running version 6.0.6, and attempted to upgrade to 6.0.7 hoping it would resolve the issue. Instead what I found was that zmldapapplydif was failing in the install/upgrade process.

    A peek at the install log shows the following:

    Tue Jul 6 23:58:13 2010 Running zmldapapplyldif...
    Tue Jul 6 23:58:13 2010 *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    Can't load '/opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/SSLeay.so' for module Net::SSLeay: libssl.so.0.9.8: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230.
    at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 18
    Compilation failed in require at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 18.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 18.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 1005.
    Tue Jul 6 23:58:23 2010 failed.

    I checked the file permissions on every folder in the /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/SSLeay.so path, and they are all r-x for all users. (including the SSLeay.so file itself). I can't see why it would be unable to access it.

    I am assuming that my unable to get a global grant is related to this error, but I have no idea how to resolve it so far.

    Server is CentOS5 32-bit.

    Thanks in advance!

    -Benjamin

  2. #2
    Join Date
    Sep 2008
    Posts
    9
    Rep Power
    7

    Default Resolution

    I was able to find and successfully test a resolution to this problem.

    Although the SSLeay.so file was in-fact readable, it linked to a non-existant folder.


    [root@mail ~]# readelf -d /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/SSLeay.so

    Dynamic section at offset 0x55014 contains 25 entries:
    Tag Type Name/Value
    0x00000001 (NEEDED) Shared library: [libssl.so.0.9.8]
    0x00000001 (NEEDED) Shared library: [libcrypto.so.0.9.8]
    0x00000001 (NEEDED) Shared library: [libz.so.1]
    0x00000001 (NEEDED) Shared library: [libc.so.6]
    0x0000000f (RPATH) Library rpath: [/opt/zimbra/openssl-0.9.8k/lib]
    0x0000000c (INIT) 0x8f40
    0x0000000d (FINI) 0x4d904
    0x00000004 (HASH) 0xb4
    0x6ffffef5 (GNU_HASH) 0x1238
    0x00000005 (STRTAB) 0x4194
    0x00000006 (SYMTAB) 0x1c34
    0x0000000a (STRSZ) 13864 (bytes)
    0x0000000b (SYMENT) 16 (bytes)
    0x00000003 (PLTGOT) 0x55594
    0x00000002 (PLTRELSZ) 2392 (bytes)
    0x00000014 (PLTREL) REL
    0x00000017 (JMPREL) 0x85e8
    0x00000011 (REL) 0x7ca8
    0x00000012 (RELSZ) 2368 (bytes)
    0x00000013 (RELENT) 8 (bytes)
    0x6ffffffe (VERNEED) 0x7c68
    0x6fffffff (VERNEEDNUM) 1
    0x6ffffff0 (VERSYM) 0x77bc
    0x6ffffffa (RELCOUNT) 2
    0x00000000 (NULL) 0x0
    [root@mail ~]#

    The problem was that Library rpath: [/opt/zimbra/openssl-0.9.8k/lib] didn't exist!

    I added a link from /opt/zimbra/openssl-0.9.8k -> /opt/zimbra/openssl

    (as seen below)

    [root@mail ~]# ls -alh /opt/zimbra
    total 364K
    ..... (section trimmed out for clarity) .....
    lrwxrwxrwx 1 root root 26 Jul 8 02:11 openssl -> /opt/zimbra/openssl-0.9.8n
    lrwxrwxrwx 1 root root 26 Jul 8 01:43 openssl-0.9.8k -> /opt/zimbra/openssl-0.9.8n
    drwxrwxr-x 6 root root 4.0K Jul 8 02:11 openssl-0.9.8n
    ..... (section trimmed out for clarity) .....
    [root@mail ~]#


    One important note: This problem existed on two servers that were otherwise identical, but they both pointed to different non-existant openssl folders in the SSLEay.so. RUN the readelf -d on SSLeay.so and verify the Library rpath before creating a link to repair it.

    After creating the link, a re-install of the current version completed successfully, and resolved the unable to get globalgrant errors.

Similar Threads

  1. Replies: 17
    Last Post: 08-30-2010, 11:59 AM
  2. Unable to sent to external domains
    By sunfire in forum Administrators
    Replies: 0
    Last Post: 02-22-2010, 01:20 PM
  3. [SOLVED] unable to send mail to external domains
    By gtdaqua in forum Administrators
    Replies: 8
    Last Post: 01-08-2008, 03:41 AM
  4. Automated Process to Add Aliases to all Domains.
    By myles in forum Administrators
    Replies: 3
    Last Post: 07-07-2007, 01:03 PM
  5. system failure: unable to modify attrs
    By ccmacmil in forum Administrators
    Replies: 2
    Last Post: 05-04-2006, 08:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •