This is more of a comment than a question.

My experience with trying to get Zimbra working has been a little troubled starting by my inability to spell zimbra correctly (zimba instead of zimbra).. Two uninstall/re-installs later I have it working after starting to dig into some of the innards.

1. Since a lot of people seem to be having problems with the ldap server still running after an uninstall/re-install, maybe the installer should check for slapd running.

2. Here is a problem with the installer, (I think).
During part of my troubleshooting installs I added a mysql user. The last install generated this problem in the log.

Oct 16 17:02:25 zimbra postfix/smtp[20594]: 6DFC02DD27: to=, orig_to=, relay=127.0.0.1[127.0.0.1], delay=1296, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.6.0 Failed, id=02822-06, from MTA([127.0.0.1]:10025): 451 Error: queue file write error (in reply to end of DATA command))
and found that the zimbra users have a new UID however the owners of /var/spool/mail/postfix and zimbra are the old users.

volz:x:500:500:Todd Volz:/home/volz:/bin/bash
mysql:x:503:503::/opt/zimbra/mysql:/sbin/nologin
zimbra:x:504:504::/opt/zimbra:/bin/bash
postfix:x:505:505::/opt/zimbra/postfix:/bin/bash
[root@zimbra mail]# ls
postfix volz zimbra
[root@zimbra mail]# ls -la
total 16
drwxrwxr-x 2 root mail 4096 Oct 13 13:25 .
drwxr-xr-x 14 root root 4096 Oct 13 18:51 ..
-rw-rw---- 1 502 mail 0 Oct 13 13:25 postfix
-rw-rw---- 1 volz mail 0 Oct 13 12:27 volz
-rw-rw---- 1 501 mail 0 Oct 13 13:23 zimbra
[root@zimbra mail]#
Hope this helps for the next version of the installer. Let me know if you need any further information.[/FONT]