Results 1 to 3 of 3

Thread: Incorrect Server Status (Zimbra 6.0.8 OSE; CentOS 5.5)

  1. #1
    Join Date
    Sep 2010
    Rep Power

    Default Incorrect Server Status (Zimbra 6.0.8 OSE; CentOS 5.5)

    I am running zcs-6.0.8_GA_2661.RHEL5_64.20100820052503 on CentOS 5.5 final 64bit.

    On a fresh install, the zimbraAdmin page does not reflect the correct Server Status of or any of the services on this server. Zmcontrol status in a terminal shows that the services are working, and everything seems to function perfectly. Additionally, the Server Statistics for message count, message volume and AS/AV activity, and disk report "no data available". Under the Server Statistics section though, session, including counts of connections, and mailbox quotas report correctly.

    This page
    suggests a few commands to check on the status of a configuration.

    1. zmloggerctl status; echo $?; ps ax | grep zmlogger

    zmloggerctl status gives no response, but:
    [zimbra@smith bin]$ zmloggerctl start
    Starting logswatch...logswatch is already running.
    [zimbra@smith bin]$ zmloggerctl status; echo $?
    [zimbra@smith bin]$ ps ax | grep zmlogger
    24409 ttyp0    S+     0:00 grep zmlogger
    31826 ?        S      0:00 /usr/bin/perl /opt/zimbra/libexec/zmlogger
    31891 ?        S      0:00 zmlogger: zmrrdfetch: server
    [zimbra@smith bin]$ /opt/zimbra/libexec/zmrrdfetch -f zmmtastats
    no structure found for zmmtastats at /opt/zimbra/libexec/zmrrdfetch line 239.
    [zimbra@smith bin]$ /opt/zimbra/libexec/zmrrdfetch -c -f zmmtastats
    no structure found for zmmtastats at /opt/zimbra/libexec/zmrrdfetch line 239.
    [zimbra@smith bin]$ grep -w MTA /var/log/zimbra-stats.log | sed s/mydomainname/example/g
    2010-09-15T13:40:06.215437-04:00 mail zimbramon[21730]: 21730:info: MTA: filter_misc,clam_events,mta_delay,mta_volume,filter_virus,filter_count,mta_count,filter_spam,sendmail_events:: 0,0,0,0,0,0,0,0,0
    filter_misc,clam_events,mta_delay,mta_volume,filter_virus,filter_count,mta_count,filter_spam,sendmail_events:: 0,0,0,0,0,0,0,0,0
    2010-09-15T19:40:07.280782-04:00 mail zimbramon[29910]: 29910:info: MTA: filter_misc,clam_events,mta_delay,mta_volume,filter_virus,filter_count,mta_count,filter_spam,sendmail_events:: 0,0,0,0,0,0,0,0,0
    2010-09-15T19:50:06.585618-04:00 mail zimbramon[7745]: 7745:info: MTA: filter_misc,clam_events,mta_delay,mta_volume,filter_virus,filter_count,mta_count,filter_spam,sendmail_events:: 0,0,0,0,0,0,0,0,0
    2010-09-15T20:00:06.987767-04:00 mail zimbramon[17670]: 17670:info: MTA: filter_misc,clam_events,mta_delay,mta_volume,filter_virus,filter_count,mta_count,filter_spam,sendmail_events:: 0,0,0,0,0,0,0,0,0
    [zimbra@smith bin]$ tail /var/log/zimbra-stats.log | sed s/mydomainname/example/g
    2010-09-15T20:11:00.355373-04:00 mail zimbramon[8469]: :::E2DE6830-C126-11DF-8494-9B444E971644:::count, clam, clam-total-cpu, clam-utime, clam-stime, clam-totalMB, clam-rssMB, clam-sharedMB, clam-process-count:: 09/15/2010 20:11:00, system, 2.9, 0.5, 96.5, 0.1, mailbox, 0.0, 0.0, 0.0, 1086.5, 287.2, 11.5, 1, mysql, 0.0, 0.0, 0.0, 636.2, 87.1, 4.6, 1, convertd, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0, ldap, 0.0, 0.0, 0.0, 312.1, 52.6, 4.5, 1, postfix, 0.0, 0.0, 0.0, 42.1, 2.1, 1.6, 6, amavis, 0.0, 0.0, 0.0, 209.5, 94.8, 0.9, 11, clam, 0.0, 0.0, 0.0, 229.8, 183.4, 5.6, 2
    2010-09-15T20:11:00.404267-04:00 mail zimbramon[8471]: 8471:info: zmstat cpu.csv: timestamp, cpu:user, cpu:nice, cpu:sys, cpu:idle, cpu:iowait, cpu:irq, cpu:softirq, cpu0:user, cpu0:nice, cpu0:sys, cpu0:idle, cpu0:iowait, cpu0:irq, cpu0:softirq, cpu1:user, cpu1:nice, cpu1:sys, cpu1:idle, cpu1:iowait, cpu1:irq, cpu1:softirq, cpu2:user, cpu2:nice, cpu2:sys, cpu2:idle, cpu2:iowait, cpu2:irq, cpu2:softirq, cpu3:user, cpu3:nice, cpu3:sys, cpu3:idle, cpu3:iowait, cpu3:irq, cpu3:softirq:: 09/15/2010 20:11:00, 2.8, 0.0, 0.5, 96.5, 0.1, 0.0, 0.0, 3.8, 0.0, 0.9, 95.3, 0.0, 0.0, 0.0, 3.2, 0.0, 0.3, 96.4, 0.0, 0.0, 0.0, 2.9, 0.0, 0.5, 96.3, 0.3, 0.0, 0.0, 1.4, 0.0, 0.3, 98.1, 0.1, 0.0, 0.0
    2010-09-15T20:11:00.936298-04:00 mail zimbramon[8485]: 8485:info: zmstat mysql.csv: timestamp, Aborted_clients, Aborted_connects, Binlog_cache_disk_use, Binlog_cache_use, Bytes_received, Bytes_sent, Com_admin_commands, Com_alter_db, Com_alter_table, Com_analyze, Com_backup_table, Com_begin, Com_call_procedure, Com_change_db, Com_change_master, Com_check, Com_checksum, Com_commit, Com_create_db, Com_create_function, Com_create_index, Com_create_table, Com_create_user, Com_dealloc_sql, Com_delete, Com_delete_multi, Com_do, Com_drop_db, Com_drop_function, Com_drop_index, Com_drop_table, Com_drop_user, Com_execute_sql, Com_flush, Com_grant, Com_ha_close, Com_ha_open, Com_ha_read, Com_help, Com_insert, Com_insert_select, Com_kill, Com_load, Com_load_master_data, Com_load_master_table, Com_lock_tables, Com_optimize, Com_preload_keys, Com_prepare_sql, Com_purge:::E3370E4A-C126-11DF-B1C2-AB444E971644:::
    2010-09-15T20:11:00.936371-04:00 mail zimbramon[8485]: 8485:info: :::E3370E4A-C126-11DF-B1C2-AB444E971644:::, Com_purge_before_date, Com_rename_table, Com_repair, Com_replace, Com_replace_select, Com_reset, Com_restore_table, Com_revoke, Com_revoke_all, Com_rollback, Com_savepoint, Com_select, Com_set_option, Com_show_binlog_events, Com_show_binlogs, Com_show_charsets, Com_show_collations, Com_show_column_types, Com_show_create_db, Com_show_create_table, Com_show_databases, Com_show_errors, Com_show_fields, Com_show_grants, Com_show_innodb_status, Com_show_keys, Com_show_logs, Com_show_master_status, Com_show_ndb_status, Com_show_new_master, Com_show_open_tables, Com_show_privileges, Com_show_processlist, Com_show_slave_hosts, Com_show_slave_status, Com_show_status, Com_show_storage_engines, Com_show_tables, Com_show_triggers, Com_show_variables, Com_show_warnings, Com_slave_start, Com_slave_sto:::E3371EF8-C126-11DF-B1C2-AB444E971644:::
    2010-09-15T20:11:00.936458-04:00 mail zimbramon[8485]: 8485:info: :::E3371EF8-C126-11DF-B1C2-AB444E971644:::p, Com_stmt_close, Com_stmt_execute, Com_stmt_fetch, Com_stmt_prepare, Com_stmt_reset, Com_stmt_send_long_data, Com_truncate, Com_unlock_tables, Com_update, Com_update_multi, Com_xa_commit, Com_xa_end, Com_xa_prepare, Com_xa_recover, Com_xa_rollback, Com_xa_start, Compression, Connections, Created_tmp_disk_tables, Created_tmp_files, Created_tmp_tables, Delayed_errors, Delayed_insert_threads, Delayed_writes, Flush_commands, Handler_commit, Handler_delete, Handler_discover, Handler_prepare, Handler_read_first, Handler_read_key, Handler_read_next, Handler_read_prev, Handler_read_rnd, Handler_read_rnd_next, Handler_rollback, Handler_savepoint, Handler_savepoint_rollback, Handler_update, Handler_write, Innodb_buffer_pool_pages_data, Innodb_buffer_pool_pages_dirty, Innodb_buffer_pool_pages_flush:::E3372272-C126-11DF-B1C2-AB444E971644:::
    2010-09-15T20:11:00.936543-04:00 mail zimbramon[8485]: 8485:info: :::E3372272-C126-11DF-B1C2-AB444E971644:::ed, Innodb_buffer_pool_pages_free, Innodb_buffer_pool_pages_misc, Innodb_buffer_pool_pages_total, Innodb_buffer_pool_read_ahead_rnd, Innodb_buffer_pool_read_ahead_seq, Innodb_buffer_pool_read_requests, Innodb_buffer_pool_reads, Innodb_buffer_pool_wait_free, Innodb_buffer_pool_write_requests, Innodb_data_fsyncs, Innodb_data_pending_fsyncs, Innodb_data_pending_reads, Innodb_data_pending_writes, Innodb_data_read, Innodb_data_reads, Innodb_data_writes, Innodb_data_written, Innodb_dblwr_pages_written, Innodb_dblwr_writes, Innodb_log_waits, Innodb_log_write_requests, Innodb_log_writes, Innodb_os_log_fsyncs, Innodb_os_log_pending_fsyncs, Innodb_os_log_pending_writes, Innodb_os_log_written, Innodb_page_size, Innodb_pages_created, Innodb_pages_read, Innodb_pages_written, Innodb_row_lock_current_wai:::E33725CE-C126-11DF-B1C2-AB444E971644:::
    2010-09-15T20:11:00.936638-04:00 mail zimbramon[8485]: 8485:info: :::E33725CE-C126-11DF-B1C2-AB444E971644:::ts, Innodb_row_lock_time, Innodb_row_lock_time_avg, Innodb_row_lock_time_max, Innodb_row_lock_waits, Innodb_rows_deleted, Innodb_rows_inserted, Innodb_rows_read, Innodb_rows_updated, Key_blocks_not_flushed, Key_blocks_unused, Key_blocks_used, Key_read_requests, Key_reads, Key_write_requests, Key_writes, Last_query_cost, Max_used_connections, Not_flushed_delayed_rows, Open_files, Open_streams, Open_tables, Opened_tables, Prepared_stmt_count, Qcache_free_blocks, Qcache_free_memory, Qcache_hits, Qcache_inserts, Qcache_lowmem_prunes, Qcache_not_cached, Qcache_queries_in_cache, Qcache_total_blocks, Queries, Questions, Rpl_status, Select_full_join, Select_full_range_join, Select_range, Select_range_check, Select_scan, Slave_open_temp_tables, Slave_retried_transactions, Slave_running, Slow_launch:::E337292A-C126-11DF-B1C2-AB444E971644:::
    2010-09-15T20:11:00.936714-04:00 mail zimbramon[8485]: 8485:info: :::E337292A-C126-11DF-B1C2-AB444E971644:::_threads, Slow_queries, Sort_merge_passes, Sort_range, Sort_rows, Sort_scan, Ssl_accept_renegotiates, Ssl_accepts, Ssl_callback_cache_hits, Ssl_cipher, Ssl_cipher_list, Ssl_client_connects, Ssl_connect_renegotiates, Ssl_ctx_verify_depth, Ssl_ctx_verify_mode, Ssl_default_timeout, Ssl_finished_accepts, Ssl_finished_connects, Ssl_session_cache_hits, Ssl_session_cache_misses, Ssl_session_cache_mode, Ssl_session_cache_overflows, Ssl_session_cache_size, Ssl_session_cache_timeouts, Ssl_sessions_reused, Ssl_used_session_cache_entries, Ssl_verify_depth, Ssl_verify_mode, Ssl_version, Table_locks_immediate, Table_locks_waited, Tc_log_max_pages_used, Tc_log_page_size, Tc_log_page_waits, Threads_cached, Threads_connected, Threads_created, Threads_running, Uptime:: 09/15/2010 20:11:00,0,0,0,0,224198,269:::E3372C7C-C126-11DF-B1C2-AB444E971644:::
    2010-09-15T20:11:00.936801-04:00 mail zimbramon[8485]: :::E3372C7C-C126-11DF-B1C2-AB444E971644:::5219,6,0,0,0,0,0,0,0,0,0,0,203,0,0,0,1,0,0,86,0,0,0,0,0,1,0,0,0,0,0,0,0,0,22,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,384,0,524,1177,0,0,0,7,0,0,0,0,0,0,0,143,0,0,0,0,0,0,0,0,0,0,471,0,0,0,7,0,0,0,0,0,0,0,0,0,0,0,158,1,0,0,0,0,0,0,OFF,479,1,5,305,0,0,0,1,468,0,0,0,25,2380,1112,270,3,74294,24,0,0,0,73959,133,0,340,28538,1,28672,1,0,38705,82,0,1797,466,0,0,0,4362240,108,571,11314176,340,92,0,151,99,189,0,0,126976,16384,4,133,340,0,0,0,0,0,19,22,2295,158,0,6694,0,0,0,0,0,0.000000,4,0,27,0,24,31,0,0,0,0,0,0,0,0,0,3477,3477,NULL,0,0,3,0,314,0,0,OFF,0,11,0,85,0,0,0,0,0,,,0,0,0,0,0,0,0,0,0,NONE,0,0,0,0,0,0,0,,603,0,0,0,0,0,4,4,1,8742
    2010-09-15T20:11:06.191102-04:00 mail zimbramon[8487]: 8487:info: zmstat mtaqueue.csv: timestamp, KBytes, requests:: 09/15/2010 20:11:06, 0, 0
    [zimbra@smith bin]$ zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats | head -20
    HTML Code:
    <GetLoggerStatsResponse xmlns="urn:zimbraAdmin"/>
    [zimbra@smith bin]$ zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats @limit=1 | head -50
    HTML Code:
    <GetLoggerStatsResponse xmlns="urn:zimbraAdmin"/>

    [zimbra@smith bin]$ hostname
    [zimbra@smith bin]$ hostname -f
    [zimbra@smith bin]$ host has address mail is handled by 10
    and etc/hosts:
    [zimbra@smith bin]$ cat /etc/hosts localhost smith scr
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    [root@mail bin]# cat /etc/rsyslog.conf
    # Log all kernel messages to the console.
    # Logging much else clutters up the screen.
    #kern.*                                                 /dev/console
    # Log anything (except mail) of level info or higher.
    # Don't log private authentication messages!
    *.info;mail.none;authpriv.none;cron.none                /var/log/messages
    # The authpriv file has restricted access.
    authpriv.*                                              /var/log/secure
    # Log all the mail messages in one place.
    mail.*                                                  -/var/log/maillog
    # Log cron stuff
    cron.*                                                  /var/log/cron
    # Everybody gets emergency messages
    *.emerg                                                 *
    # Save news errors of level crit and higher in a special file.
    uucp,news.crit                                          /var/log/spooler
    # Save boot messages also to boot.log
    local7.*                                                /var/log/boot.log
    local0.*                -/var/log/zimbra.log
    local1.*                -/var/log/zimbra-stats.log
    auth.*                  -/var/log/zimbra.log
    mail.*                -/var/log/zimbra.log
    [zimbra@smith bin]$ zmhostname
    Note also that DNS is set in the following way:
    [zimbra@smith bin]$ dig -t mx a | sed s/mydomainname/example/g | sed s/serverip/
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> -t mx a
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 15387
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    ;a.    IN MX
    .     5429  IN  SOA 2010091401 1800 900 604800 86400
    ;; Query time: 0 msec
    ;; SERVER:
    ;; WHEN: Wed Sep 15 20:28:03 2010
    ;; MSG SIZE  rcvd: 94
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40089
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    ;   IN  MX
    ;; ANSWER SECTION: 2852 IN MX 10
    ;; Query time: 0 msec
    ;; SERVER:
    ;; WHEN: Wed Sep 15 20:28:03 2010
    ;; MSG SIZE  rcvd: 71
    Finally, note that I told the installer that I wanted instead of which registered no errors because there is a MX record for, but not This gives me accounts like by default, but the server still seems to know that the FQDM is I think this was the correct configuration for what I want, but the documentation is a little unclear considering that even though I think nearly everyone would choose an rather than it is not listed that way.

    Thank you anyone for your help. I feel like I followed the directions in a similar way to how most people would, but maybe not considering how few people are asking about having the same problem.


  2. #2
    Join Date
    Nov 2009
    Rep Power

    Default Multi-server install on Debian 5 64 bits - Zimbra v6.08

    I installed Zimbra on three xen guests. zmcontrol status shows that all services are launched but the server state (in web admin console) shows that all the services on ldap and mta aren't launched. I've configured rsyslog with "-r -m 0" options on mailbox server but nothing has changed.

    Any idea ?

  3. #3
    Join Date
    Sep 2010
    Rep Power


    I have not yet found a solution, however I am pretty sure that rsyslogd is working on my server. /var/log has plenty of up to date logs that are recording information.

    I do not know why the information is not available in the web client. I am not sure if it is looking for the logs in a different place, or if it is not parsing them correctly.

    For instance rsyslog seems to be recording the equivalent of
    reports the equivalent of
    hostname -f
    . I have tried setting zmloggerhostmap in different ways, and restarting zmcontrol, but it does not seem to have helped the webclient correctly parse the files.

    It looks like it would not be very difficult to
    cat /opt/zimbra/bin/zmloggerctl
    since it, and other commands are bash scripts, then slowly trace everything back to the sources of information that is being used.

    I have been short on time to perform what will be a fairly tedious process.

    Also, I did a pretty vanilla installation, so not having heard a lot of people with the same problem, I am reluctant to find a solution that involves changing default settings.

    Please let e know if you find anything obvious.


Similar Threads

  1. Replies: 5
    Last Post: 08-18-2011, 10:15 PM
  2. [SOLVED] Important Mta Issue!!!!!!!!
    By borngunners in forum Migration
    Replies: 2
    Last Post: 01-05-2010, 05:44 AM
  3. [SOLVED] mysql.server not running
    By king0770 in forum Administrators
    Replies: 23
    Last Post: 07-25-2009, 03:07 PM
  4. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  5. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts