Results 1 to 6 of 6

Thread: zimbra.log empty after rotate

  1. #1
    Join Date
    Dec 2007
    Location
    Netherlands
    Posts
    6
    Rep Power
    7

    Default zimbra.log empty after rotate

    I just setup a new Zimbra server on Ubuntu Server 10.04 LTS. All seems well but I noticed today when I tried to trace some email delivery issues that my zimbra.log is empty since this morning. Yesterday it worked fine.

    I've tried to restart the server (multiple times) but didn't do anything...


    -rw-r--r-- 1 zimbra zimbra 0 Oct 8 06:44 zimbra.log
    -rw-r--r-- 1 syslog adm 286960 Oct 8 06:44 zimbra.log.1.gz

    I looks like it's going bad after the logrotate but I don't understand why.

    Any ideas what could be going wrong here?

    Thanks!

  2. #2
    Join Date
    Jun 2009
    Posts
    131
    Rep Power
    6

    Default

    Restarting rsyslog worked for me:

    -rw-r--r-- 1 syslog adm 91K 2010-10-10 16:58 zimbra.log

    It changes the permissions, you probably have zimbra:zimbra at the moment, but the above is what you end up with afterwards. Im not sure what knock on affect this has, ie if zimbra can still do what it needs to the file, but i guess we'll see.

    Cheers,

    iMx

  3. #3
    Join Date
    Jul 2010
    Posts
    11
    Rep Power
    5

    Default

    The mine stopped as well:

    ls -al zimbra.log*
    -rw-r--r-- 1 zimbra zimbra 4199 Oct 22 12:10 zimbra.log
    -rw-r--r-- 1 zimbra zimbra 53868 Oct 18 04:25 zimbra.log.1.gz
    -rw-r--r-- 1 zimbra zimbra 68725 Oct 15 04:25 zimbra.log.2.gz
    -rw-r--r-- 1 zimbra zimbra 38329 Oct 12 04:25 zimbra.log.3.gz
    -rw-r--r-- 1 zimbra zimbra 61631 Oct 11 04:25 zimbra.log.4.gz

    I even see a service what should be writing to it:

    zimbra 5800 1 0 11:39 pts/1 00:00:00 /usr/bin/perl /opt/zimbra/libexec/swatch --config-file=/opt/zimbra/conf/swatchrc --use-cpan-file-tail --script-dir=/opt/zimbra/data/tmp -t /var/log/zimbra.log


    Why does it stopped, can anyone help me out with this problem?

  4. #4
    Join Date
    Jul 2010
    Posts
    11
    Rep Power
    5

    Default

    Ok as you can see i did a list after a /etc/init.d/syslog restart

    And since 10 minutes zimbra.log is growing again.

    Hmm it looks like a bug of zimbra?

  5. #5
    Join Date
    Jan 2010
    Posts
    16
    Rep Power
    5

    Default zmbra.log and zimbra-stats.log empty after rotate

    Same problem on my Ubuntu 10.04 LTS ith ZCS open-src v.6.0.8... and a solution :

    Hours after after a logrotate (daily), the 2 zimbra .log files are still empty in /var/log/ :
    -rw-r--r-- 1 zimbra zimbra 0 2010-10-28 06:45 zimbra.log
    -rw-r--r-- 1 syslog adm 39112 2010-10-28 06:45 zimbra.log.1.gz
    -rw-r--r-- 1 syslog adm 112072 2010-10-27 06:38 zimbra.log.2.gz
    -rw-r--r-- 1 zimbra zimbra 0 2010-10-28 06:45 zimbra-stats.log

    And on the zimbra web amin console, no recent data for services status, and when trying to displays graphs I get a popup error :
    "Mail : system failure: Unable to read logger stats Code d'erreur : service.FAILURE Method: GetLoggerStatsRequest Détails :soap:Receiver"

    Only 2 solutions works for me :
    - full reboot of the Ubuntu
    or
    - changing owner/group of the two .log files to syslog:adm (instead of zimbra:zimbra) : after a few minutes all is back ok, all log files growing and web console grpahs/status working ok :
    chown syslog:adm /var/log/zimbra.log /var/log/zimbra-stats.log

    Wondering if I should put my "chown" in a crontab,
    or should I try modifying own/grp in /etc/logrotate.d/zimbra ?

  6. #6
    Join Date
    Jan 2010
    Posts
    16
    Rep Power
    5

Similar Threads

  1. Chats folder not empty, but appears empty
    By fcolpron in forum Users
    Replies: 1
    Last Post: 02-04-2008, 01:10 PM
  2. zmconfigure leaves an empty slapd.conf
    By wriedmann in forum Administrators
    Replies: 0
    Last Post: 08-14-2007, 01:42 AM
  3. Postfix problem
    By jimbo in forum Administrators
    Replies: 46
    Last Post: 07-23-2007, 05:24 AM
  4. Disable Empty Trash?
    By jdanda in forum Users
    Replies: 2
    Last Post: 07-20-2007, 04:47 AM
  5. Replies: 8
    Last Post: 04-29-2007, 07:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •