Results 1 to 6 of 6

Thread: Z7b1 10.6 install failure

  1. #1
    Join Date
    May 2010
    Posts
    7
    Rep Power
    5

    Default Z7b1 10.6 install failure

    I can't get the zmsetup.pl script to run on my fresh install of Z7b1. Here's what the log says:

    admin$ tail /tmp/zmsetup.10212010-122807.log
    cat: /opt/zimbra/conf/spnego_java_options: No such file or directory
    Stopping mailboxd...mailboxd is not running.
    Error: assertion '-r /opt/zimbra/conf/my.cnf' failed


    Stopping logger...Done.
    Stopping zmconfigd...Done.
    Stopping ldap...Done.
    Thu Oct 21 12:28:35 2010 failed. exiting.
    Thu Oct 21 12:28:35 2010 UPGRADE FAILED - exiting.

    Even after copying the spnego conf file to the right name it fails with the same info. I'd like to test this so we can upgrade as soon as Z7 is final.

  2. #2
    Join Date
    May 2010
    Posts
    7
    Rep Power
    5

    Default

    Looks like manually creating the my.cnf file using the results of zmmycnf allowed the setup to complete, but now I get an error from mysql stating:

    innodb_buffer_pool_size must be less then 2GB on a 32bit system
    Thu Oct 21 13:40:54 2010: Please correct /opt/zimbra/conf/my.cnf and rerun zmsetup.pl

    As far as I know, Z7 is 64-bit only for 10.6, so what's the deal? This is a 2009 Xserve.

  3. #3
    Join Date
    May 2010
    Posts
    7
    Rep Power
    5

    Default

    So after fixing this stupid error (mysql has no problem with the value, just the stupid setup checker) I get another error saying the mysql db hasn't been initialized. So I have to give the zimbra user a password in order to be able to su into it. I use that to run zmmyinit, which works fine but can't kill mysql if it's already running. Exiting back to my regular admin user I try running setup and it starts mysql but fails anyway, with this message:

    admin$ tail /tmp/zmsetup.10212010-152154.log
    Stopping ldap...Done.
    Thu Oct 21 15:22:29 2010 done.
    Thu Oct 21 15:22:29 2010 Verifying /opt/zimbra/conf/my.cnf
    Thu Oct 21 15:22:32 2010 Starting mysql...
    Thu Oct 21 15:22:32 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Starting mysqld...done.
    Thu Oct 21 15:22:57 2010 done.
    Thu Oct 21 15:23:08 2010 I can't upgrade version

    Thu Oct 21 15:23:08 2010 UPGRADE FAILED - exiting.

    WTF? Do you guys even test this stuff?

  4. #4
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Is this the first time you've encountered the word "beta" ?

    Beta software will have bugs, it's not finished, it's still being created. You want bug free, go for released software.

    Ok, that said, it looks like you're running this on OSX Snow Leopard, is that right? Can you install and start an instance of ZCS 6 on that same computer? Just to confirm that the computer has everything needed to get ZCS running.

  5. #5
    Join Date
    May 2010
    Posts
    7
    Rep Power
    5

    Default

    Usually when someone releases software as a beta, I expect it to install properly, even if some features or incomplete or it crashes. But you've got conf files improperly named so the damn thing can't even set itself up properly. Your setup script doesn't properly detect that I'm on a 64-bit system or the proper values for various MySQL setting, and this release is supposed to be specifically for 64-bit systems. These are all issues that would be encountered if the Mac install had been tested at all.

    Why would try to install Z6 when it isn't supported at all on 10.6? You guys keep saying it doesn't work. But hey, whatever, I'll give it a shot.

  6. #6
    Join Date
    May 2010
    Posts
    7
    Rep Power
    5

    Default

    Just wanted to add that setup fails for Z6 as well on my server. Proceeds this far:


    webxserve:zcs-6.0.8_GA_2661.MACOSXx86.20100820050930 admin$ sudo ./scripts/installZCS.sh -m zcs.mpkg
    Performing installation check
    Looking for core...Looking for mta...Looking for store...Looking for ldap...Looking for snmp...Looking for logger...Looking for apache...Looking for spell...installer: Package name is Zimbra Collaboration Suite
    installer: Upgrading at base path /
    installer: The upgrade was successful.
    Operations logged to /tmp/zmsetup.11082010-110000.log
    Installing LDAP configuration database...done.
    Upgrading from to 6.0.8_GA_2661
    Stopping zimbra services...done.
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql...

    But then gets stuck starting mysql. This is at the end of the log file:


    webxserve:~ admin$ tail /tmp/zmsetup.11082010-110000.log
    Mon Nov 8 11:00:32 2010 Starting mysql...
    Mon Nov 8 11:00:32 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Mon Nov 8 11:00:54 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Mon Nov 8 11:01:17 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Mon Nov 8 11:01:41 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Mon Nov 8 11:02:09 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Mon Nov 8 11:02:32 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Mon Nov 8 11:02:54 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Mon Nov 8 11:03:18 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Mon Nov 8 11:03:40 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start

Similar Threads

  1. Zimba Beta 5 OSX install failure
    By jjprusk in forum Installation
    Replies: 7
    Last Post: 07-24-2007, 10:06 AM
  2. Ubuntu-Foss install failure libgmp3
    By mjfleck2000 in forum Installation
    Replies: 7
    Last Post: 09-27-2006, 08:02 AM
  3. Zimbra 3.1.4 installation failure on package install
    By gmcraff in forum Installation
    Replies: 3
    Last Post: 07-08-2006, 12:24 PM
  4. FC3 and Zen install failure with NPTL
    By Daniel-Daniel in forum Installation
    Replies: 4
    Last Post: 11-22-2005, 12:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •