Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: HTTP Status 500 - When attempting to view attachments

  1. #1
    Join Date
    Sep 2006
    Location
    Melbourne, Australia
    Posts
    8
    Rep Power
    9

    Default HTTP Status 500 - When attempting to view attachments

    I have been running Zimbra Open Source for about a year now, it is an awesome product but I have never been able to view attachments. I have just upgraded to 4.0.1 hoping that it would solve my problems by unfortunately not. Below is the error report that I am receiving from Tomcat. I am sure that it is a simple configuration problem that I introduce in my initial install.

    Any help would be much appreciated.


    HTTP Status 500 -

    type Exception report

    message

    description The server encountered an internal error () that prevented it from fulfilling this request.

    exception

    javax.servlet.ServletException: failed to handle GET request
    com.zimbra.cs.extension.ExtensionDispatcherServlet .service(ExtensionDispatcherServlet.java:111)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    com.zimbra.cs.service.formatter.NativeFormatter.ha ndleMessagePart(NativeFormatter.java:140)
    com.zimbra.cs.service.formatter.NativeFormatter.ha ndleMessage(NativeFormatter.java:99)
    com.zimbra.cs.service.formatter.NativeFormatter.fo rmatCallback(NativeFormatter.java:83)
    com.zimbra.cs.service.formatter.Formatter$FormatOp eration.callback(Formatter.java:246)
    com.zimbra.cs.operation.Operation.schedule(Operati on.java:190)
    com.zimbra.cs.service.formatter.Formatter.format(F ormatter.java:88)
    com.zimbra.cs.service.UserServlet.doAuthGet(UserSe rvlet.java:388)
    com.zimbra.cs.service.UserServlet.doGet(UserServle t.java:290)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:173)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:802)

    root cause

    com.zimbra.cs.service.ServiceException: system failure: Extension HTTP handler not found at /convertd
    com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:174)
    com.zimbra.cs.extension.ExtensionDispatcherServlet .getHandler(ExtensionDispatcherServlet.java:146)
    com.zimbra.cs.extension.ExtensionDispatcherServlet .service(ExtensionDispatcherServlet.java:99)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    com.zimbra.cs.service.formatter.NativeFormatter.ha ndleMessagePart(NativeFormatter.java:140)
    com.zimbra.cs.service.formatter.NativeFormatter.ha ndleMessage(NativeFormatter.java:99)
    com.zimbra.cs.service.formatter.NativeFormatter.fo rmatCallback(NativeFormatter.java:83)
    com.zimbra.cs.service.formatter.Formatter$FormatOp eration.callback(Formatter.java:246)
    com.zimbra.cs.operation.Operation.schedule(Operati on.java:190)
    com.zimbra.cs.service.formatter.Formatter.format(F ormatter.java:88)
    com.zimbra.cs.service.UserServlet.doAuthGet(UserSe rvlet.java:388)
    com.zimbra.cs.service.UserServlet.doGet(UserServle t.java:290)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:173)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:802)

    note The full stack trace of the root cause is available in the Apache Tomcat/5.5.15 logs.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You may be missing some libraries, are you running CentOS? can you run the following:
    Code:
    rpm -qa | grep compat
    are libstdc++-296 and libstdc++-33 listed?

    If they're not can you install them.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2006
    Location
    Melbourne, Australia
    Posts
    8
    Rep Power
    9

    Default

    I am running FC4.

    Quote Originally Posted by phoenix
    are libstdc++-296 and libstdc++-33 listed?
    Neither of this where installed. I have now installed them and there is no difference

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Sorry, I should have added you need a restart of zimbra - see if that helps.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Sep 2006
    Location
    Melbourne, Australia
    Posts
    8
    Rep Power
    9

    Default

    Yeah, I did that a number of times after installing the new packages and still nothing. Any other ideas?

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    OK, are you still getting the same errors in the logs? Are these messages ending up in the deferred queue or is this a problem just trying to view the attachment? Which type of attachment is it? Could you also try a reboot of the server and see if the problem still exists.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Sep 2006
    Location
    Melbourne, Australia
    Posts
    8
    Rep Power
    9

    Default

    Yes I am still getting the same error in the logs.

    The problem is only trying to view attachments. I am guessing that the problem is with all attachments, I have had the problem with image files, pdf files, word documents. The one exception that I have seen thus far is if there is a attached email I can view that.

    I have now rebooted the server and the problem still exists.

  8. #8
    Join Date
    Sep 2006
    Location
    Melbourne, Australia
    Posts
    8
    Rep Power
    9

    Default

    One other thing that I forgot to mention was the I am running everything in https mode. I have a seperate webserver running on port 80.

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I can't find anything that would cause no attachemnts to be viewed, I'm stumped. One last question, if you try viewing an attachment is there any information in catalina.out log file?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    Sep 2006
    Location
    Melbourne, Australia
    Posts
    8
    Rep Power
    9

    Default

    No nothing in the catalina.out log file

    How ever I have found another post has had the same problem: http://www.zimbra.com/forums/showthread.php?t=4292

    The difference is that I am not running on MacOSX.

    Also the only reference that I can find to convertd on my server is an empty directory at /opt/zimbra/convertd

Similar Threads

  1. mysql.server is not running
    By Oswald-Kolle in forum Installation
    Replies: 27
    Last Post: 05-01-2007, 09:28 AM
  2. fatal: Queue report unavailable - mail system is down
    By zzzzsg in forum Administrators
    Replies: 16
    Last Post: 08-24-2006, 03:31 AM
  3. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 12:01 PM
  4. Upgrade Trouble woooo
    By RobertW in forum Installation
    Replies: 3
    Last Post: 06-15-2006, 06:24 PM
  5. The mailbox and mta dies in FC4 GA version
    By meikka in forum Installation
    Replies: 72
    Last Post: 03-16-2006, 05:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •