Results 1 to 7 of 7

Thread: extreamly slow "zmprov" execution

  1. #1
    Join Date
    Sep 2006
    Posts
    13
    Rep Power
    9

    Default extreamly slow "zmprov" execution

    I'm not sure what's caused it, but it's taking an extreamly long time to run the zmsetup.pl script while it's doing updates:


    ----------------

    Checking 3.1.2_GA

    Tue Sep 12 20:13:16 2006: Checking 3.1.2_GA

    Checking 3.1.3_GA

    Tue Sep 12 20:13:16 2006: Checking 3.1.3_GA

    Checking 3.1.4_GA

    Tue Sep 12 20:13:16 2006: Checking 3.1.4_GA

    Tue Sep 12 20:13:16 2006: Updating from 3.1.4_GA
    Checking 3.2.0_M1

    Tue Sep 12 20:13:17 2006: Checking 3.2.0_M1

    Tue Sep 12 20:13:17 2006: Updating from 3.2.0_M1
    Checking 3.2.0_M2

    Tue Sep 12 21:29:53 2006: Checking 3.2.0_M2

    Tue Sep 12 21:29:53 2006: Updating from 3.2.0_M2
    Checking 4.0.0_RC1

    Tue Sep 12 21:49:00 2006: Checking 4.0.0_RC1

    Tue Sep 12 21:49:00 2006: Updating from 4.0.0_RC1

    ---------------------

    Yes, that's over an hour to go from 3.2.0M1 to M2..

    I've only got 1G of ram, and if someone can confirm that this is what's causing the problem i'm happy, but if there's something else wrong, i'd like to get it figured out.

  2. #2
    Join Date
    Sep 2006
    Posts
    13
    Rep Power
    9

    Default ipv6

    I've tracked this down to ipv6. It seems that Zimbra is trying to do some ipv6 connections, which are all completely firewalled on my system, and it's taking time to timeout.

    How do I completely disable ipv6 in zimbra/java/tomcat?

  3. #3
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Did you try to disable it at the OS level ?

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by jammy
    I've tracked this down to ipv6. It seems that Zimbra is trying to do some ipv6 connections, which are all completely firewalled on my system, and it's taking time to timeout.

    How do I completely disable ipv6 in zimbra/java/tomcat?
    Can you post some details on the ipv6 connections you think we are making? I'm pretty sure we don't do that on purpose.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Sep 2006
    Posts
    13
    Rep Power
    9

    Default

    it all seems to be stuff going to localhost.. connecting to some of the java tasks that are running.

    INPUT:IN=lo OUT= MAC=00:00:00:00:00:00:00:00:00:00:00:00:86:dd SRC=0000:0000:0000:0000:0000:0000:0000:0001 DST=0000:0000:0000:0000:0000:0000:0000:0001 LEN=80 TC=0 HOPLIMIT=64 FLOWLBL=0 PROTO=TCP SPT=35420 DPT=36962 WINDOW=32752 RES=0x00 SYN URGP=0

  6. #6
    Join Date
    Mar 2009
    Posts
    4
    Rep Power
    6

    Default Solution: disable ipv6 on application level

    I've had the same problem with Zimbra 5.0.15 running on Ubuntu 8.0.4. The Ubuntu 8.0.4 itself runs as guest OS in an OpenVZ environment. That is not officially supported by Zimbra, but it works. Unfortunately, ipv6 in Debian's official ovz-kernel seems to be broken. And disabling ipv6 on OS level doesn't work.

    I disabled ipv6 in Zimbra on application level by adding the option "-Djava.net.preferIPv4Stack=true" to some Zimbra shell scripts:

    /opt/zimbra/bin/zmjava
    /opt/zimbra/bin/zmjavaext
    /opt/zimbra/libexec/zmjsprecompile
    /opt/zimbra/bin/zmmailboxdctl

    Just look for "-Xmx" and add the option "-Djava.net.preferIPv4Stack=true" at appropriate positions.

    It would be great, if Zimbra would ask for ipv6 at install time or add an option like -noipv6, add a global variable to localconfig, and if the shell scripts, which start the Java apps would evaluate that variable.
    Last edited by thmsk; 03-29-2009 at 03:35 AM.

  7. #7
    Join Date
    Dec 2008
    Posts
    68
    Rep Power
    6

    Default

    Do u need restart zimbra to apply the new changes to the scripts?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •