Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: [SOLVED] Zimbra Collaboration Suite on Ubuntu 10.10

Hybrid View

  1. #1
    Join Date
    Nov 2010
    Location
    Amsterdam, The Netherlands
    Posts
    5
    Rep Power
    5

    Question [SOLVED] Zimbra Collaboration Suite on Ubuntu 10.10

    Hi everybody,

    I know Ubuntu 10.10 isn't listed as a supported at the moment, however I'd like to know if anybody got ZCS installed without errors.

    When i run installer.sh with default settings untouched I get the following error:

    Code:
        zimbra-core......zimbra-core_6.0.9_GA_2686.UBUNTU10_64_amd64.deb...FAILED
    ###ERROR###
    In the install log I get:

    Code:
    dpkg: error processing ./packages/zimbra-core_6.0.9_GA_2686.UBUNTU10_64_amd64.deb (--install):
     parse error, in file '/var/lib/dpkg/tmp.ci/control' near line 2 package 'zimbra-core':
     error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    Errors were encountered while processing:
     ./packages/zimbra-core_6.0.9_GA_2686.UBUNTU10_64_amd64.deb
    If anybody has an idea how to get around this I'd be much oblidged. Thanks!

  2. #2
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    6

    Default

    Have you tried:
    Code:
    ./install.sh --platform-override

  3. #3
    Join Date
    Nov 2010
    Location
    Amsterdam, The Netherlands
    Posts
    5
    Rep Power
    5

    Thumbs up

    Hi mavles,

    Downgrading dpkg allowed me to succesfully install.
    Thanks!

  4. #4
    Join Date
    Nov 2010
    Location
    Amsterdam, The Netherlands
    Posts
    5
    Rep Power
    5

    Default

    Thanks Hivos. Unfortunately I end up with the same output and install log when I run the install script with the "--platform-override" switch.

    If I'm not mistaken recent versions of dpkg don't like underscores in the version number in the .deb file. This causes install to fail.

    One solution I've tried is to use "dpkg-deb -x" to extract the contents of the zimbra-core .deb file, use "dpkg-deb -e" to extract the control file and manually remove underscores from the version number in the DEBIAN/control file. After repackaging and overwriting the original .deb file I don't get the error anymore for zimbra-core when running install.sh. Of course the other zimbra packages still fail to install because their .deb's still have invalid chars in the version number. Too much of a hassle to extract, edit and repackage them all IMHO.

    So a more elegant hack would be if dpkg could be set to ignore invalid version numbers. Does anybody have a clue how to achieve this?
    PS. I've already tried adding "force-all" to /etc/dpkg/dpkg.cfg, but dpkg still fails.

    Thanks!
    Last edited by mat0ng; 11-28-2010 at 09:47 AM.

  5. #5
    Join Date
    Nov 2010
    Posts
    2
    Rep Power
    5

    Default Install on Ubuntu 10.10

    Just update upgrade and install all the things you want and need before installing Zimbra. Then downgrade dpkg with the Lucid version.
    wget http://security.ubuntu.com/ubuntu/po...u4.3_amd64.deb

    dpkg -i dpkg_1.15.5.6ubuntu4.3_amd64.deb
    install Zimbra!
    vi or nano /var/lib/dpkg/status and search for zimbra-ldap zimbra-apache .......zimbra-mta and replace all the underscores with the tilde character. _ to ~
    vi or nano /var/lib/dpkg/available and search for zimbra-ldap zimbra-apache .......zimbra-mta and replace all the underscores with the tilde character. _ to ~
    After Zimbra successful install you can do apt-get install dpkg to have the latest dpkg version.

    The latest dpkg has some strict naming convention!

    Best regards,
    Selvam Matthys
    Last edited by mavles; 11-29-2010 at 01:11 AM.

  6. #6
    Join Date
    Dec 2010
    Posts
    3
    Rep Power
    5

    Default

    i still have problem after downgrade....anyone have other method??

  7. #7
    Join Date
    Feb 2011
    Posts
    2
    Rep Power
    4

    Default Downgrading dpkg works

    I found the specified version on a mirror for amd64, installed it, installed zimbra and used apt-get to update dpkg after complete. Worked great! Thanks

  8. #8
    Join Date
    Feb 2011
    Posts
    3
    Rep Power
    4

    Lightbulb

    Quote Originally Posted by brianhildebrandt View Post
    I found the specified version on a mirror for amd64, installed it, installed zimbra and used apt-get to update dpkg after complete. Worked great! Thanks
    Same here -- the dpgk replacement listed above is no longer available. The one I used is here:

    http://security.ubuntu.com/ubuntu/po...ntu4_amd64.deb

    The functionality change seems to start with version 1.15.8

  9. #9
    Join Date
    Feb 2011
    Posts
    1
    Rep Power
    4

    Default no install zimbra7 on ubuntu 10.10

    can not install zimbra7 on ubuntu 10.10

    Installing packages
    zimbra-core......zimbra-core_7.0.0_GA_3077.UBUNTU10_64_amd64.deb...FAILED
    ###ERROR###
    zimbra-core_7.0.0_GA_3077.UBUNTU10_64_amd64.deb installation failed
    Installation cancelled

    where the error
    thanks

  10. #10
    Join Date
    Jul 2008
    Posts
    4
    Rep Power
    7

    Default

    I know this is old, and marked as solved, but this is still a problem with current builds (7.1.4_GA_2555), and since Ubuntu 12.04LTS is coming out in just over a month, it should probably be addressed ASAP (I'm building a Zimbra machine on Precise now). Downgrading dpkg isn't really doable, since any time you upgrade the machine dpkg will get upgraded back to the version with strict version checking.

    I hacked together a quick script that rewrites all the packages, so that zimbra installs and updates can be done.

    Run it like this:

    root@oishi:~# tar -zxf zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803.tgz
    root@oishi:~# ./fixpkg.sh zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803/
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-apache_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-apache' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-apache_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-core_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-core' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-core_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-ldap_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-ldap' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-ldap_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-logger_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-logger' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-logger_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-memcached_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-memcached' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-memcached_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-mta_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-mta' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-mta_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-proxy_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-proxy' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-proxy_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-snmp_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-snmp' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-snmp_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-spell_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-spell' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-spell_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Fixing zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-store_7.1.4_GA_2555.UBUNTU10_64_amd64.deb
    dpkg-deb: building package `zimbra-store' in `../zcs-7.1.4_GA_2555.UBUNTU10_64.20120105094803//packages/zimbra-store_7.1.4_GA_2555.UBUNTU10_64_amd64.deb'.
    Attached Files Attached Files

Similar Threads

  1. admin consol blank after 5.0.3 upgarde
    By maumar in forum Administrators
    Replies: 6
    Last Post: 03-21-2008, 06:16 AM
  2. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 03:37 AM
  3. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 09:21 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •