Hi everyone,

I made an upgrade this evening - and got a really strange bug. I can send mails to external hosts like before - but any mail to zimbra fails because of "Relay Access denied". If I try to send something via webinterface I get an "mail for vereinlandwege.de loops back to myself" error.

My setup:
- Ubuntu 10.04
- Zimbra OpenSource Edition 7, 64bit

Server:
- internal hostname: sun.vereinlandwege.de
- external hostname: mail.vereinlandwege.de
- mail adresses: name@vereinlandwege.de

If I send to outside it looks like this in target hostname:
Code:
Feb  8 00:46:12 lvps83-169-1-219 postfix/smtpd[16090]: connect from mail.vereinlandwege.de[88.79.167.149]
Feb  8 00:46:27 lvps83-169-1-219 postfix/smtpd[16090]: warning: 149.167.79.88.list.dsbl.org: RBL lookup error: Host or domain name not found. Name service error for name=149.167.79.88.list.dsbl.org type=A: Host not found, try againFeb  8 00:46:28 lvps83-169-1-219 postfix/smtpd[16090]: 19085166E19FD: client=mail.vereinlandwege.de[88.79.167.149]Feb  8 00:46:28 lvps83-169-1-219 postfix/cleanup[22216]: 19085166E19FD: message-id=<1c4da0a0-605d-408e-85cf-319ac434d616@sun>Feb  8 00:46:28 lvps83-169-1-219 postfix/qmgr[2007]: 19085166E19FD: from=, size=811, nrcpt=1 (queue active)Feb  8 00:46:28 lvps83-169-1-219 postfix/smtpd[16090]: disconnect from mail.vereinlandwege.de[88.79.167.149]
mail.vereinlandwege.de looks perfect - and it is perfect, it works. But internally it gets strange. A mail from webinterface to the same account:
Code:
Feb  8 01:26:46 sun postfix/smtpd[25565]: connect from localhost[127.0.0.1]
Feb  8 01:26:46 sun postfix/smtpd[25565]: E21AA4C14F4: client=localhost[127.0.0.1]Feb  8 01:26:46 sun postfix/cleanup[25568]: E21AA4C14F4: message-id=<70be5408-81a1-45f9-a96a-2fc115108577@sun>
Feb  8 01:26:46 sun postfix/qmgr[21006]: E21AA4C14F4: from=, size=593, nrcpt=1 (queue active)Feb  8 01:26:46 sun postfix/smtpd[25565]: disconnect from localhost[127.0.0.1]
Feb  8 01:26:47 sun postfix/smtp[25569]: E21AA4C14F4: to=, relay=none, delay=0.07, delays=0.05/0.02/0/0, dsn=5.4.6, status=bounced (mail for vereinlandweg
e.de loops back to myself)
Feb  8 01:26:47 sun postfix/cleanup[25568]: 043354C14F6: message-id=<20110208002647.043354C14F6@sun.localdomain>
Feb  8 01:26:47 sun postfix/bounce[25571]: E21AA4C14F4: sender non-delivery notification: 043354C14F6
Feb  8 01:26:47 sun postfix/qmgr[21006]: E21AA4C14F4: removed
Feb  8 01:26:47 sun postfix/smtp[25569]: 043354C14F6: to=, relay=none, delay=0.03, delays=0.03/0/0/0, dsn=5.4.6, status=bounced (mail for vereinlandwege.de loops back to myself)
Feb  8 01:26:47 sun postfix/qmgr[21006]: 043354C14F6: removed
This looks strange. It looks even more strange if I try to send a mail from outside:
Code:
Feb  8 01:22:51 sun postfix/smtpd[24666]: connect from sectio-aurea.org[83.169.1.219]
Feb  8 01:22:51 sun postfix/smtpd[24666]: NOQUEUE: reject: RCPT from sectio-aurea.org[83.169.1.219]: 554 5.7.1 : Relay access denied; from= to= proto=ESMTP helo=
Why does it not know its own virtual domains?! Because - vereinlandwege.de is active in zimbra admin interface and I can login with vereinlandwege.de users.

/etc/hosts:
Code:
192.168.1.1     sun.vereinlandwege.de sun.vereinlandwege.de mail.vereinlandwege.de vereinlandwege.de sun
MX-Records always point to mail.vereinlandwege.de, intern and extern.

So - any ideas where the problem might be? Thanks for any idea!