I tried to upgrade from 6.0.10NE to 7.0.0 and the upgrade failed with the following errors:

Sat Feb 12 16:42:51 2011 Checking ldap status....
Sat Feb 12 16:42:51 2011 *** Running as zimbra user: /opt/zimbra/bin/ldap status
ldap_url and ldap_master_url cannot be the same on an ldap replica
Sat Feb 12 16:42:52 2011 not running.
Sat Feb 12 16:42:52 2011 Running bdb db_recover...
Sat Feb 12 16:42:52 2011 *** Running as zimbra user: /opt/zimbra/bdb/bin/db_recover -h /opt/zimbra/data/ldap/hdb/db
Sat Feb 12 16:42:54 2011 done.
Sat Feb 12 16:42:54 2011 Running zmldapapplyldif...
Sat Feb 12 16:42:54 2011 *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
/opt/zimbra/libexec/zmldapenablereplica: line 58: [: =: unary operator expected
/opt/zimbra/libexec/zmldapenablereplica: line 293: [: =: unary operator expected
Sat Feb 12 16:43:03 2011 done.
Sat Feb 12 16:43:03 2011 Checking ldap status....
Sat Feb 12 16:43:03 2011 *** Running as zimbra user: /opt/zimbra/bin/ldap status
ldap_url and ldap_master_url cannot be the same on an ldap replica
Sat Feb 12 16:43:04 2011 not running.
Sat Feb 12 16:43:04 2011 Starting ldap...
Sat Feb 12 16:43:04 2011 *** Running as zimbra user: /opt/zimbra/bin/ldap start
ldap_url and ldap_master_url cannot be the same on an ldap replica
Sat Feb 12 16:43:05 2011 failed with exit code: 256.



Attempting to start ldap manually yields the following error:

Failed to start slapd. Attempting debug start to determine error.
config error processing olcDatabase={3}hdb,cn=config: namingContext "" already served by a preceding hdb database


Any thoughts?

The 6.0.10NE system did not have any issues prior to the upgrade

This is a single server installation on Ubuntu 8 (32bit).