Hi guys,

I am trying to migrate an existing zimbra-installation to a virtual machine which has no external ip (nat).
On the vm-host, I used some iptables for port-forwarding:
Code:
iptables -t nat -A PREROUTING -p tcp --dport 2222 -j DNAT --to 172.16.84.128:22
iptables -t nat -A PREROUTING -p tcp --dport 60080 -j DNAT --to 172.16.84.128:60080
iptables -t nat -A PREROUTING -p tcp --dport 60443 -j DNAT --to 172.16.84.128:60443
iptables -t nat -A PREROUTING -p tcp --dport 7071 -j DNAT --to 172.16.84.128:7071
iptables -t nat -A PREROUTING -p tcp --dport 7025 -j DNAT --to 172.16.84.128:7025
iptables -t nat -A PREROUTING -p tcp --dport 143 -j DNAT --to 172.16.84.128:143
iptables -t nat -A PREROUTING -p tcp --dport 993 -j DNAT --to 172.16.84.128:993
iptables -t nat -A PREROUTING -p tcp --dport 25 -j DNAT --to 172.16.84.128:25
iptables -t nat -A PREROUTING -p tcp --dport 465 -j DNAT --to 172.16.84.128:465
As you can see, 172.16.84.128 is the ip of my zcs-vm.

At first I want to say, that mail delivering seems to work, but sending mails does not.
I am always getting the following error:
mail for web.de loops back to myself
I guess it has something to do with the /etc/hosts so I want to show you may /etc/hosts:
Code:
127.0.0.1       localhost.localdomain   localhost
172.16.84.128   zimbravm.nilsbecker.net zimbravm
172.16.84.128   avenger.nilsbecker.net  avenger
zimbravm is the hostname of the vm. avenger was my old server, so many zimbra-configs still refer to avenger.nilsbecker.net. I know that there are possiblities to change the zimbra-hostname, but I've made some bad experinces with changing the zimbra-hostname.

I know that there are some threads discussion the "loops back to myself"-error, but they didn't help me.

Thanks in advance.
Great regards,
fish