Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Fedora 4 LDAP FAILED 256 ERROR

  1. #1
    Join Date
    Sep 2006
    Posts
    4
    Rep Power
    9

    Default Fedora 4 LDAP FAILED 256 ERROR

    I have been trying to get Zimbra running on my Fedora 4 box - but i haven't got that far - I keep receiving an error which states that LDAP has received an error I have tried installing it several times but i get the same error

    Does anyone know if there are any logs I should check or are there some tests I can perform:-

    This is the error ive been getting -

    Save config in file: [/opt/zimbra/config.3957]
    Saving config in /opt/zimbra/config.3957...Done
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.3957
    Initializing ldap...FAILED (256)


    Any help would be greatly appreciated thanks

    Peter

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Hi Peter,
    We would be glad to provide any help we can.

    First of all, what do your install logs say?

    Also, have you tried searching the forums? LDAP errors are covered a lot, but let us know. We're here to help.

    john

  3. #3
    Join Date
    Sep 2006
    Posts
    4
    Rep Power
    9

    Default

    Thanks i will look at the logs and get back to you - I have searched the forum regarding the LDAP issues and have seen a few which look similar to my issue which i'm experiencing and reading the posts and me being a Linux Newbie i'm wondering if LDAP is setup correctly on my machine

    thanks again

  4. #4
    Join Date
    Oct 2006
    Posts
    12
    Rep Power
    9

    Default FC5 Issue

    I had the same error when installing on FC5. A quick look at the installation log revealled that we were missing SSL libraries.

    If you don't have libssl.so.4, you can run:

    "yum provides libssl.so.4"

    which should show you which additional packages you may need to install.

  5. #5
    Join Date
    Sep 2006
    Posts
    19
    Rep Power
    9

    Default

    i have the same error which is at the last stage initialise ldap failed..

    i wonder where can i view the installation log ...

  6. #6
    Join Date
    Oct 2006
    Posts
    12
    Rep Power
    9

    Default tmp

    It should tell you during installation where the log file is kept. If I recall, ours was stored under /tmp

  7. #7
    Join Date
    Oct 2006
    Posts
    8
    Rep Power
    9

    Default

    I am having the same problem. I have had this problem with Fedora Core 5 and 4 and I had trouble with centOS (about the same point). My log in tmp shows it stopping at the slapd:

    ERROR - Failed to start slapd

    I am not sure how to fix this and I haven't found anything in the forum that helps me with the problem. Could it be that I don't have a DNS setup for it yet?

    On a side note, can does anyone know how to set up a DNS using Bind and Fedora or CentOS?

  8. #8
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    We need to know what the logs say.
    /var/zimbra.log

    If this is a fresh install, then the most likely cause is that you installed another instance of LDAP, and need to stop that service and disable it before installing.

    centos:
    service ldap stop

  9. #9
    Join Date
    Oct 2006
    Posts
    8
    Rep Power
    9

    Default

    I did the service ldap stop and it said "ldap: unrecognized service". Here is my install log and yes it was a fresh install.

    Setting defaults...


    DNS ERROR resolving MX for mailhost.test.com

    It is suggested that the domain name have an MX record configured in DNS

    Done

    Checking for port conflicts

    Port conflict detected: 25 (zimbra-mta)

    Operations logged to /tmp/zmsetup.log.27268

    Setting local config values...
    Setting local config zimbra_server_hostname to mailhost.test.com

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_server_hostname=mailhost.test.com

    Setting local config ldap_master_url to ldap://mailhost.test.com:389

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_master_url=ldap://mailhost.test.com:389

    Setting local config ldap_url to ldap://mailhost.test.com:389

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_url=ldap://mailhost.test.com:389

    Setting local config ldap_port to 389

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_port=389

    Setting local config ldap_host to mailhost.test.com

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_host=mailhost.test.com

    Setting local config zimbra_uid to 501

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_uid=501

    Setting local config zimbra_gid to 501

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_gid=501

    Setting local config zimbra_user to zimbra

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_user=zimbra

    Setting local config av_notify_user to admin@mailhost.test.com

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e av_notify_user=admin@mailhost.test.com

    Setting local config ssl_allow_untrusted_certs to TRUE

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ssl_allow_untrusted_certs=TRUE

    Done

    Setting up CA...
    *** Running as zimbra user: cd /opt/zimbra; zmcreateca

    ** Creating CA private key

    Generating a 1024 bit RSA private key
    ..............++++++
    ......................++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/ca/ca.key'
    -----
    ** Creating CA cert

    Signature ok
    subject=/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite
    Getting Private key
    unable to write 'random state'
    Done

    Creating SSL certificate...
    chmod: cannot access `/jre/lib/security/cacerts': No such file or directory
    *** Running as zimbra user: cd /opt/zimbra; zmcreatecert

    ** Importing CA

    Certificate was added to keystore
    keytool error: java.io.FileNotFoundException: /opt/zimbra/java/jre/lib/security/cacerts (Permission denied)
    ** Creating keystore

    ** Creating server cert request

    Generating a 1024 bit RSA private key
    .....++++++
    .................................................. .....................++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/server/server.key'
    -----
    ** Signing cert request

    Using configuration from /opt/zimbra/ssl/ssl/zmssl.cnf
    Check that the request matches the signature
    Signature ok
    Certificate Details:
    Serial Number: 2 (0x2)
    Validity
    Not Before: Oct 11 20:12:07 2006 GMT
    Not After : Oct 11 20:12:07 2007 GMT
    Subject:
    countryName = US
    stateOrProvinceName = N/A
    organizationName = Zimbra Collaboration Suite
    commonName = mailhost.test.com
    X509v3 extensions:
    X509v3 Basic Constraints:
    CA:FALSE
    Netscape Comment:
    OpenSSL Generated Certificate
    X509v3 Subject Key Identifier:
    77:39:C2:76:C0:87:39:FC:41:5F:4B:6B:56:45:5C:90:8B :F9:9B:7B
    X509v3 Authority Key Identifier:
    DirName:/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite
    serial:86:C4:2A:99:A0E:3C:C0

    X509v3 Key Usage:
    Digital Signature, Non Repudiation, Key Encipherment
    Certificate is to be certified until Oct 11 20:12:07 2007 GMT (365 days)

    Write out database with 1 new entries
    Data Base Updated
    unable to write 'random state'
    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=mailhost.test.com
    Getting CA Private Key
    unable to write 'random state'
    chmod: cannot access `/jre/lib/security/cacerts': No such file or directory
    Done

    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit

    ERROR - failed to start slapd

    FAILED (256)



    ERROR




    Configuration failed


    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to

    complete the configuration

  10. #10
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    I did the service ldap stop and it said "ldap: unrecognized service". Here is my install log and yes it was a fresh install.
    i think it's usually called slapd on most distros - try service slapd stop

    DNS ERROR resolving MX for mailhost.test.com
    It is suggested that the domain name have an MX record configured in DNS
    make sure you have mx record set for the domain test.com

    Checking for port conflicts
    Port conflict detected: 25 (zimbra-mta)
    you've already got a conflicting mta running - try shutting down existing sendmail/qmail/exim/postfix instances. ditto for existing openldap, cyrus/courier etc

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. Postfix problem
    By jimbo in forum Administrators
    Replies: 46
    Last Post: 07-23-2007, 06:24 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  4. Replies: 4
    Last Post: 11-15-2006, 12:16 PM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •