Results 1 to 4 of 4

Thread: [SOLVED] Problem installing LDAP replica (7.0.0)

  1. #1
    Join Date
    Feb 2011
    Posts
    10
    Rep Power
    4

    Default [SOLVED] Problem installing LDAP replica (7.0.0)

    Hi,

    I'm trying to install an LDAP replica on a different host.

    I followed the recipe here, being the closest one to 7.0.0 I could find:

    LDAP Replication Installation

    Everything works during the install, and I have configured each item marked with "**"

    This is the problem:

    There are no more items marked with (**) yet it still provides the warning and refuses to accept the configuration.

    e.g.

    Code:
    Main menu
    
       1) Common Configuration:                                                  
            +Hostname:                             mxbu1.vantage.com             
            +Ldap master host:                     mx1.vantage.com               
            +Ldap port:                            389                           
            +Ldap Admin password:                  set                           
            +Secure interprocess communications:   yes                           
            +TimeZone:                             America/New_York              
    
       2) zimbra-ldap:                             Disabled                      
       3) Enable default backup schedule:          yes                           
       r) Start servers after configuration        yes                           
       s) Save config to file                                                    
       x) Expand menu                                                            
       q) Quit                                    
    
    Address unconfigured (**) items  (? - help)
    Adding to that, when I run zmldapenablereplica as instructed on the replica, I get:

    Code:
    [zimbra@mxbu1 ~]$ libexec/zmldapenablereplica libexec/zmldapenablereplica: line 58: [: =: unary operator expected
    libexec/zmldapenablereplica: line 293: [: =: unary operator expected
    Looking for LDAP installation...succeeded
    Verifying ldap on ...FAILED
    ERROR: Unable to verify ldap connection on  - exiting
    /opt/zimbra/openldap/bin/ldapsearch -x -Z -s base -b cn=zimbra -H  -D uid=zimbra,cn=admins,cn=zimbra -w 2wOHsuMWr
    Could not parse LDAP URI(s)=-D (3)


    Am I missing something????

    --Freddy
    Last edited by CSVantage; 02-25-2011 at 09:59 AM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by CSVantage View Post
    I'm trying to install an LDAP replica on a different host.

    I followed the recipe here, being the closest one to 7.0.0 I could find:
    Why not follow the ZCS 7 Multi-Server documentation?
    Last edited by phoenix; 02-25-2011 at 12:07 PM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2011
    Posts
    10
    Rep Power
    4

    Default

    Thanks - for some reason that didn't come up. Worked perfectly with that recipe.

    --Freddy

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by CSVantage View Post
    Thanks - for some reason that didn't come up. Worked perfectly with that recipe.
    Glad you've fixed it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Upgrade from 6.0.10NE to 7.0.0 fails with LDAP error.
    By Angrysmiley in forum Installation
    Replies: 5
    Last Post: 08-19-2011, 11:51 AM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  3. Replies: 1
    Last Post: 11-19-2007, 06:32 AM
  4. Replies: 4
    Last Post: 11-15-2006, 12:16 PM
  5. LDAP & spam classification problem?
    By phoenix in forum Users
    Replies: 3
    Last Post: 09-30-2005, 12:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •