Please forgive me, I'm new to DNS and I'm posting as a last resort since I've been trolling the forums for answers and I just can't figure out my issues. I've tried and failed at several ZCA and ZCS installs to this point because of DNS issues so I've started fresh and decided that I want the DNS fixed before the install.
Please keep in mind that I'm in a test environment on VMs to use this and so I cannot connect directly to RHN, only what our production loads have updated (meaning no bind9 just dnsmasq).

The setup is RHEL5 in a VM using dnsmasq to do the split dns, and the DNS server I want to point to is on Windows 2003 Server SP1 in another VM in the same vCenter.

In the Windows DNS I set up a Host(A) record for pointing to the zimbra vm ip address and an MX record based off this A.

The output from the split dns wiki:

dig mx

Question Section: IN MX
Answer Section: 3600 IN MX 1
Additional Section: 3600 IN A [ZimbraVM IP address]

dig any

Questions section: IN ANY
Answer Section: 600 in A [DNS Server IP] 3600 IN A [DNS Secondary IP] 3600 IN NS 3600 IN SOA host master 1821 900 600 86400 3600 3600 IN MX 1 0 IN TYPE65281 \# 20 00000000000000020000000384000000011405CCAC

Additional Section: 3600 IN A [DNS Server IP] 3600 IN A [ZimbraVM IP]

host $(hostname)
connection timed out; no servers could be reached

cat /etc/resolv.conf
nameserver [DNS Server IP]

cat /etc/hosts localhost.localdomain localhost
[ZimbraVM IP] zimbra

/etc/dnsmasq.conf file
server=[DNS Server Secondary IP]
server=[DNS Server IP],,5

Any suggestions, or pointing me to the right thread would be fine. I've been trolling threads for about a week now though, and I'm probably just missing what I need.
Thanks in advance for all your help!