Results 1 to 3 of 3

Thread: Zimbra on FC4

  1. #1
    Join Date
    Oct 2005
    Rep Power

    Default Zimbra on FC4

    I had a problem which I already fixed, concerning Copyright not being a know keyword. I fixed it by editing ZimbraBuild/Makefile and in each of the spec files (search for spec, you'll find 3 files) I did a sed -e '/Copyright/License/' with all the other sed's in there.

    I now have another problem, which I can't seem to fix:
    [javac] 1. ERROR in /home/aeldaly/zcs/Ajax/src/com/zimbra/ajax/imagemerge/
        [javac]  (at line 100)
        [javac]     mBufImg =;
        [javac]                      ^^^^
        [javac] The method read(int, ImageReadParam) in the type ImageReader is not applicable for the arguments (int)
        [javac] ----------
        [javac] ----------
        [javac] 2. ERROR in /home/aeldaly/zcs/Ajax/src/com/zimbra/ajax/imagemerge/
        [javac]  (at line 440)
        [javac]     writer.write(buffImg);
        [javac]            ^^^^^
        [javac] The method write(IIOMetadata, IIOImage, ImageWriteParam) in the type ImageWriter is not applicable for the arguments (BufferedImage)
        [javac] ----------
        [javac] ----------
        [javac] 3. WARNING in /home/aeldaly/zcs/Ajax/src/com/zimbra/ajax/imagemerge/
        [javac]  (at line 28)
        [javac]     public class ImageMergeException extends Exception {
        [javac]                  ^^^^^^^^^^^^^^^^^^^
        [javac] The serializable class ImageMergeException does not declare a static final serialVersionUID field of type long
        [javac] ----------
        [javac] 3 problems (2 errors, 1 warning)
    /home/aeldaly/zcs/ZimbraWebClient/build.xml:108: Compile failed; see the compiler error output for details.
    Total time: 41 seconds
    make: *** [/home/aeldaly/zcs/ZimbraBuild/../ZimbraWebClient/build/dist/tomcat/webapps/zimbraAdmin.war] Error 1
    Does anyone know how to get around this?


  2. #2
    Join Date
    Aug 2005
    San Mateo, CA
    Rep Power


    What JDK are you using? Try 'which javac', we use SUN's 1.5_05 JDK. If you are using something different than your results may vary.

  3. #3
    Join Date
    Oct 2005
    Rep Power


    Yes. That was the problem. FC4 comes with the IBM version. I removed java with yum, which removed ant and other java related things as well.

    I then installed Sun's java, apache ant and installed them. Made a symlink in /usr/local/java, updated PATH to include where java and ant are, and all worked with no issues.

Similar Threads

  1. Replies: 26
    Last Post: 04-19-2011, 09:24 AM
  2. Removing hostname from hosts file fixed prob.
    By lemur in forum Installation
    Replies: 10
    Last Post: 06-13-2007, 06:29 PM
  3. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 12:11 PM
  4. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  5. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts