Results 1 to 4 of 4

Thread: multi-domain with SSL? needs different IP addresses still?

  1. #1
    Join Date
    Jan 2009
    Posts
    66
    Rep Power
    6

    Default multi-domain with SSL? needs different IP addresses still?

    I understand zimbra can handle multiple email domains, e.g. abc@domain1.com, xyz@domain2.com, jkf@domain3.com.

    But how does it handle imaps/smtps? My understanding from the web server side of the business is that you would need to have different external IP addresses to handle the SSL/TLS component, since the connection is encrypted before the virtual domain is resolved, so I assume it's likely the same with Zimbra?

    i.e. to handle three different email domains, I need three different external IPs?

    Thanks in advance for any clarification.

  2. #2
    Join Date
    Jan 2009
    Posts
    66
    Rep Power
    6

    Default

    I did some searching, and found this article, Multiple SSL Virtual Hosts 5.0 - Zimbra :: Wiki, as well as bug 8128 marked as fixed (Bug 8128 – multiple SSL certificates on one server).

    Has anybody tested that this latter fix works? and if so, that means we don't need to manually run through the setup steps in the article now?

  3. #3
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    You don't need multiple IP addresses. You do of course need multiple DNS entries if you'd like mail to be delivered to those domains, and if you'd like users to be able to log into zimbra.domain1.com, zimbra.domain2.com, etc. (which you'd generally combine with the Virtual Hosts option).

    You can either use a UCC cert that supports multiple domains (I've done this on ZCS 5 and ZCS 6), or multiple SSL certs if you have Zimbra 7. The wiki article is old and although it may still work for some versions of ZCS, I would imagine that it was developed as a workaround before these more straightforward approaches became available.

  4. #4
    Join Date
    Jan 2009
    Posts
    66
    Rep Power
    6

    Default

    Thanks Elliot, I've just received shipment of the new servers, so will now start doing some initial POC and testing to see how it works. Appreciate your feedback.

Similar Threads

  1. Replies: 1
    Last Post: 03-02-2011, 02:43 AM
  2. [SOLVED] Autocompletion of new domain addresses in GAL
    By russgalleywood in forum Installation
    Replies: 18
    Last Post: 10-25-2010, 07:41 PM
  3. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  4. Replies: 7
    Last Post: 03-12-2008, 05:25 AM
  5. multi domain / multi IP / SMTP HELO problem
    By fisch09 in forum Administrators
    Replies: 3
    Last Post: 04-04-2007, 05:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •