Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [SOLVED] zimbra server on a private IP and having trouble

  1. #1
    Join Date
    Apr 2011
    Posts
    62
    Rep Power
    4

    Default [SOLVED] zimbra server on a private IP and having trouble

    Dear All,

    I have just implemented the open source version 7 of zimbra and its honestly a wonderful product.
    had initial trouble but got everything working fine.
    we would be moving to the NE version but just in initial stages and letting all our users to get comfortable with

    The issue i am having is not really directly related to zimbra but i would hightly apprecite n be thnkful if someone out there would advice and help me


    I am running the followin for a couple of years with absolutlety no issues

    Linux server
    with Sendmail as mta, mail Scanner, mailwatch,and squirrel mail
    the same server runs Bind as my primary dns server and ofcourse on a public IP
    domain name is --- example.com

    Now i have implemented zimbra OPen source version on a private IP ( 172.16.10.1 ) a
    sub domain name --- mail.example.com
    created a couple of users and everything working perfect. users are able to send mail to one user to another and also to users on example.com and also they can reply back

    I needed the zimbra mail users to send emails to outside world so i used my current sendmail server as a relay in mta setting in admin console and as a zimbra user able to send mail to yahoo perfectly

    I changed the MX record from the private ip of zimbra host to the ip of my current sendmail cum dns server setup a split dns and checked.

    when i send a mail from yahoo to a zimbra user ( i monitor my mail log on the sendmail server ) the mail comes but it is returned back saying no such user..

    the error is obvious since there is no user present on the sendmail server.
    the user is actually on the zimbra server

    Now how would i get mail from outside world get to my zimbra server or basically how could i forward mail comming to user@mail.example.com to my zimbra server
    i dont want the zimbra server to have a public IP .. tried googling a lot but no much luck

    would really apprecite your advice and help

    regards


    simon

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    If you want them to co-exist in the same domain then read the Split Domain article for an answer.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Apr 2011
    Posts
    62
    Rep Power
    4

    Default zimbra server on a private ip having trouble receiving mail

    Thanks phoenix for the quick reply and apprecite your suggestion
    As I said before since I am running sendmail on my old server with a public IP and dont want to do away with it since I have over 500 users.
    the domain is example.com

    now on my zimbra server which is on a private IP i am creating new users and probably slowly move existing users who are interested ( once they see the over whelming features of Zimbra) to zimbra.
    the domain for the zimbra server is comm.example.com

    but would still like to have the current sendmail mail server running .

    since my mx record for my zimbra server points to the public ip on which dns and sendmail reside i feel its the sendmail job to forward any mail comming from internet to user@example.com sendmail should take care of it as it is doing right now
    but if any mail comes to user@comm.example.com it should be sent to my private IP zimbra server

    Now as I ahve seen in the sendmail logs that mail sent to user@comm.example.com reaches to the server which runs sendmail but after that the mail is not forwarded to zimbra server but instead bounced back saying no user found

    I feel ( maybe I am wrong ) but would aprecite to your advice that sendmail has to be aware that if any mail comes with user@comm.example.com dont proceess it but just forward it ...

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by ben1967 View Post
    I feel ( maybe I am wrong ) but would aprecite to your advice that sendmail has to be aware that if any mail comes with user@comm.example.com dont proceess it but just forward it ...
    Yes, that correct and you will need to create the user on the Zimbra server and migrate their email as well.

    I'm assuming Sendmail is the primary server hhere, take a look at this article as well: Split Domain with a Sendmail Primary - Zimbra :: Wiki
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Apr 2011
    Posts
    62
    Rep Power
    4

    Default

    thnks so much for ur quick reply and giving me the link

    i really do apprecite

    i will look at this and implement it


    thanks



    regards


    simon

  6. #6
    Join Date
    Apr 2011
    Posts
    62
    Rep Power
    4

    Default

    dear phoneix,

    jus missed to metion in my earlier post that

    the users created on zimbra server will be new users ..
    so I guess i dont have to do anything on the /etc/aliases file

    apprecite ur suggestion





    regards

    simon

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by ben1967 View Post
    the users created on zimbra server will be new users .. so I guess i dont have to do anything on the /etc/aliases file
    As long as Sendmail is forwarding unknown addresses to the Zimbra server then you're correct, you won't need to do anything.
    Last edited by phoenix; 05-11-2011 at 08:33 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Apr 2011
    Posts
    62
    Rep Power
    4

    Default

    thnkas once again .. i will be testing the above out in a couple of days or so and would let you know..

    right now I do have a ZCS open source on a private ip and its been workin fine
    for our network

    thnks a million once again for quick reply.

    regards

    simon

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by ben1967 View Post
    thnkas once again .. i will be testing the above out in a couple of days or so and would let you know..

    right now I do have a ZCS open source on a private ip and its been workin fine
    for our network

    thnks a million once again for quick reply.
    You're welcome and good luck. If everything is OK then you can mark this thread as Solved from the Thread Tools drop-down at the top of the page.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    Apr 2011
    Posts
    62
    Rep Power
    4

    Default

    dear All,

    I did setup the above setup ..
    let me re explain

    my domain will be abc.com

    the sendmail host name is mail

    my zimbra server name is zimbra
    the simbra server has a split dns running as per the below document

    Split DNS - Zimbra :: Wiki

    and my sendmail server is configured as a smart host in zimbra admin console server settings option



    I have a setup above new domain since I dont want to to disturb my current working sendmail server

    what I actually need is my zimbra server to be a secondary and sendmail as primary

    also only the acounts which do not exists on the sendmail primary server should be automatically send to the zimbra server

    now as per the advices and help got from phoenix i followed the below link

    Split Domain with a Sendmail Primary - Zimbra :: Wiki

    I have a user name sim created on my sendmail server
    and a user mel created on zimbra server

    I can send mail from either sim or mel to each other and to outside world also
    but from outside world i can send mail to sim and not to mel

    when I send a mail from yahoo to mel on the sendmail server maillog i c the below
    --------------
    May 21 01:49:27 mail sendmail[5649]: p4KMnQfb005647: to=, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=123298, relay=zimbra.int. [91.198.134.30], dsn=2.0.0, stat=Sent (Ok: queued as 01F598E027F)
    May 21 01:49:28 mail sendmail[5650]: p4KMnSab005650: from=, size=4121, class=0, nrcpts=1, msgid=<218935.22498.qm@web112617.mail.gq1.yahoo.com>, bodytype=7BIT, proto=ESMTP, daemon=MTA, relay=zimbra [91.198.134.30]
    May 21 01:49:28 mail sendmail[5652]: STARTTLS=client, relay=zimbra.int., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    May 21 01:49:28 mail sendmail[5652]: p4KMnSab005650: to=, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=124121, relay=zimbra.int. [91.198.134.30], dsn=2.0.0, stat=Sent (Ok: queued as C2B9F8E027F)
    May 21 01:49:28 mail sendmail[5653]: p4KMnSkT005653: from=, size=4944, class=0, nrcpts=1, msgid=<218935.22498.qm@web112617.mail.gq1.yahoo.com>, bodytype=7BIT, proto=ESMTP, daemon=MTA, relay=zimbra [91.198.134.30]
    May 21 01:49:28 mail sendmail[5655]: STARTTLS=client, relay=zimbra.int., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    May 21 01:49:28 mail sendmail[5655]: p4KMnSkT005653: to=, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=124944, relay=zimbra.int. [91.198.134.30], dsn=2.0.0, stat=Sent (Ok: queued as 40B908E027F)
    May 21 01:49:29 mail sendmail[5656]: p4KMnT05005656: from=, size=5767, class=0, nrcpts=1, msgid=<218935.22498.qm@web112617.mail.gq1.yahoo.com>, bodytype=7BIT, proto=ESMTP, daemon=MTA, relay=zimbra [91.198.134.30]
    May 21 01:49:29 mail sendmail[5658]: STARTTLS=client, relay=zimbra.int., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    May 21 01:49:29 mail sendmail[5658]: p4KMnT05005656: to=, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=125767, relay=zimbra.int. [91.198.134.30], dsn=2.0.0, stat=Sent (Ok: queued as 0DD968E027F)
    May 21 01:49:30 mail sendmail[5659]: p4KMnTPj005659: from=, size=6590, class=0, nrcpts=1, msgid=<218935.22498.qm@web112617.mail.gq1.yahoo.com>, bodytype=7BIT, proto=ESMTP, daemon=MTA, relay=zimbra [91.198.134.30]
    May 21 01:49:30 mail sendmail[5659]: p4KMnTPj005659: SYSERR(root): Too many hops 26 (25 max): from via zimbra, to
    ----
    this sttes that there is loop if im not mistaken
    -------

    then just for testing I commented the mel: mel@zimbra.int entry in my /etc/aliases file on my sendmail server and i see the below message in my /var/log/maillog

    mail sendmail[5593]: p4KMLcdK005593: ... User unknown

    any advice , help or links on how to forward users not in my sendmail server to the zimbra server..

    i really would appreciate your help and advice

    regards

    simon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •