Results 1 to 4 of 4

Thread: Users with phantom emails, messages cannot be deleted or moved...

  1. #1
    Join Date
    Apr 2011
    Rep Power

    Default Users with phantom emails, messages cannot be deleted or moved...

    Good morning all; I'm encountering issues with my ZCS 6.0.1_GA install over Ubuntu 8.04.4 x32 LTS. Our single mail server is not behaving properly and I think I have a database issues going on, but I'm a zimbra newb and could really use some expert help to fix the issue. It's my comapny's mission critical, standalone mail server.

    Our mail is not physical, it's VM hosted on VMware ESXi 4.1. I have not moved or migrated it in a while. Over the past few weeks, users have begun to report issues such as phantom unread message counts which cannot be reset, and most recently, users are getting some spam in their inboxes which they can neither move, delete, or mark read. Upon trying to delete the messages through webclient, they get the following error:

    method:	MsgActionRequest
    msg:	system failure: inconsistent state: unread < 0 for item 2
    code:	service.FAILURE
    detail:	soap:Receiver
    trace:	btpool0-27:1308658379252:5f664561a33659b4
    Body: {
      MsgActionRequest: {
        _jsns: "urn:zimbraMail",
        action: {
          id: "4785",
          l: "3",
          op: "move"
    Header: {
      context: {
        _jsns: "urn:zimbra",
        account: {
          _content: "",
          by: "name"
        authToken: "(removed)",
        session: {
          _content: 1274,
          id: 1274
        userAgent: {
          name: "ZimbraWebClient - FF3.0 (Win)",
          version: "6.0.1_GA_1816.UBUNTU8"
    I am also encountering javascript errors when trying to make some changes in the admin control panel, but this has been going on a lot longer. I've been using the CLI to do maintenance that I can't do with the UI.

    It's worth noting that we had a database corruption a few months ago during an hour or two of undervolted, dirty power. I had to dump and reload the database according to the directions on the forums. This fixed almost all of the issues with the DB, but recent issues may be fallout from that problem. The fallout from that was only a damaged calendar for one user, who is not concerned with the issue since they don't really use their cal.

    I've searched the forums high and low but have not been able to find a user with a similar situation remedy. I don't know what else to do and am becoming increasingly frustrated spending countless hours trying to fix the issue unsuccessfully.

    On top of all of this,

    I need to move this server from its current 32 bit host to a new 64 bit host and was going to follow the guide to do so, but I don't want to move a broken install. We need to get on the 64 bit platform so I the upgrade paths are clear again. I understand that 32 bit is now more or less deprecated and won't be supported or developed for much longer, if not at all.

    What is a better course of action? Fix what I have and then move it, or move it and then fix it? Or, can I export the data and inject it into a new host? Is there a way to export all settings and user accounts to a backup so they can be restored to a new host?

    I'm desperately seeking help - I have no idea where to start or what what to look at to diagnose this problem, but I will provide any info necessary to remedy it.

  2. #2
    Join Date
    Apr 2011
    Rep Power

    Default Never fails...


    Just had a user with a phantom unread message show up. So, the problem is persisting somehow. Can someone help me fix this? Not sure what else to do.


    I always winding up finding some sort of solution right after I make a post. For anyone else with the same issue, running zmprov rmc will fix the mailbox count and error issues.

    [Edit] This did not solve the problem.
    Last edited by loganphyve; 06-27-2011 at 09:39 AM.

  3. #3
    Join Date
    Apr 2011
    Rep Power

    Default Help?

    Anyone? I can't be the only one that's ever had this problem

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    You should update your forum profile with the output of the following command (do not post the output in this thread):

    zmcontrol -v
    Quote Originally Posted by loganphyve View Post
    Anyone? I can't be the only one that's ever had this problem
    No, you're not and it has been covered many times in the forums: +"system failure: inconsistent state: unread" +solved - Yahoo! Search Results


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. [SOLVED] Re-creating the spam training e-mail account
    By richard-hdd in forum Administrators
    Replies: 21
    Last Post: 03-20-2012, 07:34 AM
  2. Deleted messages stay on disk
    By asemenov in forum Administrators
    Replies: 0
    Last Post: 04-21-2011, 12:00 AM
  3. Users receiving email messages 'late'
    By tenpagyatso in forum Administrators
    Replies: 0
    Last Post: 11-09-2010, 07:31 AM
  4. Restore deleted users Email
    By amgaa in forum Administrators
    Replies: 0
    Last Post: 12-10-2007, 12:33 PM
  5. Deleted files not freeing their handle in /tmp
    By Centurion in forum Administrators
    Replies: 5
    Last Post: 12-08-2007, 03:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts