Results 1 to 2 of 2

Thread: Bayes score not showing in headers.

  1. #1
    Join Date
    Dec 2005
    Posts
    94
    Rep Power
    9

    Default Bayes score not showing in headers.

    Ok, I'm nearly ready to roll this out as a production server, just a couple little details left.

    OS: Ubuntu 6.06 LTS in Vmware
    ZCS: zcs-4.0.2_GA_362.DEBIAN3.1.tgz

    Looking at the X-Spam-Status headers there is no bayes score (i.e. BAYES_00=-2.599), many other test scores there but no bayes.

    Originally used zmtrainsa to feed it around 2,000 spam and 1,000 ham - that works without error.
    Blew away the bayes database in /opt/zimbra/amavisd/.spamassassin and fed it another 250 spam and 210 ham, bayes database files were re-created as a result. Ran zmcontrol stop - start, still no score in the headers.

    Logs are clean.

    Added bayes_path /opt/zimbra/amavisd/.spamassassin/bayes
    to /opt/zimbra/conf/salocal.cf.in and ran zmcontrol stop - start. Still no score in the headers.

    On my production server (running qmail, vpopmail, spamassassin 2.x, etc) I would run spamassassin -D --lint and get some output but haven't been able to find the equivalent command under zimbra.

    Any suggestions?
    Last edited by brained; 10-21-2006 at 08:50 PM.

  2. #2
    Join Date
    Dec 2005
    Posts
    94
    Rep Power
    9

    Default Additional Info

    Looked at this post:
    http://www.zimbra.com/forums/showthread.php?t=2914
    and saw it suggested to run sh -x zmsatrain for debugging.

    Before I've run the zmsatrain as the installed cron job and the spamtrain.log showed a successful run with no errors, and have also run it standalone against a specific folder for a particular user and it also ran with out error.

    Running sh -s zmsatrain yielded this:
    sh -x zmtrainsa
    ++ whoami
    + '[' xzimbra '!=' xzimbra ']'
    ++ dirname zmtrainsa
    + source ./zmshutil
    /opt/zimbra/bin/zmtrainsa: line 66: ./zmshutil: No such file or directory

    Changing line 66 from this:
    source `dirname $0`/zmshutil || exit 1
    to this:
    source /opt/zimbra/bin/zmshutil || exit 1
    results in a successful run.

    Now all three (cron job, manual run and sh -x zmsatrain) all run without error. Still no bayes score in the headers though.

Similar Threads

  1. Disable outbound SA check, and/or remove headers?
    By RACjr in forum Administrators
    Replies: 6
    Last Post: 01-22-2009, 08:20 AM
  2. Replies: 6
    Last Post: 03-02-2007, 04:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •