Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: zimbra install fails

  1. #1
    mikelurk Guest

    Default zimbra install fails

    My install of Zimbra fails every time I try, but I think I know why. I am running a web server on my network. Is there a way of installing Zimbra while still running a web server on the network.
    Thanks for any help

    Mike

  2. #2
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    9

    Default

    Quote Originally Posted by mikelurk
    My install of Zimbra fails every time I try, but I think I know why. I am running a web server on my network. Is there a way of installing Zimbra while still running a web server on the network.
    Sure, you can definitely run it while running a webserver on your network.

    Do you have some more information on the installation failure? Do you get any error messages?

    During the installation itself, a log file is produced. What would be really helpful is to be able to see that log file.

    It's located in /tmp/install.log.XYZ (where XYZ is a seemingly random set of numbers).

    Really, the best thing to do would be to delete all the log files (there would be one for every installation attempt) by doing: cd /tmp; rm install.log*

    After that, try the installation again. Then, post a followup to this thread, and attach your install log to that.

    Have a good one,
    -Eric

  3. #3
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by andreychek
    It's located in /tmp/install.log.XYZ (where XYZ is a seemingly random set of numbers).
    FYI;

    XYZ is the proccess is (pid) of the running install.

  4. #4
    mikelurk Guest

    Default

    Quote Originally Posted by andreychek
    Sure, you can definitely run it while running a webserver on your network.

    Do you have some more information on the installation failure? Do you get any error messages?

    During the installation itself, a log file is produced. What would be really helpful is to be able to see that log file.

    It's located in /tmp/install.log.XYZ (where XYZ is a seemingly random set of numbers).

    Really, the best thing to do would be to delete all the log files (there would be one for every installation attempt) by doing: cd /tmp; rm install.log*

    After that, try the installation again. Then, post a followup to this thread, and attach your install log to that.

    Have a good one,
    -Eric
    here is the install log. hope you can help.

    Preparing packages for installation...
    useradd: warning: the home directory already exists.
    Not copying any file from skel directory into it.
    zimbra-core-3.0.M1_21.FC3-20050920155949_
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    Preparing packages for installation...
    zimbra-ldap-3.0.M1_21.FC3-20050920155949_
    Preparing packages for installation...
    zimbra-mta-3.0.M1_21.FC3-20050920155949_
    Preparing packages for installation...
    zimbra-snmp-3.0.M1_21.FC3-20050920155949_
    Preparing packages for installation...
    zimbra-store-3.0.M1_21.FC3-20050920155949_
    COMMAND: /opt/zimbra/libexec/zmmyinit
    * Creating required directories
    * Generating mysql config /opt/zimbra/conf/my.cnf
    * Creating database in /opt/zimbra/db/data
    * Starting mysql server
    * Loading schema /opt/zimbra/db/db.sql
    * Loading version from /opt/zimbra/db/versions-init.sql
    * Setting random password for mysql root user in zimbra local config
    * Setting random password for mysql zimbra user in zimbra local config
    * Changing mysql root user password
    * Changing mysql zimbra user password
    * Changed zimbra mysql user password
    COMMAND: zmlocalconfig -e zimbra_server_hostname=zimbramail.haileyssandbox.d yndns.org
    COMMAND: zmlocalconfig -e ldap_host=zimbramail.haileyssandbox.dyndns.org
    COMMAND: zmlocalconfig -e ldap_port=389
    COMMAND: /opt/zimbra/libexec/zmldapinit
    Started slapd: pid
    ldap_bind: Invalid credentials (49)
    ldap_bind: Invalid credentials (49)
    COMMAND: zmprov cs zimbramail.haileyssandbox.dyndns.org
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    COMMAND: zmprov cd haileyssandbox.dyndns.org
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    COMMAND: zmprov mcf zimbraDefaultDomainName haileyssandbox.dyndns.org
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    COMMAND: zmprov ca admin@haileyssandbox.dyndns.org password zimbraIsAdminAccount TRUE
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    COMMAND: id=`zmprov gs zimbramail.haileyssandbox.dyndns.org | grep zimbraId | awk '{print $2}'`; for i in `zmprov gc default | grep zimbraMailHostPool | sed 's/zimbraMailHostPool: //'`; do host="$host zimbraMailHostPool $i"; done; zmprov mc default $host zimbraMailHostPool $id
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    zmprov [cmd] [args ...]

    CreateAccount(ca) {name@domain} {password} [attr1 value1 [attr2 value2...]]
    DeleteAccount(da) {name@domain|id}
    GetAccount(ga) {name@domain|id}
    GetAllAccounts(gaa) [-v] [{domain}]
    GetAllAdminAccounts(gaaa) [-v]
    ModifyAccount(ma) {name@domain|id} [attr1 value1 [attr2 value2...]]
    SetPassword(sp) {name@domain|id} {password}
    AddAccountAlias(aaa) {name@domain|id} {alias@domain}
    RemoveAccountAlias(raa) {name@domain|id} {alias@domain}
    SetAccountCos(sac) {name@domain|id} {cos-name|cos-id}
    SearchAccounts(sa) [-v] {ldap-query} [limit {limit}] [offset {offset}] [sortBy {attr}] [attrs {a1,a2...}] [sortAscending 0|1*] [applyCos [0|1*] [domain {domain}]
    SearchGal(sg) {domain} {name}
    RenameAccount(ra) {name@domain|id} {newName@domain}

    CreateDomain(cd) {domain} [attr1 value1 [attr2 value2...]]
    DeleteDomain(dd) {domain|id}
    GetDomain(gd) {domain|id}
    GetAllDomains(gad) [-v]
    ModifyDomain(md) {domain|id} [attr1 value1 [attr2 value2...]]

    CreateCos(cc) {name} [attr1 value1 [attr2 value2...]]
    DeleteCos(dc) {name|id}
    GetCos(gc) {name|id}
    GetAllCos(gac) [-v]
    ModifyCos(mc) {name|id} [attr1 value1 [attr2 value2...]]
    RenameCos(rc) {name|id} {newName}

    CreateServer(cs) {name} [attr1 value1 [attr2 value2...]]
    DeleteServer(ds) {name|id}
    GetServer(gs) {name|id}
    GetAllServers(gas) [-v]
    ModifyServer(ms) {name|id} [attr1 value1 [attr2 value2...]]

    GetAllConfig(gacf)
    GetConfig(gcf) {name}
    ModifyConfig(mcf) attr1 value1 [attr2 value2...]

    CreateDistributionList(cdl) {list@domain}
    GetAllDistributionLists(gadl) [-v]
    GetDistributionList(gdl) {list@domain|id}
    DeleteDistributionList(ddl) {list@domain|id}
    AddDistributionListMember(adlm) {list@domain|id} {member@domain}
    RemoveDistributionListMember(rdlm) {list@domain|id} {member@domain}

    exit (quit)
    help (?)

    COMMAND: /opt/zimbra/libexec/zmmtainit zimbramail.haileyssandbox.dyndns.org
    COMMAND: zmlocalconfig -e av_notify_user=notify@zimbramail.haileyssandbox.dy ndns.org
    COMMAND: zmlocalconfig -e av_notify_domain=zimbramail.haileyssandbox.dyndns. org
    COMMAND: zmlocalconfig -e snmp_notify=0
    COMMAND: zmlocalconfig -e smtp_notify=0
    COMMAND: zmlocalconfig -e snmp_trap_host=localhost.localdomain
    COMMAND: zmlocalconfig -e smtp_source=none
    COMMAND: zmlocalconfig -e smtp_destination=none
    COMMAND: zmsnmpinit
    creating /opt/zimbra/conf/swatchrc
    COMMAND: zmprov ms zimbramail.haileyssandbox.dyndns.org zimbraServiceInstalled ldap zimbraServiceInstalled mailbox zimbraServiceInstalled mta zimbraServiceInstalled antivirus zimbraServiceInstalled antispam zimbraServiceInstalled snmp
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    COMMAND: zmprov ms zimbramail.haileyssandbox.dyndns.org zimbraServiceEnabled ldap zimbraServiceEnabled mailbox zimbraServiceEnabled mta zimbraServiceEnabled antivirus zimbraServiceEnabled antispam zimbraServiceEnabled snmp
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    COMMAND: zmlocalconfig -e zimbra_services="ldap mailbox mta antivirus antispam snmp"
    COMMAND: zmcreatecert
    ** Creating CA private key

    Generating a 1024 bit RSA private key
    ....++++++
    ..++++++
    writing new private key to '/opt/zimbra/ssl/ssl/ca/ca.key'
    -----
    ** Creating CA cert

    Signature ok
    subject=/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite/CN=localhost.localdomain
    Getting Private key
    ** Importing CA

    Certificate was added to keystore
    keytool error: java.io.FileNotFoundException: /opt/zimbra/java/jre/lib/security/cacerts (Permission denied)
    ** Creating keystore

    ** Creating server cert request

    ** Signing cert request

    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=localhost.localdomain
    Getting CA Private Key
    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=localhost.localdomain
    Getting Private key
    COMMAND: zmcertinstall mailbox
    ** Importing server cert

    keytool error: java.lang.Exception: Failed to establish chain from reply
    COMMAND: zmtlsctl mixed
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    COMMAND: zmcertinstall mta /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key
    ** Importing server cert

    COMMAND: zmlocalconfig -e ssl_allow_untrusted_certs=true
    COMMAND: zmcontrol startup
    Calling startup (zimbramail.haileyssandbox.dyndns.org)

    perl /opt/zimbra/bin/zmmon &

    RESPONSE: (Zimbra::Mon::serviceInfo)
    host
    ip 72.138.232.73
    name zimbramail.haileyssandbox.dyndns.org
    COMMAND: zmlocalconfig -s > .localconfig.save.12913
    COMMAND: zmprov gs zimbramail.haileyssandbox.dyndns.org > .zmprov.zimbramail.haileyssandbox.dyndns.org.save. 12913
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    COMMAND: zmprov gacf zimbramail.haileyssandbox.dyndns.org > .zmprov.gacf.save.12913
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])


    The domain name of the web server is haileyssandbox.dyndns.org, if that makes a difference.The install was done after a ./install.sh -u and stopping the services for zimbra and rebooting the system, then an install.

    Mike

  5. #5
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    LDAP is/was running for your install. You need to kill it after the uninstall before trying to install again.

  6. #6
    mikelurk Guest

    Default

    Quote Originally Posted by KevinH
    LDAP is/was running for your install. You need to kill it after the uninstall before trying to install again.
    I checked again to see if LDAP was running and it is not, I used (ps -ef |grep slapd). Is there anything else that could be causing this problem. I am using the same domain name as the webserver. The webserver is running on the network during the install of Zimbra.

  7. #7
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    The error "LDAP: error code 49 - Invalid Credentials" saysthe installer was able to connect but had the wrong password. So something was listening on port 389. Can you try:

    install.sh -u
    rm -rf /opt/zimbra
    reboot

    Then install.sh

    This should give you a clear start.

  8. #8
    mikelurk Guest

    Unhappy

    Quote Originally Posted by KevinH
    The error "LDAP: error code 49 - Invalid Credentials" saysthe installer was able to connect but had the wrong password. So something was listening on port 389. Can you try:

    install.sh -u
    rm -rf /opt/zimbra
    reboot

    Then install.sh

    This should give you a clear start.
    I have tried that a number of time and still the same thing... same error.

  9. #9
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    What OS are you using? Did you do a minimal install as reccomended in the quick start guide?

  10. #10
    mikelurk Guest

    Default

    Quote Originally Posted by KevinH
    What OS are you using? Did you do a minimal install as reccomended in the quick start guide?
    OOOPs! I can't read. I did a workstation install. I'll try again using the minimal install.
    Thanks

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  3. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM
  4. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 07:23 AM
  5. Replies: 1
    Last Post: 11-23-2005, 12:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •