Results 1 to 3 of 3

Thread: A couple of install issues -- MX and domain

Hybrid View

  1. #1
    Join Date
    Sep 2006
    Location
    Virginia, USA
    Posts
    67
    Rep Power
    9

    Default A couple of install issues -- MX and domain

    Hello all,

    I am attempting to install 4.0.3 on my home network under Debian. I did a test install of 4.0.2 a few weeks ago, but am ready to tak the plunge. I am encountering a couple of problems though...

    First of all, the installer is telling me

    Code:
    DNS ERROR resolving MX for merrimac.foo.yi.org
    It is suggested that the domain name have an MX record configured in DNS
    Change domain name? [Yes]
    Now as far as I can tell, I have the DNS wired seven ways to Sunday:

    Code:
    # dig mail.foo.yi.org
    
    ;; ANSWER SECTION:
    mail.foo.yi.org. 86400 IN CNAME merrimac.foo.yi.org.
    merrimac.foo.yi.org. 86400 IN A 192.168.0.12
    Code:
    # dig MX foo.yi.org
    
    ;; ANSWER SECTION:
    foo.yi.org. 86400 IN   MX      10 merrimac.foo.yi.org.
    foo.yi.org. 86400 IN   MX      12 mekong.foo.yi.org.
    So I have a valid A record for merrimac, a CNAME record to mail.foo.yi.org and a valid MX record. Why is the installer still telling me that it cannot resolve the domain name?

    The other thing is where do I set the domain on the install? Since this install is for my home network, I don't want the default mail domain to be merrimac.foo.yi.org, I want it to be foo.yi.org. Where does that get set during the install? And would it be better to not set a maildomain of merrimac.foo.yi.org at all?

    thanks,
    --Storm

  2. #2
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    10

    Default

    The installer isn't saying it can't resolve the domain name. The installer is saying it can't find an MX record for merrimac.foo.yi.org. From your post you don't have an MX record for that nor do you want one. You want an MX record for foo.yi.org. Therefore at that prompt you need to say yes and type in foo.yi.org it will then find an MX record for that domain.

  3. #3
    Join Date
    Sep 2006
    Location
    Virginia, USA
    Posts
    67
    Rep Power
    9

    Default

    Quote Originally Posted by rsharpe
    The installer isn't saying it can't resolve the domain name. The installer is saying it can't find an MX record for merrimac.foo.yi.org. From your post you don't have an MX record for that nor do you want one. You want an MX record for foo.yi.org. Therefore at that prompt you need to say yes and type in foo.yi.org it will then find an MX record for that domain.
    Thanks rsharpe. That worked perfectly. It also fixed the default domain problems I was having.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •