Results 1 to 7 of 7

Thread: Zimbra is not working, cant send and receive mails

Hybrid View

  1. #1
    Join Date
    Sep 2011
    Posts
    4
    Rep Power
    4

    Default Zimbra is not working, cant send and receive mails

    Hi,

    I just installed Zimbra in ubuntu and is not working, I cant send emails inside nor outside.

    I have been reading forums and papers about DNS and Split DNS, done a lot of changes and
    can't get zimbra to work.

    From outside this is what I get

    The Postfix program

    : connect to mx1.compania.org[190.166.100.239]: Connection timed out

    Reporting-MTA: dns; hosting.myhost.com
    X-Postfix-Queue-ID: 343AB184BE7
    X-Postfix-Sender: rfc822; xxxxxx@yahoo.com
    Arrival-Date: Sat, 10 Sep 2011 15:33:25 -0700 (PDT)

    Final-Recipient: rfc822; eddy@compania.org
    Action: failed
    Status: 4.0.0
    Diagnostic-Code: X-Postfix; connect to mx1.compania.org[190.166.100.239]:
    Connection timed out


    -----


    root@compania:~# dig compania.org

    ; <<>> DiG 9.7.0-P1 <<>> compania.org
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 24300
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;ccp.org.do. IN A

    ;; Query time: 0 msec
    ;; SERVER: 172.139.100.90#53(172.139.100.90)
    ;; WHEN: Wed Sep 14 08:06:29 2011
    ;; MSG SIZE rcvd: 28

    My internal IP is 172.139.100.90

    hostname and hostname -f
    return myserver.compania.org


    Thanks in advance for your help.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Eddy67 View Post
    I just installed Zimbra in ubuntu and is not working, I cant send emails inside nor outside.

    I have been reading forums and papers about DNS and Split DNS, done a lot of changes and
    can't get zimbra to work.
    Then if you've read about Split DNS you'll have also read that you need to provide the output of all the commands in the 'Verify....' section of the wiki article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2011
    Posts
    4
    Rep Power
    4

    Default

    This is what I have in the /etc/bind/named file


    include "/etc/bind/named.conf.options";
    include "/etc/bind/named.conf.local";
    include "/etc/bind/named.conf.default-zones";

    zone "compania.org" {
    type master;
    file "/etc/bind/db.local";
    };

    zone "100.139.172" {
    type master;
    file "/etc/bind/db.127";
    };

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Eddy67 View Post
    This is what I have in the /etc/bind/named file
    That isn't what I asked for, go to the Split DNS wiki article and post the output from all the commands in the 'Verify....' section.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Sep 2011
    Posts
    4
    Rep Power
    4

    Default info required

    Hi,

    This is the info in from the verify section


    root@myserver:~# dig compania.org mx

    ; <<>> DiG 9.7.0-P1 <<>> compania.org mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 11105
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;comania.org. IN MX

    ;; Query time: 0 msec
    ;; SERVER: 172.139.100.90#53(172.139.100.90)
    ;; WHEN: Thu Sep 15 07:22:39 2011
    ;; MSG SIZE rcvd: 28


    root@myserver:~# dig compania.org any

    ; <<>> DiG 9.7.0-P1 <<>> compania.org any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 17410
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;compania.org. IN ANY

    ;; Query time: 0 msec
    ;; SERVER: 172.139.100.90#53(172.139.100.90)
    ;; WHEN: Thu Sep 15 07:22:39 2011
    ;; MSG SIZE rcvd: 28


    root@myserver:~# host $(hostname)
    Host myserver.compania.org.compania.org not found: 2(SERVFAIL)


    root@myserver:~# more /etc/resolv.conf
    nameserver 172.139.100.90
    search compania.org


    root@myserver:~# more /etc/hosts
    127.0.0.1 localhost.compania.org localhost
    172.139.100.90 myserver.compania.org mail

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    The simple answer to your problem is you have no A or MX DNS records and your hosts file is totally incorrect. Go to the Split DNS article and read what's necessary for your DNS records and hosts file, when you've done that then you can check your settings again with the commands you've already used..
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Sep 2011
    Posts
    4
    Rep Power
    4

    Default

    This is my definition of the A and MX records.

    I know that something have to be wrong in one of the files, but I've checked several times and see nothing wrong. I've been dealing with this matter for a full week and nothing, that's why I'm posting in the forum.

    root@myserver:/etc/bind# more db.local
    ;
    ; BIND data file for local loopback interface
    ;
    $TTL 604800
    @ IN SOA myserver.compania.org. root.compania.org. (
    2 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;
    @ IN NS myserver.compania.org.
    myserver IN A 172.139.100.90
    mail IN MX 190.166.100.239
    @ IN A 127.0.0.1
    @ IN AAAA ::1


    This is the content of my /etc/bind directory
    bind.keys db.255 db.root named.conf.local zones.rfc1918
    db.0 db.empty named.conf named.conf.options
    db.127 db.local named.conf.default-zones rndc.key

Similar Threads

  1. Only Admin can receive and send mails
    By yasanthau in forum Administrators
    Replies: 0
    Last Post: 05-28-2011, 04:23 AM
  2. BESX with Zimbra 6 can not send mails
    By deepblue in forum Zimbra Connector for BlackBerry
    Replies: 2
    Last Post: 02-24-2011, 12:52 AM
  3. Send Receive not working
    By dwlehning in forum General Questions
    Replies: 0
    Last Post: 01-25-2011, 05:02 PM
  4. Can't send email (zimbra to gmail) - receive fine
    By hellspawn in forum Administrators
    Replies: 5
    Last Post: 01-24-2011, 12:01 PM
  5. Can't send or receive mails from Zimbra
    By ppurama in forum Administrators
    Replies: 4
    Last Post: 11-14-2005, 09:17 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •