I've installed zimbra, and its been up and running fine.
I can connect through IMAP with Thunderbird using TLS, and the webmail works wonderfully.

The current problem is that I can't send emails through my Zimbra server's SMTP port (Port 25) with my Thunderbird email client when I have TLS turned on:
Settings:
- Use name and password -> Yes
- Use secure connection: -> TLS, if available

Thunderbird fails, giving me the error message:
"You have received an invalid certificate. Please contact the server administrator or email correspondent and give them the following information:
Your certificate contains the same serial number as another certificate issued by the certificate authroity. Please get a new certificate containing a unique number"

Thunderbird successfully sends out the emails once I choose
- Use secure connection: -> None
everything else unchanged.

I have tried regenerating my certificates using instructions found here:
http://wiki.zimbra.com/index.php?tit...icate_Problems ,
as well as reinstalling Zimbra, to no avail. I still get the same certificate error message.

I am running zimbra-core-4.0.3_GA_406.RHEL4-20061016134107.i386.rpm on CENTOS 4.3.

Any ideas how I can send emails with Thunderbird, TLS turned on?