Results 1 to 6 of 6

Thread: Unable to determine enabled services from ldap.

  1. #1
    Join Date
    Jun 2008
    Posts
    4
    Rep Power
    7

    Default Unable to determine enabled services from ldap.

    We got a zcs 5.0.18 working fine for some time but suddenly this afternoon the server stopped answering saying user/name passwords were incorrect.

    I did a zmcontrol status and got this error:
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Checked the forum and verified the hosts file, dns records, certificate... and everything seems correct.

    Here is a few lines of the zimbra.log file:

    Code:
    Sep 19 22:00:45 mail2 slapd[1872]: conn=496 op=0 STARTTLS 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=496 op=0 RESULT oid= err=0 text= 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=496 fd=23 TLS established tls_ssf=128 ssf=128 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=496 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" method=128 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=496 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" mech=SIMPLE ssf=0 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=496 op=1 RESULT tag=97 err=0 text= 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=496 op=2 SRCH base="cn=servers,cn=zimbra" scope=2 deref=3 filter="(objectClass=zimbraServer)" 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=496 op=2 SEARCH RESULT tag=101 err=0 nentries=1 text= 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=497 fd=24 ACCEPT from IP=192.168.0.16:51924 (IP=192.168.0.16:389) 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=497 op=0 STARTTLS 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=497 op=0 RESULT oid= err=0 text= 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=497 fd=24 TLS established tls_ssf=128 ssf=128 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=497 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" method=128 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=497 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" mech=SIMPLE ssf=0 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=497 op=1 RESULT tag=97 err=0 text= 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=497 op=2 SRCH base="cn=config,cn=zimbra" scope=0 deref=3 filter="(objectClass=*)" 
    Sep 19 22:00:45 mail2 slapd[1872]: conn=497 op=2 SEARCH RESULT tag=101 err=0 nentries=1 text= 
    Sep 19 22:00:46 mail2 slapd[1872]: conn=497 fd=24 closed (connection lost) 
    Sep 19 22:00:46 mail2 slapd[1872]: conn=496 fd=23 closed (connection lost) 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=498 fd=23 ACCEPT from IP=192.168.0.16:51925 (IP=192.168.0.16:389) 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=498 op=0 STARTTLS 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=498 op=0 RESULT oid= err=0 text= 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=498 fd=23 TLS established tls_ssf=128 ssf=128 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=498 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" method=128 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=498 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" mech=SIMPLE ssf=0 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=498 op=1 RESULT tag=97 err=0 text= 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=498 op=2 SRCH base="cn=servers,cn=zimbra" scope=2 deref=3 filter="(&(objectClass=zimbraServer)(zimbraServiceEnabled=imapproxy))" 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=498 op=2 SEARCH RESULT tag=101 err=0 nentries=1 text= 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=499 fd=24 ACCEPT from IP=192.168.0.16:51926 (IP=192.168.0.16:389) 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=499 op=0 STARTTLS 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=499 op=0 RESULT oid= err=0 text= 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=499 fd=24 TLS established tls_ssf=128 ssf=128 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=499 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" method=128 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=499 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" mech=SIMPLE ssf=0 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=499 op=1 RESULT tag=97 err=0 text= 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=499 op=2 SRCH base="cn=config,cn=zimbra" scope=0 deref=3 filter="(objectClass=*)" 
    Sep 19 22:00:47 mail2 slapd[1872]: conn=499 op=2 SEARCH RESULT tag=101 err=0 nentries=1 text= 
    Sep 19 22:00:48 mail2 slapd[1872]: conn=499 fd=24 closed (connection lost) 
    Sep 19 22:00:48 mail2 slapd[1872]: conn=498 fd=23 closed (connection lost) 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=500 fd=23 ACCEPT from IP=192.168.0.16:51927 (IP=192.168.0.16:389) 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=500 op=0 STARTTLS 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=500 op=0 RESULT oid= err=0 text= 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=500 fd=23 TLS established tls_ssf=128 ssf=128 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=500 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" method=128 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=500 op=1 BIND dn="uid=zimbra,cn=admins,cn=zimbra" mech=SIMPLE ssf=0 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=500 op=1 RESULT tag=97 err=0 text= 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=500 op=2 SRCH base="cn=servers,cn=zimbra" scope=2 deref=3 filter="(objectClass=zimbraServer)" 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=500 op=2 SEARCH RESULT tag=101 err=0 nentries=1 text= 
    Sep 19 22:00:49 mail2 slapd[1872]: conn=501 fd=24 ACCEPT from IP=192.168.0.16:51928 (IP=192.168.0.16:389)
    Can anyone point me a clue of what can be happening ?

  2. #2
    Join Date
    Jun 2008
    Posts
    4
    Rep Power
    7

    Default

    some more info....

    Code:
    [zimbra@mail2 ~]$ cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1	localhost.localdomain localhost
    ::1		localhost6.localdomain6 localhost6
    192.168.0.16	mail2.itec.cat mail2
    [zimbra@mail2 ~]$ hostname --fqdn
    mail2.itec.cat
    [zimbra@mail2 ~]$ dig itec.cat MX

    ; <<>> DiG 9.3.4-P1 <<>> itec.cat MX
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47275
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;itec.cat. IN MX

    ;; ANSWER SECTION:
    itec.cat. 86400 IN MX 10 mail2.itec.cat.

    ;; AUTHORITY SECTION:
    itec.cat. 86400 IN NS ns1.itec.cat.
    itec.cat. 86400 IN NS eris.itec.cat.

    ;; ADDITIONAL SECTION:
    mail2.itec.cat. 86400 IN A 192.168.0.16
    ns1.itec.cat. 86400 IN A 192.168.0.1
    eris.itec.cat. 86400 IN A 192.168.0.13

    ;; Query time: 0 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Mon Sep 19 22:05:30 2011
    ;; MSG SIZE rcvd: 133

  3. #3
    Join Date
    Jan 2009
    Location
    Buffalo, NY
    Posts
    5
    Rep Power
    6

    Default

    This is a stand-alone installation I take it?

    Could you do a "zmlocalconfig | grep ldap"?

  4. #4
    Join Date
    Jun 2008
    Posts
    4
    Rep Power
    7

    Default

    Yes, its a stand-alone

    here you are:
    Code:
    [zimbra@mail2 ~]$ zmlocalconfig | grep ldap
    ldap_amavis_password = *
    ldap_bind_url = 
    ldap_cache_account_maxage = 15
    ldap_cache_account_maxsize = 20000
    ldap_cache_cos_maxage = 15
    ldap_cache_cos_maxsize = 100
    ldap_cache_domain_maxage = 15
    ldap_cache_domain_maxsize = 100
    ldap_cache_external_domain_maxage = 15
    ldap_cache_external_domain_maxsize = 2000
    ldap_cache_group_maxage = 15
    ldap_cache_group_maxsize = 200
    ldap_cache_reverseproxylookup_domain_maxage = 15
    ldap_cache_reverseproxylookup_domain_maxsize = 100
    ldap_cache_reverseproxylookup_server_maxage = 15
    ldap_cache_reverseproxylookup_server_maxsize = 100
    ldap_cache_server_maxage = 15
    ldap_cache_server_maxsize = 100
    ldap_cache_timezone_maxsize = 100
    ldap_cache_zimlet_maxage = 15
    ldap_cache_zimlet_maxsize = 100
    ldap_connect_pool_debug = false
    ldap_connect_pool_initsize = 1
    ldap_connect_pool_master = false
    ldap_connect_pool_maxsize = 50
    ldap_connect_pool_prefsize = 0
    ldap_connect_pool_timeout = 120000
    ldap_connect_timeout = 30000
    ldap_deref_aliases = always
    ldap_host = mail2.itec.cat
    ldap_is_master = true
    ldap_log_level = 16640
    ldap_master_url = ldap://mail2.itec.cat:389
    ldap_nginx_password = *
    ldap_port = 389
    ldap_postfix_password = *
    ldap_read_timeout = 30000
    ldap_replication_password = *
    ldap_require_tls = false
    ldap_root_password = *
    ldap_starttls_supported = 1
    ldap_url = ldap://mail2.itec.cat:389
    postfix_sender_canonical_maps = proxy:ldap:/opt/zimbra/conf/ldap-scm.cf
    postfix_transport_maps = proxy:ldap:/opt/zimbra/conf/ldap-transport.cf
    postfix_virtual_alias_domains = proxy:ldap:/opt/zimbra/conf/ldap-vad.cf
    postfix_virtual_alias_maps = proxy:ldap:/opt/zimbra/conf/ldap-vam.cf
    postfix_virtual_mailbox_domains = proxy:ldap:/opt/zimbra/conf/ldap-vmd.cf
    postfix_virtual_mailbox_maps = proxy:ldap:/opt/zimbra/conf/ldap-vmm.cf
    zimbra_class_provisioning = com.zimbra.cs.account.ldap.LdapProvisioning
    zimbra_ldap_password = *
    zimbra_ldap_user = zimbra
    zimbra_ldap_userdn = uid=zimbra,cn=admins,cn=zimbra
    zimbra_zmprov_default_to_ldap = false

  5. #5
    Join Date
    Jun 2008
    Posts
    4
    Rep Power
    7

    Default

    I finally gave up and chose to restore it from yesterday's backup. Everything is working again. Hope it won't happen anymore ....

  6. #6
    Join Date
    Jan 2009
    Location
    Buffalo, NY
    Posts
    5
    Rep Power
    6

    Default

    Yeah, nothing looked out of the ordinary. I was about to have you run a test query to see what happens, but I guess it's moot now.

    Good luck

Similar Threads

  1. [SOLVED] Unable to determine enabled services from ldap.
    By farrukhndm in forum Administrators
    Replies: 15
    Last Post: 02-10-2013, 11:19 PM
  2. Unable to determine enabled services from ldap.
    By flanciotti in forum Administrators
    Replies: 6
    Last Post: 08-18-2011, 06:46 AM
  3. Replies: 0
    Last Post: 06-15-2011, 02:14 AM
  4. Replies: 8
    Last Post: 12-28-2010, 11:50 PM
  5. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 02:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •