Results 1 to 9 of 9

Thread: undefined symbol: Perl_Tstack_sp_ptr

  1. #1
    Join Date
    Aug 2010
    Location
    INDIA
    Posts
    5
    Rep Power
    5

    Unhappy undefined symbol: Perl_Tstack_sp_ptr

    Hi,

    When I am going to install zcs-7.1.3_GA_3346.RHEL5.20110928134520
    this to my "CentOS Linux release 6.0 (Final)" server it is going to stop in between and gave that error. - "/usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/IO/IO.so: undefined symbol: Perl_Tstack_sp_ptr"

    on this server the perl version is - "This is perl, v5.10.1 (*) built for i386-linux-thread-multi".

    please help me out to come out from this error.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by manishweta View Post
    Hi,

    When I am going to install zcs-7.1.3_GA_3346.RHEL5.20110928134520
    this to my "CentOS Linux release 6.0 (Final)" server it is going to stop in between and gave that error. - "/usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/IO/IO.so: undefined symbol: Perl_Tstack_sp_ptr"

    on this server the perl version is - "This is perl, v5.10.1 (*) built for i386-linux-thread-multi".

    please help me out to come out from this error.
    Search these forums for the error message, this has been asked and answered many times.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Aug 2010
    Location
    INDIA
    Posts
    5
    Rep Power
    5

    Default

    Searched but no fruitful replies found.
    can you pl let me know once again, I need this for CENTOS6 for Zimbra 7.1.3

  4. #4
    Join Date
    Aug 2010
    Location
    INDIA
    Posts
    5
    Rep Power
    5

    Default

    Initializing ldap...failed. (28160)

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    As I said, this answer is in the forums.

    Quote Originally Posted by manishweta View Post
    on this server the perl version is - "This is perl, v5.10.1 (*) built for i386-linux-thread-multi
    That would indicate you either a) have a 32bit CentOS or b) the wrong version of perl installed - the Zimbra build for CentOS6 (RHEL6) is a 64bit build only.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Aug 2010
    Location
    INDIA
    Posts
    5
    Rep Power
    5

    Default

    I have Cent os 6 -32 bit nad Zimbra is also 32 bit....

    now this error is coming....

    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    Can't call method "write" on an undefined value at /opt/zimbra/libexec/zmldapinit line 123, line 6.

    I installed this version successfully on CentOS 5.6. ans itis working fine

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by manishweta View Post
    I have Cent os 6 -32 bit nad Zimbra is also 32 bit....
    Then you installed the wrong version of Zimbra, there is no 32bit version of Zimbra for RHEL 6 (that includes CentOS6) - that was your problem and one item you omitted to tell us. Install the correct version of Zimbra on a supported platform and it will work - they have all been tested by Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Aug 2010
    Location
    INDIA
    Posts
    5
    Rep Power
    5

    Default

    I am installing - "zcs-7.1.3_GA_3346.RHEL5.20110928134520.tgz"

    this on Cent OS 6.0 32 bit.

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by manishweta View Post
    I am installing - "zcs-7.1.3_GA_3346.RHEL5.20110928134520.tgz"
    I've already told you this in my previous post. That is the wrong version and was not built for RHEL 6 (nor CentOS 6), you will not be able to install it on the operating system.

    Quote Originally Posted by manishweta View Post
    this on Cent OS 6.0 32 bit.
    Same answer as above, there is no 32bit version of Zimbra for RHEL 6 (nor CentOS6). You either need to install the 32bit version of CentOS5 or get a 64bit server to run CentOS6 and install the correct version of Zimbra. The 32bit versions of Zimbra will not be provided for the next major release of Zimbra, there will only be 64bit versions.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. id is undefined in Admin extention zimlet
    By nilesh.pambhar in forum Developers
    Replies: 0
    Last Post: 09-02-2011, 05:15 AM
  2. contactList is undefined
    By konrad in forum General Questions
    Replies: 2
    Last Post: 04-14-2008, 12:57 PM
  3. undefined smileys
    By SpEnTBoY in forum Zimlets
    Replies: 0
    Last Post: 02-08-2008, 07:06 AM
  4. cannot use the @ symbol in IE7.0
    By lars_BE in forum Installation
    Replies: 0
    Last Post: 10-02-2007, 06:16 AM
  5. undefined symbol: SSL_load_error_strings
    By redbaron in forum Installation
    Replies: 4
    Last Post: 07-25-2007, 02:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •