Results 1 to 2 of 2

Thread: problem with amavisd after update to 4.03

  1. #1
    Join Date
    Jan 2006
    Rep Power

    Default linux vserver modifications after upgrading zimbra

    Hi all

    I'm running Zimbra 4.0.1 in a linux-vserver. After upgrading to 4.0.3, some settings I had made manually to make it run in a linux-vserver environment were lost. To make it work again, I had to perform steps documented below. I hope this helps anyone else with such a setup. My main server is running fc4 x86_64, the VServer is running fc4 i386.


    (my vserver ip is, my hostname is v-zimbra.milnet.lan)

    1) ensure that the first line in /etc/hosts is: localhost.localdomain localhost v-zimbra.milnet.lan v-zimbra

    2) check if database logins succeed. If they fail, it might help to

    su - zimbra
    mysql zimbra
    show grants;

    ...then re-enter some GRANT statements, like the ones you see, but replace
    TO 'zimbra'@'localhost'
    TO 'zimbra'@'v-zimbra.milnet.lan'

    3) replace occurences of by in amavisd.conf, dspam.conf and

    4) modify amavisd.conf and to include the line
    @mynetworks = qw( ) ;

    and uncomment and adapt the lines
    $notify_method = 'smtp:[]:10025';
    $forward_method = 'smtp:[]:10025'; # set to undef with milter!

    5) in /opt/zimbra/postfix/conf/master.conf replace by the server's IP and adapt the line
    -o mynetworks=

    6) modify the line in /opt/zimbra/amavisd/sbin/amavisd
    @inet_acl = qw( ); # allow SMTP access only from localhost
    Last edited by milprog; 11-04-2006 at 03:29 PM.

  2. #2
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    Would you kindly add this to the wiki??


Similar Threads

  1. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 05:21 PM
  2. Building SVN for CentOS 4.4 (mysql)
    By GrepACE in forum Developers
    Replies: 3
    Last Post: 12-29-2006, 10:54 PM
  3. yum update problem
    By jamesjr555 in forum Installation
    Replies: 1
    Last Post: 09-08-2006, 09:45 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  5. Replies: 14
    Last Post: 12-22-2005, 04:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts