Results 1 to 6 of 6

Thread: Mysql Server is not starting

  1. #1
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    9

    Exclamation Zimbra 4.0.3 Mysql Server is not starting on centos 4.4

    The issue started by stopping after the instalation at the documnet initiation step.
    I tried to find out what is the problem and i found that the mysql server is not running.
    I tried to start mysql server after the install and i failed.

    this is the command is used:
    Code:
    [zimbra@mail ~]$ Starting mysqld daemon with databases from /opt/zimbra/db/data
    STOPPING server from pid file /opt/zimbra/db/mysql.pid
    061108 13:13:36  mysqld end
    The mysql.log file look like this:
    Code:
    [zimbra@mail ~]$ tail log/mysqld.log
    
    061108 13:13:36  mysqld started
    061108 13:13:36 [ERROR] Can't start server: Bind on TCP/IP port: Cannot assign requested address
    061108 13:13:36 [ERROR] Do you already have another mysqld server running on port: 7306 ?
    061108 13:13:36 [ERROR] Aborting
    
    061108 13:13:36 [Note] /opt/zimbra/mysql/libexec/mysqld: Shutdown complete
    
    061108 13:13:36  mysqld ended
    
    [zimbra@mail ~]$
    my netstat output is:
    Code:
    [root@mail ~]# netstat -antp
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 0.0.0.0:707                 0.0.0.0:*                   LISTEN      2645/rpc.statd
    tcp        0      0 172.16.1.102:389            0.0.0.0:*                   LISTEN      1818/slapd
    tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      2625/portmap
    tcp        0      0 172.16.1.102:53             0.0.0.0:*                   LISTEN      2607/named
    tcp        0      0 127.0.0.1:53                0.0.0.0:*                   LISTEN      2607/named
    tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      2764/cupsd
    tcp        0      0 127.0.0.1:953               0.0.0.0:*                   LISTEN      2607/named
    tcp        0      0 :::22                       :::*                        LISTEN      2795/sshd
    [root@mail ~]#
    i am installing on centos 4.4 64 with 2GB RAM and large HD.

    can any one tell me what can i do?
    i have search the internet and the zimbra site to find a soulution but i colud nt find any.
    Last edited by freeq80; 11-08-2006 at 10:28 AM.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    New install. Try killing all the zimbra processes and run it again.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    9

    Default Done

    I reinstall it 5 times and restarted the full server 3 times and the same error is there.
    the error start after the instllation when initializing documents hang.

    there are three services not running after that the most important one is the mysql server

    Code:
    [zimbra@mail root]$ zmcontrol start
    Host mail.knsecurity.net
            Starting logger...Done.
            Starting mailbox...Done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting snmp...Done.
            Starting spell...Done.
            Starting mta...Done.
    [zimbra@mail root]$ zmcontrol status
    Host mail.knsecurity.net
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Stopped
                    logmysql.server is not running
                    zmlogswatchctl is not running
            mailbox                 Stopped
                    mysql.server is not running
            mta                     Running
            snmp                    Running
            spell                   Running
    [zimbra@mail root]$
    i think i will down grade to version 3 and check

  4. #4
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    9

    Default Still i have the same error

    i down graded to 4.0.2 but still i can not get mysql.server to start.
    i tried the server preinstall mysql server and it started without any issue !!

    also i reinstall to RHES4 U3 i386 and test zimbra on it and the zimbra mysql server did not start.

    i don't know where is the error ??

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    what does:
    ps auwxx | grep zimbra
    or
    ps auwxx | grep mysqld

    return?

  6. #6
    Join Date
    Nov 2006
    Posts
    4
    Rep Power
    9

    Default I think i had a network conflict with the named server (named)

    I don't know what is the proplem exactly but once i turn off my name server runnig on the same machine . zimbra started without any issue !!

    it is working fine Now but i will try to install the name server (named) back to check the issue.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  3. Replies: 18
    Last Post: 03-20-2006, 02:22 PM
  4. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 11:36 AM
  5. more fedora install problems
    By jlynch3 in forum Installation
    Replies: 13
    Last Post: 09-14-2005, 10:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •