Results 1 to 6 of 6

Thread: vserver installation

  1. #1
    Join Date
    Nov 2006
    Posts
    13
    Rep Power
    9

    Default vserver installation

    Dear list,

    I try to get zimbra 4.0.3 working on an debian etch system under vserver.
    For some reasons it does not recognise
    the prequisites, any hints?

    e.g.

    vserver1:~/zcs# apt-get install sudo
    It tell me that sudo is installed
    vserver1:~/zcs# ./install.sh
    ...
    Checking for prerequisites...
    NPTL...FOUND
    sudo...MISSING
    libidn...MISSING
    curl...MISSING
    fetchmail...MISSING
    gmp...MISSING

    ###ERROR###

    One or more prerequisite packages are missing.
    Please install them before running this installer.

    Installation cancelled.

    best regards

    Dani

  2. #2
    Join Date
    Nov 2005
    Location
    Germany
    Posts
    89
    Rep Power
    10

    Default vserver installation

    Hi,

    try apt-get install sudo ...

    This will install the missing programms. But expect some additional problems. From my experiences you need a minimum of 512 MB garateed memory and java will have problems. Bau with soeme tricks it runs.

    If you need help let me know.


    Regards

    Friedmar

  3. #3
    Join Date
    Jan 2006
    Posts
    81
    Rep Power
    9

    Default

    Quote Originally Posted by friedmar
    Hi,

    try apt-get install sudo ...
    He already has.
    Jacob Turner
    Ringnebula Systems - Ukiah, CA

  4. #4
    Join Date
    Oct 2005
    Location
    Washington DC
    Posts
    47
    Rep Power
    10

    Default

    Try searching through the forum. This has been discussed a few times. The issue is your /etc/debian_version most likely..

  5. #5
    Join Date
    Nov 2006
    Posts
    13
    Rep Power
    9

    Default

    yes sudo is installed on the vserver

    vserver1:/# sudo
    usage: sudo -K | -L | -V | -h | -k | -l | -v
    usage: sudo [-HPSb] [-p prompt] [-u username|#uid]
    { -e file [...] | -i | -s | }

    I think there is a problem in the script that detects
    the prequisites

  6. #6
    Join Date
    Nov 2006
    Posts
    13
    Rep Power
    9

    Default

    This is what /etc/debian_version tells me
    vserver1:~/zcs/bin# cat /etc/debian_version
    4.0

    so in zcs/bin/get_plat_tag.sh I modified the line with the grep

    original:
    if [ -f /etc/debian_version ]; then
    grep "3.1" /etc/debian_version > /dev/null 2>&1
    if [ $? = 0 ]; then
    echo "DEBIAN3.1"
    exit 0
    fi
    fi

    modified the grep line to
    grep "4.0" /etc/debian_version > /dev/null 2>&1

    and it works. Thanks to quick help.

    best regards
    Dani

Similar Threads

  1. Installation fails on vServer / Debian 3.1
    By Tobias in forum Installation
    Replies: 3
    Last Post: 03-09-2007, 12:31 AM
  2. Installation Failed
    By freit5 in forum Installation
    Replies: 2
    Last Post: 08-18-2006, 12:38 AM
  3. Replies: 16
    Last Post: 01-05-2006, 09:55 AM
  4. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •