I had an error upgrading to 4.0.1. I think it had something to do with the documents not being properly setup from the 3.1 -> 4.0 move. When I upgrade from 4.0.1 to 4.0.2 the upgrade completes but I get a message about and INVALID_PDU when I attempt to login. If I try to push farther and upgrade the 4.0.2 to 4.0.3 it fails saying:

Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
Operations logged to /tmp/zmsetup.log.15204
Setting defaults...Setting defaults from existing config...Done
Upgrading from 4.0.2_GA_362 to 4.0.3_GA_406
Sun Nov 19 00:40:04 2006: Stopping zimbra services
Sun Nov 19 00:40:08 2006: Starting mysql
Sun Nov 19 00:40:10 2006: Checking logger mysql status
Sun Nov 19 00:40:10 2006: Starting logger mysql
Sun Nov 19 00:40:11 2006: SELECT value FROM config WHERE name = 'db.version'
This appears to be 4.0.2_GA
Schema upgrade required
Sun Nov 19 00:40:11 2006: Running /opt/zimbra/libexec/scripts/migrate-ComboUpdater.pl
Sun Nov 19 00:40:13 2006: Verified schema version 26.
ERROR 1060 (42S21) at line 1: Duplicate column name 'contact_count'
Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=jbPc95sRbjXlbk9BJRt1sGva --database=zimbra --batch --skip-column-names'. at /opt/zimbra/libexec/scripts/Migrate.pm line 136, line 287.
Sun Nov 19 00:40:13 2006: Script failed with code 1 - exiting
UPGRADE FAILED - exiting


Ultimately, I have to revert to my backup in order to recover.

Please help, I'd really like to get past this.

Thanks in advance.