I'm a bit confused, I'm tried to use the WiKi and it stated to install bind9.

Do both bind and dnsmasq have to be installed, or is it one or the other?