Results 1 to 5 of 5

Thread: Upgrade Problem

  1. #1
    Join Date
    Aug 2006
    Rep Power

    Default Upgrade Problem

    I upgraded from 3.1.4 to 4.0.4 on RHEL4 yesterday and everything went well, no problems or errors. This morning I check my mail and one week of mail is missing. I did backup so I should be able to restore it but I'm puzzled why this happened...

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Have a look in the deferred queue in the Admin UI, is it there?


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Aug 2006
    Rep Power


    Quote Originally Posted by phoenix View Post
    Have a look in the deferred queue in the Admin UI, is it there?
    No, not there. Also noticed that my Inbox is only going back to Sep 20th and it should go back to Sep 1st. All my other folders like sent are up to date.

    I was reading mail around 10 last night so its puzzling to say the least.

  4. #4
    Join Date
    Aug 2006
    Rep Power

    Default Restore didn't work

    Just great, tried to restore the account and it didn't work.

    Message: system failure: restoring table: mailbox
    com.zimbra.cs.service.ServiceException: system failure: restoring table: mailbox
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser
    at com.zimbra.cs.db.DbBackup.loadTable( 70)
    at com.zimbra.cs.db.DbBackup.loadTable( 43)
    at com.zimbra.cs.backup.RestoreAccountSession.loadTab lesFromLocalFile(
    at com.zimbra.cs.backup.FileBackupTarget$RestoreAcctS ession.loadTables(
    at com.zimbra.cs.backup.RestoreAccountSession.startRe store(
    at com.zimbra.cs.backup.FileBackupTarget.restore(File
    at com.zimbra.cs.backup.BackupManager.restore(BackupM
    at com.zimbra.cs.service.backup.Restore.handle(Restor
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:162)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at ternalDoFilter(
    at Filter(
    at org.apache.catalina.core.StandardWrapperValve.invo ke(
    at org.apache.catalina.core.StandardContextValve.invo ke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke (
    at org.apache.catalina.core.StandardEngineValve.invok e(
    at org.apache.catalina.valves.AccessLogValve.invoke(A
    at org.apache.catalina.connector.CoyoteAdapter.servic e(
    at org.apache.coyote.http11.Http11Processor.process(H
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt
    at Socket(
    at ead.runIt(
    at org.apache.tomcat.util.threads.ThreadPool$ControlR
    Caused by: java.sql.SQLException: Data truncation: Data truncated for column 'tracking_imap' at row 1

    Query being executed when exception was thrown:

    LOAD DATA LOCAL INFILE '/opt/zimbra/backup-pre-4.0/sessions/full-20061122.212641.375/accounts/83c85a92-09cf-4be7-821c-79113d60311b/mailbox.dat' REPLACE INTO TABLE mailbox FIELDS TERMINATED BY ',' OPTIONALLY ENCLOSED BY '"' LINES TERMINATED BY '\n'
    at com.mysql.jdbc.SQLError.convertShowWarningsToSQLWa rnings(
    at com.mysql.jdbc.MysqlIO.scanForAndThrowDataTruncati on(
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect( :1804)
    at com.mysql.jdbc.Connection.execSQL( 2994)
    at com.mysql.jdbc.PreparedStatement.executeInternal(P
    at com.mysql.jdbc.PreparedStatement.execute(PreparedS
    at org.apache.commons.dbcp.DelegatingPreparedStatemen t.execute(
    at com.zimbra.cs.db.DbBackup.loadTable( 68)
    ... 29 more

    Error code: service.FAILURE
    Method: ZmCsfeCommand.prototype.invoke
    Last edited by freit5; 11-23-2006 at 06:19 AM.

  5. #5
    Join Date
    Aug 2005
    Rep Power

    Default restoring backups from older versions

    You can't restore a 3.* backup to a 4.* install. The schemas aren't compatible.

    Does reindexing your mailbox fix the date problem?
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. 4.01 to 4.02 upgrade problem (with solution)
    By criley in forum Migration
    Replies: 2
    Last Post: 09-29-2006, 12:36 AM
  2. 3.1.3OS Upgrade Problem
    By mcevoys in forum Installation
    Replies: 7
    Last Post: 06-16-2006, 10:47 AM
  3. 3.0.1 GA upgrade problem
    By kollross in forum Administrators
    Replies: 5
    Last Post: 04-04-2006, 11:42 AM
  4. Another odd GA upgrade problem (FYI)
    By meikka in forum Installation
    Replies: 0
    Last Post: 02-08-2006, 01:38 PM
  5. Odd GA upgrade problem
    By drewage in forum Installation
    Replies: 2
    Last Post: 02-08-2006, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts