Results 1 to 1 of 1

Thread: Undefined subroutine 'main'

  1. #1
    Join Date
    Apr 2012
    Rep Power

    Default [Solved] Undefined subroutine 'main'

    I have a new installation of 7.1.4_GA_2555.RHEL6_64_20120105094634 which is almost ready to go live. But, this weekend cron started sending me:

    PHP Code:
    Undefined subroutine &main::logError called at /opt/zimbra/libexec/zmdailyreport line 238, <CONFline 540. 
    Since I have not edited this script I am at a loss to explain this. Anyone?

    I guess we will not be rolling ZCS out this week...

    Oh and hello forum o/

    ===================== SOLUTION ==================

    1) That script error may still exist, as it is an attempt at error logging. When there is no error, that line is not reached.

    2) The script was failing because it could not email the report. zimbraSmtpHostname was set incorrectly to two different strings, the first was an invalid host name (most likely from install) the second was the correct value (set via the webui perhaps).

    For any struggling with zimbraSmtpHostname and _default_soap_server, this article was useful to me:

    Ajcody's MTA page
    Last edited by koning; 04-03-2012 at 06:19 AM.

Similar Threads

  1. contactList is undefined
    By konrad in forum General Questions
    Replies: 2
    Last Post: 04-14-2008, 12:57 PM
  2. [SOLVED] Main menu issues
    By naoto in forum Installation
    Replies: 4
    Last Post: 02-06-2008, 08:28 AM
  3. [SOLVED] Remove main domain!
    By zibra in forum Administrators
    Replies: 11
    Last Post: 09-27-2007, 08:50 AM
  4. undefined symbol: SSL_load_error_strings
    By redbaron in forum Installation
    Replies: 4
    Last Post: 07-25-2007, 02:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts