Results 1 to 7 of 7

Thread: password problem

Hybrid View

  1. #1
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default password problem

    I changed the admin password through the admin web console and the zimbra system seemed to lock me out or i made a mistake typing the password twice. The latter seems unlikely but is possible. Anywho i used the zimba command line until to set the admin password like a so.

    zmprov sp admin@canmail.org XXXXXXX

    Now i have a particularly nasty problem of being able to login to the admin web console without enter a password is this what the setpassword command is supposed to do?

    Checked the zmmypasswd command but not quite sure how to use it or if it might help?

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default not zmmypasswd

    Quote Originally Posted by rmvg
    I changed the admin password through the admin web console and the zimbra system seemed to lock me out or i made a mistake typing the password twice. The latter seems unlikely but is possible. Anywho i used the zimba command line until to set the admin password like a so.

    zmprov sp admin@canmail.org XXXXXXX

    Now i have a particularly nasty problem of being able to login to the admin web console without enter a password is this what the setpassword command is supposed to do?

    Checked the zmmypasswd command but not quite sure how to use it or if it might help?
    zmmypasswd sets the sql db password, that's not what you want.

    Your method of resetting the admin password was correct - you shouldn't be able to log into the console without a password, but we'll check it out to see if we can reproduce it here.

    Try restarting tomcat and see if it picks up the new password you've set.

  3. #3
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    I am resetting the server as i have some hardware to add/remove it is going down now...................................
    Ok back up and system is now asking for password i am going to try and change admin password again using web console and see what happens.................. everything worked fine this time.

    Think I may have had a couple of admin panels open last time i will pay close attention next time and send any errors to this list.

  4. #4
    Join Date
    Sep 2005
    Posts
    187
    Rep Power
    10

    Default

    Thanks for the post. I think you encountered two different(but related) issues. Below are what my interpretation of what you might have done and their details.

    I changed the admin password through the admin web console and the zimbra system seemed to lock me out or i made a mistake typing the password twice.
    I could reproduce(the result) but not sure if this is exactly what you did.

    The problem occurs(hard to makeout in IE) if we check 'must change password next time'-checkbox while updating the password.
    Steps to reproduce:
    1. Login to admin console
    2. Select an account(dont doubleClick nor press Edit)
    3. Press ChangePassword button in the toolBar
    4. Enter new password and 'check' the must change password-checkbox
    5. Logoff
    6. Try relogin

    In Firefox we get
    An unknown application error has occurred. Please correct any errors and retry. If the problem persists, please contact your System Aministrator. (account.CHANGE_PASSWORD)
    In IE we get:
    Authentication failed and a javaScript browser exception.

    We already have a bug logged for this< bug# 901>

    Now i have a particularly nasty problem of being able to login to the admin web console without enter a password is this what the setpassword command is supposed to do?
    If you meant ' login to Admin > CloseBrowser(dont logoff) > try logging
    into admin again by typing the adminURL in the browser'
    ...then, it directly opening adminconsole bypassing the admin login screen

    We already have a bug logged for this as well< bug# 3335>

    P.S. Bugzilla will be open for forum users in the near future.

    Please let us know if my interpretation of the steps are not accurate.

    Thanks,
    Raja
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    You hit the nail on the head but i did not check the change password nexttime box to get the error, or did i if u say it is hard to makeout in IE mabey i did it by accident. The second problem is exactly as u state below must be a tomcat cache issue or something right? Just have to remember to logout infact that could be used as a feature not a bug saves having to type the admin password all the time.

    ps does the change password box come up when u create new users? i have not seen it yet. That would be great (even if it is broken) as i have an earlier post asking for that feature.

  6. #6
    Join Date
    Sep 2005
    Posts
    187
    Rep Power
    10

    Arrow

    Quote Originally Posted by rmvg
    The second problem is exactly as u state below must be a tomcat cache issue or something right?
    It is stored as a cookie in the browser.
    Quote Originally Posted by rmvg
    Just have to remember to logout infact that could be used as a feature not a bug saves having to type the admin password all the time.
    Although it could be a feature, just to make adminConsole more secure as it is*admin* console, it is scraped in the upcoming release and the admin will be asked to authenticate everytime.
    However, this feature is available for ZimbraMailClient. Just check 'Remember me on this computer'-checkbox in the login screen and you can directly login to the mail client everytime from then on unless/until you manually logoff OR clear your browser's cache

    Quote Originally Posted by rmvg
    ps does the change password box come up when u create new users? i have not seen it yet. That would be great (even if it is broken) as i have an earlier post asking for that feature.
    It should be available in the upcoming release.

    As a work around, Users can always change their password in mailClient's Options. Although it doesnt FORCE users of the mailclient to change password, they still have an option.
    MailClient > Options > General(Tab) > Change Password

    Thanks,
    Raja
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    10

    Default

    Users change there passwords without being forced haha very funny.

    Guess the autologin as admin is a more of security issue rather than a feature call me lazy but i thought it was alright. Scrapping it is the best idea though.

    Thanks

Similar Threads

  1. Please solve my installation problem
    By dinesh_rut in forum Installation
    Replies: 4
    Last Post: 11-06-2006, 12:03 AM
  2. FC4 Test install getting SU: Incorrect Password
    By bbepristis in forum Installation
    Replies: 16
    Last Post: 08-11-2006, 11:07 AM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •