Results 1 to 4 of 4

Thread: ZCS installation on KVM (Ubuntu 8.04 Turnkey Zimbra)

  1. #1
    Join Date
    May 2012
    Rep Power

    Default ZCS installation on KVM (Ubuntu 8.04 Turnkey Zimbra)

    Hey guys,

    I've been trying to install ZCS within my virtual environment for while now with no luck, initially I had it running without DNS working now I'm seeing the following LDAP related error:

    May 6 07:49:35 zimbra zimbramon[21620]: 21620:info: zmmtaconfig: Skipping Configuration for server mail.** update.
    May 6 07:49:35 zimbra zimbramon[21620]: 21620:info: zmmtaconfig: gs:mail.** ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mail.**:389)
    May 6 07:49:35 zimbra zimbramon[21620]: 21620:info: zmmtaconfig: Sleeping...Key lookup failed.

    What do I need to post for assistance in a diagnosis or should I install a fresh machine running a newer release of Ubuntu? I've tried this on Deb 7 with more luck but the ZCS web service wasn't accessible after reboot (OpenVZ container).

    I'm after some guidance here, is the any support for ZCS in OpenVZ containers or will I be forced into running a 64bit KVM machine? Can anyone shed any light on the LDAP issue I'm having?

    Alex Turner

  2. #2
    Join Date
    May 2010
    Rep Power


    Hi Alex,

    I can't help you out with the error you are getting. However, I strongly suggest that if you want to use Ubuntu, you install a clean Ubuntu Server 10.04 LTS 64bit (not 12.04 LTS as it is not yet supported). After your OS is configured and updated download the latest version of ZCS 7.2.

    Hope that helps!

  3. #3
    Join Date
    Apr 2012
    Rep Power


    I'll just say I run it under 10.04 on a 64bit KVM here.

    In my (admittedly limited) experience, LDAP errors tend to point to issues with name resolution. I've found zimbra is very sensitive to correct dns resolution of the zimbra host name, and just setting the hosts file is not enough to make it work properly.

    I run dnsmasq on my vm to make sure zimbra can always resolve itself properly. This allows me to copy the entire vm to a test machine and give it a different ip address to test with. Before dnsmasq zimbra kept resolving the ip address of the actual zimbra machine and all hell would break loose. Not a kosher way of running things I suspect, but it solved all the DNS issues I had when replicating and modifying the test setup.

  4. #4
    Join Date
    Sep 2011
    Rep Power


    I am not familiar with KVM virtualization but I have run Ubuntu inside VirtualBox (on a Windows PC) and on VMware's ESXi server (vSphere).

    I would recommend installing a base copy of Ubuntu 10.04 LTS and then Zimbra. The "Turnkey" server never really worked for me (probably because of noob issues) but installing everything by hand did work.

    I looked at many different tutorials, manuals and articles about how to get it running and decided to write down everything I did step-by-step to get Zimbra up-and-running on a virtualized Ubuntu (although should be very similar to bare metal or other VM platforms).
    Type su - zimbra -c "zmcontrol -v" to get your version and copy that into your profile (more info here)

Similar Threads

  1. fatal: parameter "smtpd_recipient_restrictions"
    By Robin in forum Administrators
    Replies: 8
    Last Post: 12-22-2010, 04:48 AM
  2. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 10:13 AM
  3. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 08:56 PM
  4. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 12:00 PM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts