Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: When setting up Zimbra I get and LDAP error

  1. #11
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    4

    Default [solved]

    After uninstalling Zimbra from the server and running the install again I am right back to square one.

    I get this error again
    Initializing ldap...failed. (28160)
    When I do a cat of the log file this is what it says

    IO::Socket::INET: connect: Connection timed out at /opt/zimbra/libexec/zmldapinit line 137.
    Mon May 28 04:49:21 2012 failed. (28160)
    Here is the cat for resolv.conf I added the server itself to nameservers to see if that would help out with the 256 error
    [root@hcc ~]# cat /etc/resolv.conf
    ; generated by /sbin/dhclient-script
    search HCC.HILLTOPCHURCHNET.NET
    nameserver 192.168.30.3
    nameserver 192.168.128.230
    That did not fix it got the 28160 error

    And here is the host file


    [root@hcc ~]# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.30.3 mail.hcc.hilltopchurchnet.net mail
    Any ideas cause I am out of them
    Last edited by michael24; 06-04-2012 at 03:30 AM. Reason: solved

  2. #12
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by michael24 View Post
    Ok so now this is my changes as you suggested come on Phoenix you and me again going at it again with internal servers you and me have a history.
    I don't really understand what you mean here.

    Assuming you have disabled the firewall and SElinux on this server and the DNS records etc. are correct (and they appear to be) then I really don't have anything useful to contribute that would be of any use. FWIW, I have installed ZCS on all version of CentOS (ranging from minimum install to full servers with KDE installed) and providing the prerequisites have been installed I've had no problems so I can't imagine what's wrong with your system..
    Last edited by phoenix; 05-30-2012 at 04:39 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #13
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    4

    Default

    Anyone have any idea on this issue I sold a client on this solution and I would hate to have to go to them and say it doesn't work.

  4. #14
    Join Date
    Oct 2011
    Location
    jignesh_22_1990@yahoo.com
    Posts
    68
    Rep Power
    4

    Default

    Hi Michael
    There is some another process is running on port no:389.
    You have to kill that process and try again from "/opt/zimbra/libexec/zmsetup.pl" .

  5. #15
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    4

    Default

    This is what I get when look at port 389

    # netstat -apnt | grep 389
    tcp 0 0 192.168.30.3:389 0.0.0.0:* LISTEN 13456/slapd
    Interesting but I have slapd set to not run

  6. #16
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    4

    Default

    Slapd does not want to stop and when I do kill the process it changes it pid after killing it here is what it get when I killed it the first time.


    # netstat -apnt | grep 389
    tcp 0 0 192.168.30.3:389 0.0.0.0:* LISTEN 15062/slapd
    when I run service slapd I get the following


    # service slapd stop
    slapd: unrecognized service
    Any ideas how to get slapd to stop running?

  7. #17
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    4

    Default

    This is what I get when cat the log file after it fails


    Tue May 29 19:45:04 2012 checking isEnabled zimbra-ldap
    Tue May 29 19:45:04 2012 zimbra-ldap is enabled
    Tue May 29 19:45:04 2012 Initializing ldap...
    Tue May 29 19:45:04 2012 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    /opt/zimbra/bin/ldap: line 56: kill: (18035) - No such process
    IO::Socket::INET: connect: Connection timed out at /opt/zimbra/libexec/zmldapinit line 137.
    Tue May 29 19:45:39 2012 failed. (28160)

  8. #18
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    4

    Default

    So it would appear that I am not the only issue and it would seem that no one has a single clue what the fix is

    http://www.zimbra.com/forums/adminis...tos-6-2-a.html

    Tired the fix in here no go

    http://www.zimbra.com/forums/install...ine-137-a.html

    And no one even answered this forum post again why should I go with Zimbra, Exchange is looking good right now as this is appears to be an issue with every instance of Zimbra 7 and even a Moderator has not clue what is wrong.

    I have done all the searching in the world on this issue and nothing works, guess that means my client is going to get MS Exchange as I have spent way to long on this project and have about 2 days to get it up and running to prove to them it works.
    Last edited by michael24; 05-30-2012 at 03:06 AM.

  9. #19
    Join Date
    Oct 2011
    Location
    jignesh_22_1990@yahoo.com
    Posts
    68
    Rep Power
    4

    Default

    Hi Michael
    Can you send me your logs on jignesh_22_1990@yahoo.com ?

  10. #20
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    4

    Default

    Where do you want the log files from?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •