Results 1 to 3 of 3

Thread: Problem upgeade zimbra 6 zmldapapplyldif failed

  1. #1
    Join Date
    Jun 2009
    Posts
    51
    Rep Power
    6

    Default Problem upgeade zimbra 6 zmldapapplyldif failed

    Hi all, I'm trying to upgrade from zimbra 6.0.9 to zimbra 6.0.16 on a centos 5.

    This is the package I'm trying to install:
    zimbra-core-6.0.16_GA_2998.RHEL5_64-20120404131711.x86_64.rpm

    The last messages are these:

    Code:
    Restoring existing configuration file from /opt/zimbra/.saveconfig/localconfig.xml...done
    Operations logged to /tmp/zmsetup.05302012-092604.log
    Upgrading from 6.0.9_GA_2686 to 6.0.16_GA_2998
    Stopping zimbra services...done.
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql...done.
    This appears to be 6.0.9_GA
    Checking ldap status...not running.
    Running zmldapapplyldif...failed.
    Checking ldap status...not running.
    Starting ldap...failed with exit code: 256.
    4fc5cc14 daemon: bind(7) failed errno=99 (Cannot assign requested address)
    4fc5cc14 slap_open_listener: failed on ldap://mailserver.localdomain:389
    UPGRADE FAILED - exiting.
    In the log i see

    Code:
    4fc5ca55 hdb_db_open: database "": recovery skipped in read-only mode. Run manual recovery if errors are encountered.
    I attach the full messages and log.

    Do you know how to fix it?
    May I give more info?
    Attached Files Attached Files

  2. #2
    Join Date
    Jun 2009
    Posts
    51
    Rep Power
    6

    Default

    I forgot this, from /tmp/zmsetup.05302012-093918.log

    Code:
    Wed May 30 09:39:20 2012 Upgrading from 6.0.9_GA_2686 to 6.0.16_GA_2998
    Wed May 30 09:39:20 2012 Stopping zimbra services...
    Wed May 30 09:39:20 2012 *** Running as zimbra user: /opt/zimbra/bin/zmcontrol stop
    Host mailserver.localdomain
            Stopping stats...Done.
            Stopping mta...Done.
            Stopping spell...Done.
            Stopping snmp...Done.
            Stopping archiving...Done.
            Stopping antivirus...Done.
            Stopping antispam...Done.
            Stopping imapproxy...Done.
            Stopping memcached...Done.
            Stopping mailbox...Done.
            Stopping logger...Done.
            Stopping ldap...Done.
    Wed May 30 09:39:21 2012 done.
    Wed May 30 09:39:21 2012 Verifying /opt/zimbra/conf/my.cnf
    Wed May 30 09:39:22 2012 Starting mysql...
    Wed May 30 09:39:22 2012 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Starting mysqld...done.
    Wed May 30 09:39:32 2012 done.
    Wed May 30 09:39:33 2012 This appears to be 6.0.9_GA
    Wed May 30 09:39:33 2012 Checking ldap status...
    Wed May 30 09:39:33 2012 *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Wed May 30 09:39:34 2012 not running.
    Wed May 30 09:39:34 2012 Running zmldapapplyldif...
    Wed May 30 09:39:34 2012 *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    IO::Socket::INET: connect: No route to host at /opt/zimbra/libexec/zmldapapplyldif line 122.
    Wed May 30 09:40:17 2012 failed.
    Wed May 30 09:40:17 2012 Checking ldap status...
    Wed May 30 09:40:17 2012 *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Wed May 30 09:40:17 2012 not running.
    Wed May 30 09:40:17 2012 Starting ldap...
    Wed May 30 09:40:17 2012 *** Running as zimbra user: /opt/zimbra/bin/ldap start
    Failed to start slapd.  Attempting debug start to determine error.
    4fc5cf06 daemon: bind(7) failed errno=99 (Cannot assign requested address)
    4fc5cf06 slap_open_listener: failed on ldap://mailserver.localdomain:389
    
    Wed May 30 09:40:54 2012 failed with exit code: 256.
    Wed May 30 09:42:31 2012 UPGRADE FAILED - exiting.

  3. #3
    Join Date
    Jun 2009
    Posts
    51
    Rep Power
    6

    Default

    Solved: there was the wrong address in /etc/hosts: 192.168.133 instead of 192.168.2.113.
    Thanks anyway.

Similar Threads

  1. Replies: 658
    Last Post: 04-04-2014, 10:01 AM
  2. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  3. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 09:21 AM
  4. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 01:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •