Results 1 to 2 of 2

Thread: Outgoing SMTP Authentication - External Relay - Won't authenticate

Hybrid View

  1. #1
    Join Date
    Jul 2012
    Posts
    2
    Rep Power
    3

    Default Outgoing SMTP Authentication - External Relay - Won't authenticate

    We're having a super tough time setting up outgoing SMTP Authentication. We've followed the wiki at http://http://wiki.zimbra.com/wiki/O...Authentication with no luck. We've searched these forums also following these directions and via googled up and down and not found anything that helps resolve our issue.

    No matter what we've tried, we can't get postfix to even attempt to authenticate. This is what we end up with in our log files:

    Code:
    Jul 13 07:06:16 postmaster postfix/smtp[25682]: 81E50C202AF: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.47, delays=0.01/0.01/0/0.44, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as E66C9C202B0)
    Jul 13 07:06:16 postmaster postfix/qmgr[25681]: 81E50C202AF: removed
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_buf_get_ready: fd 15 got 30
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: < smtp.sendgrid.net[50.97.69.147]:25: 220 ************************
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: name_mask: disable_esmtp
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: name_mask: delay_dotcrlf
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: E66C9C202B0: enabling PIX workarounds: disable_esmtp delay_dotcrlf for smtp.sendgrid.net[50.97.69.147]:25
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: > smtp.sendgrid.net[50.97.69.147]:25: HELO postmaster.domain.net
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_fflush_some: fd 15 flush 29
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_buf_get_ready: fd 15 got 47
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: < smtp.sendgrid.net[50.97.69.147]:25: 250 mi15 Hello 10.60.208.15, nice to meet you
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: server features: 0x31000 size 0
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: > smtp.sendgrid.net[50.97.69.147]:25: MAIL FROM:< customer @ domain.net >
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_fflush_some: fd 15 flush 30
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_buf_get_ready: fd 15 got 99
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: < smtp.sendgrid.net[50.97.69.147]:25: 550 Cannot receive from specified address < customer @ domain.net >: Unauthenticated senders not allowed
    Jul 13 07:06:17 postmaster postfix/smtp[25687]: connect to subsystem private/bounce
    Does anyone have any suggests on what one should look at when after following the wiki and all of these other guides and the server won't even attempt to authenticate? We're desperate!

    Thanks for any thoughts, comments suggestions...

    Regards,

    Ajar

  2. #2
    Join Date
    Jul 2012
    Posts
    2
    Rep Power
    3

    Default

    I've finally solved this... and I hope I can save someone else some time by posting the solution. If you have already done everything in the wiki and are not seeing any attempt at authentication in your logs; check your main.cf file for:

    Code:
    start_tls = yes
    This was not in my default main.cf file, nor was it suggested by any of the wiki's, posts or other online tutorials.

    Cheers,

    Ajar

Similar Threads

  1. Replies: 2
    Last Post: 10-27-2010, 12:42 PM
  2. Replies: 0
    Last Post: 09-13-2009, 05:56 AM
  3. Replies: 1
    Last Post: 05-27-2009, 02:07 PM
  4. Problems with outgoing SMTP Relay
    By cyber_jack in forum Administrators
    Replies: 3
    Last Post: 01-10-2008, 03:38 PM
  5. Replies: 2
    Last Post: 10-10-2006, 01:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •