We're having a super tough time setting up outgoing SMTP Authentication. We've followed the wiki at http://http://wiki.zimbra.com/wiki/O...Authentication with no luck. We've searched these forums also following these directions and via googled up and down and not found anything that helps resolve our issue.

No matter what we've tried, we can't get postfix to even attempt to authenticate. This is what we end up with in our log files:

Code:
Jul 13 07:06:16 postmaster postfix/smtp[25682]: 81E50C202AF: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.47, delays=0.01/0.01/0/0.44, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as E66C9C202B0)
Jul 13 07:06:16 postmaster postfix/qmgr[25681]: 81E50C202AF: removed
Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_buf_get_ready: fd 15 got 30
Jul 13 07:06:17 postmaster postfix/smtp[25687]: < smtp.sendgrid.net[50.97.69.147]:25: 220 ************************
Jul 13 07:06:17 postmaster postfix/smtp[25687]: name_mask: disable_esmtp
Jul 13 07:06:17 postmaster postfix/smtp[25687]: name_mask: delay_dotcrlf
Jul 13 07:06:17 postmaster postfix/smtp[25687]: E66C9C202B0: enabling PIX workarounds: disable_esmtp delay_dotcrlf for smtp.sendgrid.net[50.97.69.147]:25
Jul 13 07:06:17 postmaster postfix/smtp[25687]: > smtp.sendgrid.net[50.97.69.147]:25: HELO postmaster.domain.net
Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_fflush_some: fd 15 flush 29
Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_buf_get_ready: fd 15 got 47
Jul 13 07:06:17 postmaster postfix/smtp[25687]: < smtp.sendgrid.net[50.97.69.147]:25: 250 mi15 Hello 10.60.208.15, nice to meet you
Jul 13 07:06:17 postmaster postfix/smtp[25687]: server features: 0x31000 size 0
Jul 13 07:06:17 postmaster postfix/smtp[25687]: > smtp.sendgrid.net[50.97.69.147]:25: MAIL FROM:< customer @ domain.net >
Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_fflush_some: fd 15 flush 30
Jul 13 07:06:17 postmaster postfix/smtp[25687]: vstream_buf_get_ready: fd 15 got 99
Jul 13 07:06:17 postmaster postfix/smtp[25687]: < smtp.sendgrid.net[50.97.69.147]:25: 550 Cannot receive from specified address < customer @ domain.net >: Unauthenticated senders not allowed
Jul 13 07:06:17 postmaster postfix/smtp[25687]: connect to subsystem private/bounce
Does anyone have any suggests on what one should look at when after following the wiki and all of these other guides and the server won't even attempt to authenticate? We're desperate!

Thanks for any thoughts, comments suggestions...

Regards,

Ajar